Menus in Firefox and Thunderbird are dark in the New Wave theme

Bug #335496 reported by Mat Tomaszewski on 2009-02-27
108
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
New
Undecided
Unassigned
New Wave
Wishlist
Unassigned
community-themes (Ubuntu)
Undecided
Unassigned
gnome-themes-ubuntu (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: community-themes

Top menu items in FF and TB are dark against dark background, therefore almost unreadable.

Mat Tomaszewski (mat.t.) on 2009-02-27
description: updated
Dilomo (ankere) wrote :

I'm working on New Wave theme for Firefox but I think that would not be much of a help here.

Pip (allred-b) wrote :

I can confirm this as well. I really like the new wave theme but the menu bar text needs to be white.

Dilomo (ankere) wrote :

Everybody that wants light text have to use New Wave Dark menus. Otherwise there is a Firefox theme (I'm attaching now) that can fix this as well as to provide better integration. The file I provide is still beta so it might contain bugs. Be free to report them.

Pip (allred-b) wrote :

Excellent firefox theme! This definitely fixed the theme issue for me.

nullack (nullack) wrote :

Marking community-themes invalid. New Wave is no longer in community themes, its in the default ubuntu set of themes for Jaunty. Adding new wave project.

Changed in gnome-themes-ubuntu:
status: New → Confirmed
Changed in community-themes:
status: New → Invalid
nullack (nullack) on 2009-03-22
Changed in anton:
status: New → Confirmed
Mario Limonciello (superm1) wrote :

The posted jar file appears to do the Right Thing for the most part, but all of my bookmarks toolbar are still dark :(

Dilomo (ankere) wrote :

What do you mean? Can you post a screenshot?

Changed in anton:
importance: Undecided → Wishlist
Dilomo (ankere) wrote :

I'm attaching the latest FF theme. It has some more improvements in the identyty notifications as well as the bookmarks organizer. I hope it will help a lot of ppl to fix their issues with FF.

New version still doesn't address bookmark's toolbar colors. Posting
screenshot

On Fri, Mar 27, 2009 at 12:31, Dilomo <email address hidden> wrote:

> I'm attaching the latest FF theme. It has some more improvements in the
> identyty notifications as well as the bookmarks organizer. I hope it
> will help a lot of ppl to fix their issues with FF.
>
> ** Attachment added: "newwave-FF-02.jar"
> http://launchpadlibrarian.net/24416690/newwave-FF-02.jar
>
> --
> Menus in Firefox and Thunderbird are dark in the New Wave theme
> https://bugs.launchpad.net/bugs/335496
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Mario Limonciello
<email address hidden>

Dilomo (ankere) wrote :

Your bookmarks toolbars are dark because they are not intended to be placed in the menubar but in the area below the addressbar that is light. I can't create (or at least don't know how) dynamic toolbar that changes color depending on backgrounds. As for now most ppl use the second method I will keep this version as current.

nullack (nullack) wrote :

The FF 02 jar has fixed the bug for me. Will be great to have this packaged fully into the new wave theme so when selecting on the new theme in the gnome themes list, all apps including FF are updated properly - as well as deselecting the new wave theme removes all custom app configs.

Merijn Schering (mschering) wrote :

The same problem exists in OpenOffice.Org. Isn't there a better way to fix this so it works across all apps?

Dilomo (ankere) wrote :

@ nullack
I don't know if this is possible but I agree that this would be the perfect solution.

@ Merijn
Nope, it is not possible as these programs use custom widgets that imitate gtk but not very well thus resulting in serious conflicts sometimes.

Dilomo (ankere) on 2009-03-30
Changed in anton:
status: Confirmed → Won't Fix
bono8106 (bono8106) wrote :

Dilomo,

The toolbars are customizable so their "intended" location is arguable. Firefox has allowed placing the bookmarks toolbar alongside the menus for a very long time, so I believe it is best to assume this is a feature and not a bug.

I think both Firefox and OpenOffice contain bugs in their immitation of gtk, and it seems to me that they either need to be patched by Ubuntu developers to support New Wave (and other custom-menu-color themes), or we all have to wait for the firefox/openoffice devs to fix this behavior sometime soon.

Is it feasible for Ubuntu to include a patched version of firefox that draws menus corrrectly under New Wave?

It would be nice to fix the toolbar colors as well, so they use the appropriate color depending on location, although that might be much more involved. Hopefully just fixing the menus is straightforward (for both firefox and openoffice).

Dilomo (ankere) wrote :

I agree about the toolbars but in default Ubuntu Installation they are below the navigation toolbar.

I think that the problematic apps should fix this issues not Ubuntu by making alternative versions.

Depending fg on bg color is not possible in FF as far as I know.

Kenneth Wimer (kwwii) wrote :

right, this is a bug in how FF uses the colors and styles in the gtkrc.

John Vivirito (gnomefreak) wrote :

Kenneth, This is much broader than firefox, OO.o has this problem as well as other apps. This should be fixed it the theme, As far as i can tell its only with this one theme. closing firefox task

Changed in firefox:
status: New → Invalid
Dilomo (ankere) wrote :

Excuse me John but can you tell me one pure gtk/gnome app that have this problem?

I have to say that the problem is not in my theme but in the inappropriate faking of FF and OO and any other program that imitates gtk with no luck. Btw all applications written for the Java platform also use the theme correctly so I don't agree with you.

John Vivirito (gnomefreak) wrote :

well to start with thunderbird and firefox handle themes different.
Look in a post above you will see OO.o has this issue as well here is the following comment link:

https://bugs.launchpad.net/ubuntu/+source/community-themes/+bug/335496/comments/14

Julius Karppi (julius-karppi) wrote :

I'm wondering why this problem persists with New Wave theme, when with Dust no such problem exists regardless of similar menu design?

pablomme (pablomme) wrote :

@Julius: some of the themes contain workarounds for firefox, e.g.:

- For Dust, see /usr/share/themes/Dust/gtk-2.0/gtkrc line 597
- For Dust Sand see /usr/share/themes/Dust\ Sand/gtk-2.0/gtkrc line 477

It should be possible to add workarounds to New Wave too, I suppose. I agree that the problem is with Firefox etc having custom widgets, but it is far easier to work around this problem in the theme than to fix all offending apps (which won't want to lose their internal themeability anyway; this would most likely be a "won't fix" from them).

Biji (biji) wrote :

For workaround, choose New Wave theme then click Customize and Choose New Wave dark menu
HTH

pablomme (pablomme) wrote :

@Biji: yes, but that doesn't fix things if your layout has the "bookmarks toolbar" on the menubar. That works under Dark Room though, so there is a way to work around that too. Plus what if you like the light menus better?

Biji (biji) wrote :

yup you're right.. btw i dont like dark menu of new wave....... it is too light ^^ should be darker

Dilomo (ankere) wrote :

If I had an opportunity to fix this I would have done it in the gtkrc file. If you think you can provide patch that works I would be very glad to see it.

I have tried the following methous but have commented them because they don't work:
#widget_class "MozillaGtkWidget*MenuBar" style :highest "newwave-menubar"#-mozilla"
#widget "MozillaGtkWidget*Menu*" style :highest "newwave-menu-item-mozilla"

Still a comparison with Dust is not acceptable as it has dark menus all over and comparison with dust sand is also not good because it have light bg for the menubar. The case of New Wave is specific and only fixably by Firefox coders or a theme that I have provided.

@Julius (and everyone who thinks this problem is in New Wave):

Isn't it obvious that the problem is that firefox (and OOo) treat the menubar items as menu items?

The problem is when the menubar has a light background and the menu has a dark background or vice versa. In this case, firefox and OOo put the 'menu style' text over whatever background is selected. These apps completely ignore 'menubar style' text colours...

Now, Dust - doesn't have different menubar/menu colours... New Wave Dark Menus also doesn't have a strong contrast between menubar and menu background. The only way to 'fix' New Wave is to make it New Wave Dark Menus. This bug should definitely be marked as 'Confirmed' for firefox. It is a very long standing bug that was first made obvious by the many 'vista' styled themes a couple of years ago.

At least we can fix firefox with userchrome I suppose, OOo pisses me off more.

Just to summarise: There is NO possible work around except to change the background colour of the menubar or the menu so that they both work with the same foreground colour. (As the talented author did for New Wave Dark Menus).

Dilomo (ankere) on 2009-04-27
Changed in firefox:
status: Invalid → New
Kido (greasedbolt) wrote :

@pablomme: That doesn't work for Dust.

@Daniel: Firefox will have the Add Bookmark pop-up broken (black text on black bg) as in the Dust theme if you use dark menus. But at least the menubar will look OK.

The best way to handle this, IMO, is to make a FF/TB theme.

Johan van Dijk (johanvandijk) wrote :

The menu text in Thunderbirds Lightning alarm window is unreadable if you use the "New Wave Dark Menus" theme.

See this thread at the MozillaZine forums for screenshots and an explanation:
http://forums.mozillazine.org/viewtopic.php?f=46&t=1228855

I'm not sure this is the right place mention it, maybe I should file a new bug?

Dilomo (ankere) wrote :

I think you should report another bug concerning Thunderbird but the issues involved may be the same as here:
https://bugs.launchpad.net/anton/+bug/271223

Johan van Dijk (johanvandijk) wrote :

Should I create a new bug report for Thunderbird? Or a new bug for community-themes?
Do you need more information?
Please explain.

Dilomo (ankere) wrote :

I think that you should report the problem in the thunderbird bugzilla as well as in the New Wave project.

Thomas Wood who works on the gnome themes writes:

>While we're on the topic of GTK/Firefox integration however, I would
>like to raise a pet bug of my own. It seems that Firefox will use the
>text colour for the menubar items from the menu item object. However,
>when the items are not selected, they should use the fg colour from the
>menubar, since non-selected menu items are transparent. This causes
>problems in themes where the menu bar is a different colour to menu
>items, and can cause the menu items in the menu bar to become invisible
>because of the mismatch in colours.

I can do this. It'll hopefully be possible for 3.5.

Created an attachment (id=381902)
Patch

This does it. New Wave (which is the most awesome theme I've ever seen, even though its incomplete) shows this bug, and it's a default Ubuntu theme.

m-c is open for general checkins, right?

In , Dao (dao) wrote :

(In reply to comment #3)
> m-c is open for general checkins, right?

no, you need explicit approval for m-c or for 1.9.1.

This bug's priority relative to the set of other polish bugs is:
P1 - Polish issue that appears in the main window, or is something that the user may encounter several times a day.

Brewster Malevich (brews) wrote :

The Dust theme ~does~ have a similar problem in places.

Another eg: In Firefox: Click on the website icon (I don't know what its called) to the left of the web address in the navigation bar... This brings up a brief bit about identity information, but the user is unable to read the text because of its color.

In , thos (thos) wrote :

Thanks for fixing this Michael, much appreciated! We're going to try and include this patch in Moblin, as we are affected by this issue with our theme as well.

Jamie Bennett (jamiebennett) wrote :

Brews its called the favicon.

Someone has actually submitted a fix for this - see https://bugzilla.mozilla.org/show_bug.cgi?id=496454

Only thing is... I can't figure what ruddy version the patch got assigned to. [mutter]svn... bzr... git... hg... grrrrrrr[/mutter]

Just a quick update - I noticed (on ubuntu at least) that OOo is now fixed. They have set it up so that the menubar text - is displayed using the colour indicated for the menubar rather than for the popup menu items. It would be great if FF could also fix this. Hopefully the patch Stephen referred to works nicely.

mij (miguel-hermo) wrote :

I confirm that this bug is also affecting netBeans 6.7.1

If you try the latest 3.6 rc (Namaroko) the issue is corrected.

@mij: netBeans has nothing to do with Firefox. This would have to be raised as a separate bug.

This bug is still present in netBeans 6.8, freshly downloaded and installed from java.sun.com.

Tom Harris (tom-harris) on 2010-06-22
Changed in gnome-themes-ubuntu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.