phpize is missing from program.d database (update-alternatives usage in postinst)

Bug #186626 reported by Victor Stinner on 2008-01-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
command-not-found (Ubuntu)
Medium
Casual

Bug Description

Binary package hint: command-not-found

Hi, command-not-found is a great program but it doesn't know all Ubuntu programs. I tried to rebuild programs.d/*db database but phpize is still missing.

I'm using Ubuntu Gustsy with command-not-found version 0.2.8ubuntu2.

Note: UnifiedDataExtractor/apt/sources.list is :
deb http://archive.ubuntu.com/ubuntu/ feisty main restricted universe multiverse
instead of
deb http://archive.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse

The program phpize is missing, it comes from Ubuntu Gutsy main packages, package php5-dev. The problem may comes from Debian alternatives tool:

$ ls -l /usr/bin/phpize
lrwxrwxrwx 1 root root 24 2008-01-28 13:22 /usr/bin/phpize -> /etc/alternatives/phpize
$ ls -l /etc/alternatives/phpize
lrwxrwxrwx 1 root root 16 2008-01-28 13:22 /etc/alternatives/phpize -> /usr/bin/phpize5
$ ls -l /usr/bin/phpize5
-rwxr-xr-x 1 root root 4122 2008-01-10 10:38 /usr/bin/phpize5

Michael Vogt (mvo) on 2008-03-07
Changed in command-not-found:
importance: Undecided → Medium
status: New → Confirmed
Michael Vogt (mvo) wrote :

It looks like the alternatives parser does not understand the folllowing fragment:

for i in php-config phpize; do
        update-alternatives \
          --install /usr/bin/"$i" $i /usr/bin/"$i"5 50 \
          --slave /usr/share/man/man1/"$i".1.gz "$i".1.gz /usr/share/man/man1/"$i"5.1.gz
done

(from php5-dev.postinst)

Rolf Leggewie (r0lf) wrote :

Victor, still a problem with the latest version in Jaunty? Do you have a test case?

Michael Vogt (mvo) on 2009-06-26
summary: - phpize is missing from program.d database
+ phpize is missing from program.d database (update-alternatives usage)
summary: - phpize is missing from program.d database (update-alternatives usage)
+ phpize is missing from program.d database (update-alternatives usage in
+ postinst)
andypiper (andypiperuk) wrote :

Still an issue in Karmic AFAICT. When php5-devel is not installed, running aptitude install phpize returns command not found without any suggestion as to which package it should be in.

Casual (doc-octopus) on 2011-12-27
Changed in command-not-found (Ubuntu):
assignee: nobody → Casual (doc-octopus)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers