Incorrect message if /snap/bin is not in PATH

Bug #1769088 reported by Michael Vogt on 2018-05-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
command-not-found (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
 * Usability of snap recommendations degrated

[Test Case]
 1. Remove /snap/bin from PATH
 2. snap install corebird
 3. run "corebird"
 4. observe command-not-found suggesting to install corebird

 5. install fixed c-n-f
 6. observe that c-n-f suggests to run corebird from /snap/bin

[Regression Potential]
 * very low

[ORIGINAL REPORT]

When the user installs a snap (like slack) but does not have /snap/bin in PATH the message is very confusing:
```
$ sudo snap install slack
...
$ slack

Command 'slack' not found, but can be installed with:
sudo apt install slack
```

The fix is that /snap/bin needs to be considered by c-n-f so that it can say:
```
command 'slack' is available in '/snap/bin/slack'
The command could not be located because '/snap/bin' is not included in the PATH environment variable.
slack: command not found
```

Related branches

Michael Vogt (mvo) on 2018-05-04
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package command-not-found - 18.10.0~pre1

---------------
command-not-found (18.10.0~pre1) cosmic; urgency=medium

  * first cosmic build

 -- Michael Vogt <email address hidden> Mon, 07 May 2018 07:35:23 +0200

Changed in command-not-found (Ubuntu):
status: New → Fix Released

Hello Michael, or anyone else affected,

Accepted command-not-found into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/command-not-found/18.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in command-not-found (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Since this also basically refreshes the db's, I would like the package verification to include some arbitrary dogfooding of command-not-found for various deb-based applications.

Nafallo Bjälevik (nafallo) wrote :

nafallo@wendigo:~$ sl

Command 'sl' not found, but can be installed with:

sudo apt install sl

127 nafallo@wendigo:~$ slack

Command 'slack' not found, but can be installed with:

sudo snap install slack
sudo apt install slack

See 'snap info slack' for additional versions.

127 nafallo@wendigo:~$ spotify

Command 'spotify' not found, but can be installed with:

sudo snap install spotify

Nafallo Bjälevik (nafallo) wrote :

not sure if that's enough for verification?

Brian Murray (brian-murray) wrote :

 $ weechat

Command 'weechat' not found, but can be installed with:

sudo apt install weechat-curses

 $ discord

Command 'discord' not found, but can be installed with:

sudo snap install discord

 $ 0ad

Command '0ad' not found, but can be installed with:

sudo snap install 0ad
sudo apt install 0ad

See 'snap info 0ad' for additional versions.

 $ sudoku

Command 'sudoku' not found, but can be installed with:

sudo apt install sudoku

Seems good to me too.

 $ apt-cache policy command-not-found
command-not-found:
  Installed: 18.04.5
  Candidate: 18.04.5

tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package command-not-found - 18.04.5

---------------
command-not-found (18.04.5) bionic; urgency=medium

  * Ensure /snap/bin is in PATH when checking for commands
    (LP: #1769088)

 -- Michael Vogt <email address hidden> Sat, 05 May 2018 08:41:03 +0200

Changed in command-not-found (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for command-not-found has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers