Ubuntu

doesn't cope with db format transition

Reported by Colin Watson on 2007-08-20
28
Affects Status Importance Assigned to Milestone
command-not-found (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: command-not-found

Python recently moved to db4.6. After this, any unknown command produces:

Unable to open binary database %s: %s /usr/share/command-not-found/programs.d/all-multiverse.db (22, 'Invalid argument')
Unable to open binary database %s: %s /usr/share/command-not-found/programs.d/all-main.db (22, 'Invalid argument')
Unable to open binary database %s: %s /usr/share/command-not-found/programs.d/powerpc-multiverse.db (22, 'Invalid argument')
Unable to open binary database %s: %s /usr/share/command-not-found/programs.d/all-restricted.db (22, 'Invalid argument')
Unable to open binary database %s: %s /usr/share/command-not-found/programs.d/all-universe.db (22, 'Invalid argument')
Unable to open binary database %s: %s /usr/share/command-not-found/programs.d/powerpc-main.db (22, 'Invalid argument')
Unable to open binary database %s: %s /usr/share/command-not-found/programs.d/powerpc-restricted.db (22, 'Invalid argument')
Unable to open binary database %s: %s /usr/share/command-not-found/programs.d/powerpc-universe.db (22, 'Invalid argument')

(ignoring the buggy error message, already filed as bug 131435)

Something needs to cope with upgrading the db format, preferably on the fly; I believe that Berkeley DB has an 'upgrade' method for this.

Jussi Kukkonen (jku) wrote :

Confirming. I'm seeing this too on a fresh gutsy install.

Changed in command-not-found:
status: New → Confirmed
Áron Sisak (asisak) wrote :

Confirmed again, I think this should be fixed for the beta.

Changed in command-not-found:
importance: Undecided → Medium
Hasse Bylov (hassebylov) wrote :

Yep, me too. It also appears when I type in an unknown command ("command not found") in a prompt...

HASSAN SAID OMAR (sayyidhassan) wrote :

i have tred to restart the system several times,but the same eroors keep coming,and am not able either to start the X system nor send any commands

Zygmunt Krynicki (zkrynicki) wrote :

Hassan: could you please be more specific? Please include: what command triggers the error? Why can't you start X?

the error comes automatically during startup,first there is a message about doing a disk check,after the disk check(which does not complete to 100%),the errors surfaces.this takes me to root@home,where upon inputting start X command,the same error

Unable to open binary database %s: %s /usr/share/command-not-found/programs.d

Zygmunt Krynicki <email address hidden> wrote: Hassan: could you please be more specific? Please include: what command
triggers the error? Why can't you start X?

--
doesn't cope with db format transition
https://bugs.launchpad.net/bugs/133691
You received this bug notification because you are a direct subscriber
of the bug.

---------------------------------
Shape Yahoo! in your own image. Join our Network Research Panel today!

I'm able to replicate this message as well. Here's my system info and error message:

Distro: Kubuntu Gutsy 7.10 (latest updates applied)
Arch: i386

manchicken@thepea:~/.kde/share/apps/kmail$ ll
Unable to open binary database /usr/share/command-not-found/programs.d/all-multiverse.db: (22, 'Invalid argument')
Unable to open binary database /usr/share/command-not-found/programs.d/all-main.db: (22, 'Invalid argument')
Unable to open binary database /usr/share/command-not-found/programs.d/all-restricted.db: (22, 'Invalid argument')
Unable to open binary database /usr/share/command-not-found/programs.d/all-universe.db: (22, 'Invalid argument')
Unable to open binary database /usr/share/command-not-found/programs.d/i386-main.db: (22, 'Invalid argument')
Unable to open binary database /usr/share/command-not-found/programs.d/i386-multiverse.db: (22, 'Invalid argument')
Unable to open binary database /usr/share/command-not-found/programs.d/i386-restricted.db: (22, 'Invalid argument')
Unable to open binary database /usr/share/command-not-found/programs.d/i386-universe.db: (22, 'Invalid argument')
bash: ll: command not found

Heitzso (heitzso) wrote :

I confirm on my gutsy system (current as of yesterday, Sept 12th).
Open up gnome-terminal and at the command prompt enter a non-existant command such as:
       lss
which yields
      Unable to open binary database /usr/share/command-not-found/programs.d/all-main.db: (22, 'Invalid argument')
      ... etc. ...

Evan Carroll (evancarroll) wrote :

confirmed sept. 13, deleted-binary database and reinstalled c-n-f-data, still no joy.

confirmed also here...

Rafael Sachetto (rsachetto) wrote :

fixed here in the version 0.28

How to fix the problem so as to access my documents?

Sachetto <email address hidden> wrote: fixed here in the version 0.28

--
doesn't cope with db format transition
https://bugs.launchpad.net/bugs/133691
You received this bug notification because you are a direct subscriber
of the bug.

---------------------------------
Pinpoint customers who are looking for what you sell.

Jussi Kukkonen (jku) wrote :

Last updates to command-not-found and command-not-found-data indeed fix this. Changing status accordingly.

Hassan, you're probably seeing another bug and should file another report.

Changed in command-not-found:
status: Confirmed → Fix Released

at last i got the solution to my problem at this forum:

http://forum.ubuntu-fr.org/viewtopic.php?pid=1149184

thanks

Jussi Kukkonen <email address hidden> wrote: Last updates to command-not-found and command-not-found-data indeed fix
this. Changing status accordingly.

Hassan, you're probably seeing another bug and should file another
report.

** Changed in: command-not-found (Ubuntu)
       Status: Confirmed => Fix Released

--
doesn't cope with db format transition
https://bugs.launchpad.net/bugs/133691
You received this bug notification because you are a direct subscriber
of the bug.

---------------------------------
Shape Yahoo! in your own image. Join our Network Research Panel today!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers