Ubuntu

grep -R doesn't automatically search amazon

Reported by akeane on 2012-09-24
978
This bug affects 217 people
Affects Status Importance Assigned to Milestone
command-not-found (Ubuntu)
Undecided
Stephen Michael Kellat

Bug Description

Dear "root owning" overlords,

When using grep recursively I only get local results:

grep -R fish_t /home/noob/fish_game/*

/home/noob/fish_game/fish.h: struct fish_t {
/home/noob/fish_game/fish.c: struct fish_t eric_the_ fish;

or worse:

grep -R shark_t /home/noob/fish_game/*

/home/noob/fish_game/fish.h: struct shark_t {
/home/noob/fish_game/fish.c: struct shark_t_t mark_sw;

I declare this a bug for two reasons:

1. The output is boring.
2. The terminal has more than 2 lines!!! It's an unefficient use of my screenspace.

I believe the reason for this is that the grep command only searches locally for things I am actually looking for, I kind of expect the results I get from my codebase and as such it removes any sense of mystery or something new and exciting to spice up my dull geek existence. That's boring, grep -R should also search amazon, so I get more exciting results such as:

Shark Season 1 Starring Steven Eckholdt, Nora Dunn, Patrick Fabian, et al.
Amazon Instant Video
to buy episodes: $1.99
to buy season: $34.99 ($1.59 per episode)

Watch instantly on your PC, Mac, compatible TV or device.
2.
Product Details
See Color & Size Options
NHL San Jose Sharks Primary Logo T-Shirt Men's by Reebok
$16.95 - $19.99

new from $16.95
(1)
Eligible for FREE Super Saver Shipping.
3.
Product Details
See Size Options
Shark Week Girls T-Shirt by Hot Topic
$22.50

See all 9,755 results

"struct shark_t" (See all 1,583 results)
1.
Product Details
See Size Options
D:fi D:struct Pliable Molding Creme by D:Fi
$23.50 $17.05 ($11.37/100 g)

new from $10.50
Only 7 left in stock - order soon.
(35)
Eligible for FREE Super Saver Shipping.
2.
Product Details

Take 'N' Play Anywhere Activities Activity Tin - Robo-struct by Patch Products
$11.99 $8.77

new from $3.99
Order in the next 1 hour and get it by Tuesday, Sep 25.
Only 12 left in stock - order soon.
(1)
Eligible for FREE Super Saver Shipping.
Manufacturer recommended age: 4 - 9 Years
3.
Product Details

d:fi d:struct 2.65 oz by AMERICAN CREW

This is less dull and also maximises the use of my terminal and hence increases my productivity.

Please can you change the grep warez to have this feature, and just install it on my machine while I'm down the pub, after all you do "erm, have root", so it should be easy for you to do :-)

Thanks Ubuntu devs!!!

Sent from my Unity device, (which is why it took several glacial ages and a couple of eras to get it done)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-terminal 3.0.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Mon Sep 24 22:20:29 2012
ExecutablePath: /usr/bin/gnome-terminal
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
SourcePackage: gnome-terminal
UpgradeStatus: No upgrade log present (probably fresh install)

akeane (akeane) wrote :
Jeremy Bicha (jbicha) on 2012-09-24
Changed in gnome-terminal (Ubuntu):
status: New → Invalid
Dimitri John Ledkov (xnox) wrote :

command-not-found should totally have ubuntu software centre integration for things like this:

you@home:~$ portal2
base: portal2: command not found...
Would you like to buy and install Portal 2 via Steam for $7.49 ? [Y/n]

above taken from http://lwn.net/Articles/517454/

akeane (akeane) wrote :

yep, and <TAB><TAB> only gives:

akeane@awesome-haX0r:~$
Display all 2717 possibilities? (y or n)

Should give:

akeane@awesome-haX0r:~$
Display all 3,141,596,254 results possibilities? (y or n)
Do you feel lucky? (y)

no

Jeremy Bicha (jbicha) wrote :

akeane, please stop with the snark.

We're actually trying to fix bugs and make Ubuntu better on Launchpad.

akeane (akeane) wrote :

>akeane, please stop with the snark.

Why is my bug report a "snark", I have in good faith reported what I consider a bug with Ubuntu, namely the functionality that is being added to the GUI is not also being consistently added to the CLI tools that some many of us rely on.

You have chosen to mark my bug report "invalid", which is your total prerogative and I have total respect for you doing that.

I am saddened, however, you have chosen to resort to personal insults (being labeled a snark nearly made my monocle drop out!), rather than focusing on the technical issues presented.

>We're actually trying to fix bugs and make Ubuntu better on Launchpad.

I'm trying to make Ubuntu better too...

Would it help if I hacked up grep myself and posted the patch?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in command-not-found (Ubuntu):
status: New → Confirmed
Changed in command-not-found (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Opinion
Changed in ayatana-design:
status: New → Opinion
Paul Sladen (sladen) wrote :

akeane: if you'd be happy to pinpoint this request to specifically focus on requesting surfacing of the 'unity-lens-applications' backend output via 'command-not-found', I'd be happy to help you do that. (At the moment, it's a bit hard to do much else as a very useful idea at the centre is diluted).

Of course, yes, the other way is to describe what you're after with a patch, and we can focus the bug report on exactly what the patch is trying to perform.

Changed in ayatana-design:
status: Opinion → Invalid
Changed in command-not-found (Ubuntu):
status: Opinion → Invalid
Paul Tagliamonte  (paultag) wrote :

It's funny, calm down everyone.

Soul-Sing (soulzing) wrote :

LOL (sorry!)

TROLOLOLOLOLOLOLOLOLOL

This is NOT funny. I want ads in my terminal.

summerishere (culpritdoctor) wrote :

Hi Engineering Team

Please let me know if there is any update on this.

grep --universe might be a better shortcut ;)

Matt C (mvc1095) wrote :

grep --universe would be a good shortcut, except that i think we all agree this important functionality should be present by default. showing these results from places other than my local computer should be opt-out! how about grep --no-universe ?

Mark Rose (markrose) wrote :

How are we command line jockeys supposed to support Canonical without ads in our terminals? Couldn't they be added to the screen command?

tom livingston (tlivingston) wrote :

This would be consistent with upstream's core values.

LocalWiki Team (localwiki) wrote :

+1 for grep --no-universe shortcut, and search everything by default

Kurt Nelson (kurtisnelson) wrote :

I agree, all URLs in gnome-terminal should have referral codes appended to help support Ubuntu.

Jeremy Bicha (jbicha) wrote :

> I agree, all URLs in gnome-terminal should have referral codes appended
> to help support Ubuntu.

That's a cool idea. Do you have a patch for that?

Also present on quantal.

command-not-found:
  Installed: 0.3ubuntu3
  Candidate: 0.3ubuntu3
  Version table:
 *** 0.3ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

command-not-found-data:
  Installed: 0.3ubuntu3
  Candidate: 0.3ubuntu3
  Version table:
 *** 0.3ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

gnome-terminal:
  Installed: 3.5.90-0ubuntu1
  Candidate: 3.5.90-0ubuntu1
  Version table:
 *** 3.5.90-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status

GlitchMr (glitchmr) wrote :

I agree with this change, but I have feeling it wouldn't be backwards compatible.

Would it be possible to check if terminal is real tty (so it's real user and not pipes used by UNIX scripts) and use --no-universe by default if it is piped into other process?

Benjamin Kerensa (bkerensa) wrote :

Perhaps we could generate ascii versions of the Amazon Product Images and have them displayed in a 75x75 square format just below the prompt ;)

The grep results you suggested are a good start, but Ubuntu really cares about users having the best advertising experience possible, so grep results should provide more detail:

    - User reviews of the file matches

    - Five-star ratings

    - "People who searched for this regexp also searched for"

And what about Empathy?

Aron Burrell (litui) wrote :

To really add power to this, support match inversion on -v: "Users who searched for anything that doesn't match this regexp also excluded the following products from similar searches..."

MercuryCC (mercurycc) wrote :

Should do the same to the search functionality in gedit/vim/emacs. When I say "search", I really don't mean plain text search. It would be nice if I can get results about everything that is related, except if I explicitly said I only want Amazon product pages or Wikipedia entries.

I totally don't want to open up Google to do these searches. That is not very efficient is it.

Colin Godsey (crgodsey) wrote :

This all sounds great, but Amazon does have sponsored listings and I'm sure they would not be pleased if these were left out or somehow ended up on the first page of a multi-page result.

Could an interstitial be possible with ncurses?

Kasimir Gabert (kasimir-g) wrote :

I don't see how I can get the full Ubuntu 12.10 integrated experience without this.

I think "ls" would really benefit from this fantastic strategy as well. I'm sure Mark Shuttleworth would agree that when I run "ls /root" I'm not just interested in seeing his files, I'm also truly interested in purchasing some Green Light Organic Rooting Hormone - 2 oz 06920A.

Leo Unglaub (leo-unglaub) wrote :

@kasimir-g: You forgetting something about the ls /root command. It's all transfered to canonical so if you loose your files, you can get the files and the amazon suggesions back from canonical. It's a double feature, free ads and a backup system.

Make sure not to leave "ps" out, I would really love to see some Amazon products when I decide to look at currently running processes. :-(

Tony Narlock (borneo) wrote :

"Help support Ubuntu... Enable integration with third party services"

checkbox in ubiquity installer.

And call it a day.

Never let go of your base.

I agree with Tony Narlock. After all, you only have to run sudo apt-get purge unity-lens-shopping unity-scope-musicstores unity-webapps-common && rm ~/.local/share/applications/Amazonwwwamazoncom.desktop in order to get rid of all the search suggestions and web apps. If those three packages wouldn't be installed by default and the .desktop file wouldn't be created, no one would mind anymore. A checkbox just like the fluendo decoder would be a great idea. You could even come up with a description of how it might be useful etc. Just keep it out of the ubuntu-desktop and unity packages.

Jon (three18ti) wrote :

I agree with Tony Narlock. Hell, even if the checkbox was checked by default.

Kevin, I shouldn't have to remove packages that I didn't want put there in the first place.

Also, I'd like to see this functionality added to top. Simply put, when I'm looking at top, what I really want to be looking at as adds.

J Cord (j7cord) wrote :

Some one has posted a link to this bug report on readit, just a few minutes ago. I think you will all be famous soon

Paul Sladen (sladen) wrote :

@Leo: Yes, you /can/ request backup of your data "in case you loose [sic] your files", by enabling Ubuntu One:

  https://one.ubuntu.com/

Paul Sladen (sladen) wrote :

@Benjamin Kerensa: Regarding the "could generate ascii versions of the Amazon Product Images" idea, this would already be possible to do without needing to convert to ASCII art. The text-browser 'w3m' can display image overlays when running inside 'xterm', see the screenshots halfway down:

  http://www.howtogeek.com/103574/how-to-browse-from-the-linux-terminal-with-w3m/

Extender (msveshnikov) on 2012-09-26
Changed in ayatana-design:
status: Invalid → Confirmed
Paul Sladen (sladen) on 2012-09-26
Changed in ayatana-design:
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Paul Sladen (sladen) on 2012-09-26
affects: grep (Debian) → grep (Ubuntu)
Changed in grep (Ubuntu):
status: New → Confirmed
Paul Sladen (sladen) on 2012-09-26
no longer affects: grep (Ubuntu)
Changed in gnome-terminal (Ubuntu):
status: Invalid → Opinion
Changed in command-not-found (Ubuntu):
status: Invalid → Opinion
Changed in ayatana-design:
status: Invalid → Opinion
Changed in gnome-terminal (Ubuntu):
status: Opinion → Invalid
Changed in command-not-found (Ubuntu):
status: Opinion → Invalid
Changed in ayatana-design:
status: Opinion → Invalid
Shiki (shiki) wrote :

I like the Kandlu redor too. I want to support them. Ads all the way.

after a boring day I just got a link to this thread, thank you for making me laugh :D

Federico Lucifredi (f2) wrote :

Good one, well played!

RastaSean (sean-rastasean) wrote :

pre-emptively changed status.

Changed in ayatana-design:
status: Invalid → New
status: New → Opinion
J Cord (j7cord) wrote :

I have had time to think about this today and I really am warming up to the idea. The plan to upstream this to Grandpa Debian is wise and as I have sid on another hard drive I will check latter today for the fix from the debian devs. Please though give me just a minute of your time. I don't think this goes quite far enough. Therefore I suggest including the Compiz Team to assist. What I am thinking of is a Terminal Mall. I would like the compiz cube . The 2d terminal is so passe. We could then by utilizing the 4 cube faces and top and bottom caps , a real mall type experience. This could segment different vendors to a particular face of the cube , I like organization.
For example hardware vendors have a plane, amazon ,etc, their own, google wallet , paypal, my bank (better Mark's bank) all on their own plane. We should however keep one of the planes available for terminal commands so we can choose to or not to run the mall. We could use the cube gears in the center of the cube mall and let the movie people have it to send ads with hypnotizing subliminal messages, this may help to finally make those people happy. I know it's late in 12.10's cycle, but possibly with a big push , who knows?

I have a name for this. I would call it ubuntu gnome enhanced terminal spacial planes asci mall. We would shorten the actual command to ' su u-get-spam . It must be run as root as I don't want Mark to have to roam around root all alone.

Best Wishes

akeane (akeane) wrote :

jcord, I really like your hypercube mall terminal idea, but alas I fear it will run slowly on my Commodore-64 :-(

Mr Shuttleworth's grep --universe idea is a far more pragmatic solution for us users who can't afford the latest Cray
supercomputer to do our grepping with.

For the moment I have a simple shell script wrapper to workaround the bug:
___________
!#/bin/sh

# terminal-ad (C) 1984 akeane conglomerates Inc
# LICENSE: One of the GPL thingies, full text here: http:// interwebz, don't steal this code and post to BBS!!!

if [$USER != "root"]
then
        echo "Warning: Must be Mark!"
        exit :-(
fi

telnet www.amazon.com 80 &
<<<HERE
get #hl=en&output=search&sclient=psy-ab&q=$*
>>>THERE

exec $*
___________

Granted, it's not very elegant or even works, but it'll do for now, it's gonna take ages to patch all of the GNU tools!

gajm (gajm-deactivatedaccount) wrote :

For the time being, +1 for the wrapper, let's just add it as an alias by default.

nadrimajstor (ipejic) wrote :

One can use libferris to mount websites as a virtual file systems.

J Cord (j7cord) wrote :
Download full text (5.3 KiB)

Dear akeane

I must defer to your judgement on this, however, I do think your code
is quite elegant, also clean and compact. (By the way did they make
some new rule that the code must also work ??? I may have been
napping.

Anyway as I feel your work is much more important than anything I am
doing here, I am sending along my Atari 1200xl and TRS80, in hopes you
can network them together with the c64 and proceed with your work.
Only problem is that the only cardboard box I have is serving as my
computer case. Be patient help is on the way!

(Your post brought back many good memories and I laughed almost to the
point of incontinence . Take care my friend.
Best Wishes

On Wed, Sep 26, 2012 at 12:33 PM, akeane <email address hidden> wrote:
> jcord, I really like your hypercube mall terminal idea, but alas I fear
> it will run slowly on my Commodore-64 :-(
>
> Mr Shuttleworth's grep --universe idea is a far more pragmatic solution for us users who can't afford the latest Cray
> supercomputer to do our grepping with.
>
> For the moment I have a simple shell script wrapper to workaround the bug:
> ___________
> !#/bin/sh
>
> # terminal-ad (C) 1984 akeane conglomerates Inc
> # LICENSE: One of the GPL thingies, full text here: http:// interwebz, don't steal this code and post to BBS!!!
>
> if [$USER != "root"]
> then
> echo "Warning: Must be Mark!"
> exit :-(
> fi
>
> telnet www.amazon.com 80 &
> <<<HERE
> get #hl=en&output=search&sclient=psy-ab&q=$*
>>>>THERE
>
> exec $*
> ___________
>
> Granted, it's not very elegant or even works, but it'll do for now, it's
> gonna take ages to patch all of the GNU tools!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1055766
>
> Title:
> grep -R doesn't automatically search amazon
>
> Status in Ayatana Design:
> Opinion
> Status in “command-not-found” package in Ubuntu:
> Invalid
> Status in “gnome-terminal” package in Ubuntu:
> Invalid
>
> Bug description:
> Dear "root owning" overlords,
>
> When using grep recursively I only get local results:
>
> grep -R fish_t /home/noob/fish_game/*
>
> /home/noob/fish_game/fish.h: struct fish_t {
> /home/noob/fish_game/fish.c: struct fish_t eric_the_ fish;
>
> or worse:
>
> grep -R shark_t /home/noob/fish_game/*
>
> /home/noob/fish_game/fish.h: struct shark_t {
> /home/noob/fish_game/fish.c: struct shark_t_t mark_sw;
>
> I declare this a bug for two reasons:
>
> 1. The output is boring.
> 2. The terminal has more than 2 lines!!! It's an unefficient use of my screenspace.
>
> I believe the reason for this is that the grep command only searches
> locally for things I am actually looking for, I kind of expect the
> results I get from my codebase and as such it removes any sense of
> mystery or something new and exciting to spice up my dull geek
> existence. That's boring, grep -R should also search amazon, so I get
> more exciting results such as:
>
> Shark Season 1 Starring Steven Eckholdt, Nora Dunn, Patrick Fabian, et al.
> Amazon Instant Video
> to buy episodes: $1.99
> to buy season: $34.99 ($1.59 per episode)
>
> ...

Read more...

Changed in ayatana-design:
status: Opinion → Invalid
akeane (akeane) wrote :

Salutations jcord,

I am looking forward to receiving the Atari and TRS80, you sir are a scholar and gent and I thank you for your kind donation.

I shall network these machines together with the C-64 and make a beowulf cluster, I will have a full 24 bits at my disposal and finally be able to finish my hacking of the GNU wares to integrate the amazon functionality and be able to close this important bug report once and for all :-)

I finished hacking grep, but now all I get is:

google struct shark_t /home/noob/van_halen/*

Search
About 80,500,000 results (0.12 seconds)

    Web
    Images
    Maps
    Videos
    News
    Shopping

More

    Search near…

Search Options

        The web
        Pages from the UK

More search tools
Search Results

    grep -R doesn't automatically search amazon - Launchpad.net
    https://bugs.launchpad.net/ubuntu/+source/gnome.../1055766
    2 days ago – ... /home/noob/fish_game/fish.h: struct shark_t { /home/noob/fish_game/fish.c: struct shark_t_t mark_sw; I declare this a bug for two reasons: 1.
    grep doesn't search amazon - All Things Unix | DSLReports Forums
    www.dslreports.com/forum/r27562292-grep-doesn-t-search-amazon
    16 hours ago – grep -R shark_t /home/noob/fish_game/* /home/noob/fish_game/fish.h: struct shark_t { /home/noob/fish_game/fish.c: struct shark_t_t mark_sw; ...
    Shark Social Structure
    www.sharks-world.com › Shark Information
    Sharks are loners and there is no other social structure than survival for the fittest. Even pups have to take care of

D'oh

costales (costales) wrote :

+1 for @akeane! This is one of the best bugs that I've ever seen :)
@canonical: Just think on it, please. Thanks in advance!

Stuart Prescott (themill) wrote :

It would be shortsighted to do this only for grep.

A better approach would be to set PROMPT_COMMAND for the shell in /etc/bash.bashrc to an appropriate shell function. The last command executed is available as `history 1` in that handler:

--- bash.bashrc.orig 2012-09-27 16:52:30.452001532 +0100
+++ bash.bashrc 2012-09-27 16:54:24.312515801 +0100
@@ -53,3 +53,6 @@
                fi
        }
 fi
+
+PROMPT_COMMAND='/usr/lib/ubuntu-amazon/prompthandler "$(history 1)"'
+

The handler can then work out what sort of output the user really wanted to see in their shell based on the command given and also the arguments. Commands like "nslookup", "dig" and "hosts" could offer registration deals from GoDaddy. Commands like "passwd" could offer to sell the user books on managing security policies. Commands like "vlc", "mplayer" could could sell videos and music.

Communicating the command and arguments to an external server would presumably be necessary, but I can't imagine anyone objecting to that.

Martyn Hare (martynhare) wrote :

Presumably the only reason grep should have this is because of the number of people who do: find / | grep Miracle\ Spring\ Water

(Oh no, forgot, that's free beer!)

Toni Lähdekorpi (lahdekorpi) wrote :

We are also wasting a lot of valuable space when printing.

CUPS should be fixed to include ads in all the empty spaces when printing documents.
Not only that, but also use printers with an option to print to both sides, to automatically includes ads to the back of every document.

bjd (bjd-xs4all) wrote :

To all posters here:

Isn't it clear to you that your dear overlord will soon
kill off Ubuntu and convert it to the cloud and SAAS
on either Amazon or Microsoft?

Oke, but serious: there is no You in Ubuntu anymore,
it's 'WE' instead, as in "we decide, not you!". So where
you think it's Ubuntu, they think in terms of:

                                       WEbWEntWE

Now what does that start with, which three-letter word?
Isn't that Amazing?

Paul Sladen (sladen) wrote :

@bjd: Yes, absolutely, it sounds a bit like:

  Wii

the most popular, and most widely used consumer gaming system, in many more homes, which is out there displacing the competing products from large multinationals such as Microsoft and Sony.

In fact, very much like where Ubuntu wants to be!

Paul Sladen (sladen) wrote :

@Toni: A printing advert (for Ubuntu) sounds like an excellent idea! It would allow people to easily share their love of Ubuntu with their friends and colleagues who are interested. A few months back a new test page was designed for Ubuntu in response to suggestions by Nick Ellery et al:

  http://design.canonical.com/2012/03/printer-test-page/

But yes, perhaps there's the opportunity to include /more useful/ advertising in some of the space on the test page. Perhaps you could do a mock-up and post it here on this bug report for others to give feedback on?

Martin Wildam (mwildam) wrote :

Sorry folks, for introducing another factor - but I am austrian and we have something similar to Amazon - http://www.thalia.at - when adding amazon you should - of course depending on my location, on my mother tongue and interests add more 3rd party search results. Of course Google should be searched in general to give more options.

Oh and BTW: When searching in my "home" in Dash, you should offer me to buy new slippers - of course already using my shoe size.

Now - back to reality: All this stuff is maybe funny, maybe offers really interesting results. Hence it should be separate lense! NOT in the Dash HOME.

jno (jnoster) wrote :

1. For security reasons, grep(1) must be able to search for encrypted patterns.
2. List of shops must be a property of the current locale.

jno (jnoster) wrote :

2a. if [ "$LANG" = 'C' ]; then declare -a LC_SHOPS=( google.com ); fi # reserve amazon.com for LANG=en_us

Joseph Wynn (joewynn-nz) wrote :

This is a great bug report, thanks akeane!

P.S. Am I supposed to be able to change the status to Confirmed?

Changed in command-not-found (Ubuntu):
status: Invalid → Confirmed
Changed in gnome-terminal (Ubuntu):
status: Invalid → Confirmed
Changed in ayatana-design:
status: Invalid → Confirmed
Paul Sladen (sladen) wrote :

@Joseph Wynn: yes you are able to check and help with triaging. There are many bugs out there were help with triaging would be a very useful contribution to helping to make Ubuntu better.

Changed in gnome-terminal (Ubuntu):
status: Confirmed → Invalid
Changed in command-not-found (Ubuntu):
status: Confirmed → Invalid
Changed in ayatana-design:
status: Confirmed → Invalid
Shreepad S (shreepads) wrote :

Excellent!

Please extend the localisation of the grep hack to India as well (could use language but time zone would be better).

For us this should point to flipkart.com

Hope I don't give the BDFL any ideas here...

I would also love to see a shopping "ballot" option, so that I can also choose my favourity online store to search.

Not everybody uses Amazon as their local web store and I think that is only fair that users get a choice over their selection of web store!

Changed in gnome-terminal (Ubuntu):
status: Invalid → Confirmed
Vibhav Pant (vibhavp) on 2012-10-07
Changed in gnome-terminal (Ubuntu):
status: Confirmed → Invalid
Drmgiver (drmgiver) wrote :

Yes, I agree! What am I going to do when I go to TTY1 and don't see the same ads that I should always see as part of my normal Ubuntu experience?! This must be fixed immediately!

Changed in gnome-terminal (Ubuntu):
status: Invalid → Confirmed
Changed in command-not-found (Ubuntu):
status: Invalid → Confirmed
Changed in ayatana-design:
status: Invalid → Confirmed
Paul Sladen (sladen) on 2012-10-09
Changed in gnome-terminal (Ubuntu):
status: Confirmed → Invalid
Changed in command-not-found (Ubuntu):
status: Confirmed → Invalid
Changed in ayatana-design:
status: Confirmed → Invalid
Drmgiver (drmgiver) on 2012-10-10
Changed in ayatana-design:
status: Invalid → Confirmed
Changed in command-not-found (Ubuntu):
status: Invalid → Confirmed
Changed in gnome-terminal (Ubuntu):
status: Invalid → Confirmed

Please, please, stop changing this to Confirmed. As an item of amusement it's Opinion _at best_ and certainly not related to gnome-terminal.

Changed in ayatana-design:
status: Confirmed → Invalid
Changed in command-not-found (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-terminal (Ubuntu):
status: Confirmed → Invalid
Drmgiver (drmgiver) wrote :

But it affects me! It has to be resolved immediately!

Drmgiver (drmgiver) wrote :

Just look at it, it is the hottest thing there is right now! It must be addressed!

akeane (akeane) wrote :

jfernyhough wrote:

>Please, please, stop changing this to Confirmed. As an item of amusement it's Opinion _at best_ and certainly not related to gnome-terminal.

Yep, he's quite right, leave theUubuntu devs alone, it was really just a cheap laugh at something that, that scoundrel akeane regarded as a bit daft, namely turning local searches into something a "bit more", bah humbug!

I really like Ubuntu, it's turned my humble little netbook into a powerful tool (yay!!!, unix I can carry around in my pocket) I can use it to develop software and effectively troll the interwebz ;-) these guys did a lot of good work making it like that, so Kudos to the Ubuntu devs for doing this great work!

And thanks to Mr Shuttleworth, and the Ubuntu devs for having a good sense of humour, and took it in the spirit is was intended!

And if anyone else changes it to "confirmed", my other monocle might pop out!!!

Timo Witte (spacefish) wrote :

Wow this should get integrated ASAP, nice feature! i mean "new", "astonishing", "great", "big" if you know what i mean ;)

Changed in command-not-found (Ubuntu):
status: Invalid → New
status: New → Opinion
status: Opinion → Invalid
Timo Witte (spacefish) wrote :

maybe we should implement libgrepmazon which handles the request in a different thread, it could be reused in other packages like "command-not-found" or "binutils" aswell.

I think because everyone out there has 1Gbit internetaccess via fibre wire, we can safely make this singlethreaded, because it will only block and make the commands it´s integrated with useless for a the event that the amazon servers are down or you don´t have an internet connection, as this will NEVER ever happen, we can safely asume that 100ms - 10seconds of wait time per command can be tolreated by a user (must be, because we say so).

rupa (rupa) wrote :

I've been following this bug with some interest. A lot of good ideas here, but there are some technical issues that haven't been addressed.

Until all the common unix utilities can be upgraded to be affiliate-aware, common pipe operations might suffer from related amazon results. if you pipe grep into awk for example, without being able to be sure of the results, things can get messy.

I feel this issue can be solved by introducing a new 'default' file descriptor. In addition to 'stdout' and 'stderr', I propose a 'stdaffiliate' file descriptor, and amazon results can go there. This would allow us to see relevant results in the terminal, but keep them out of pipes unless purposely redirected.

This needs to be closed out with a WONTFIX

Changed in gnome-terminal (Ubuntu):
status: Invalid → Opinion
Changed in command-not-found (Ubuntu):
status: Invalid → Opinion
Changed in ayatana-design:
status: Invalid → Opinion
floid (jkanowitz) wrote :

re: #35 - could this overlay functionality be used to present automatically-updating context-sensitive QR codes? Then a user poking through a source tree would simply have to point a smartphone at the screen to purchase a license to Visual Studio 2012.

MR Zenwiz (mrzenwiz) wrote :

I totally agree with Stephen (comment #69).

This should be a "not just no, but HELL no." This isn't a bug. Period.

Brayden Hull (brayden-hull) wrote :

I was thinking of making a new report for this but I feel it is somewhat related.

I just had a brain wave and felt that another way of supporting Canonical would be to give product suggestions whilst the user is idle at the terminal for a certain period of time. Clearly if someone is idle they're just bored and the helpful suggestions provided by Canonical would aid them in freeing themselves from bored despair.

I've had a look at the Amazon RSS API and have found that this would be rather easy to implement.

Periodically bash should call this Python script that I've made (and will attach) which would randomly select out of 20 suggestions. It'll provide a title and URL so the user can buy. I'd love to implement a mechanism where it can be purchased by just clicking on the URL however it is not possible to implement via RSS.

All Canonical needs to do is substitute the current example user ID with their own. Feedparser is not included in Ubuntu by default but is part of the repo with the package name: "python-feedparser - Universal Feed Parser for Python" for 2.7 and "python3-feedparser - Universal Feed Parser for Python" for 3.2

Drmgiver (drmgiver) on 2012-11-09
Changed in ayatana-design:
status: Opinion → Confirmed
Changed in command-not-found (Ubuntu):
status: Opinion → Confirmed
Changed in gnome-terminal (Ubuntu):
status: Opinion → Confirmed
Paul Sladen (sladen) on 2012-11-09
Changed in ayatana-design:
status: Confirmed → Opinion
Changed in command-not-found (Ubuntu):
status: Confirmed → Opinion
Changed in gnome-terminal (Ubuntu):
status: Confirmed → Opinion

Wow, what a great bug! Someone needs to work on this and set this to rights, akeane (akeane) said that they would be willing to hack together a quick patch to enable the expected behavior--is this patch available for public consumption yet?

Changed in ayatana-design:
status: Opinion → Confirmed
Changed in command-not-found (Ubuntu):
status: Opinion → Confirmed
Changed in gnome-terminal (Ubuntu):
status: Opinion → Confirmed

I too would like my dull Ubuntu-based development environment spiced up a little by getting shopping results. Sounds like fun. Everyone knows the main purpose of IT is to aid in SHOPPING!

Changed in ayatana-design:
status: Confirmed → Invalid
Changed in command-not-found (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-terminal (Ubuntu):
status: Confirmed → Invalid
Sergei Beilin (saabeilin) wrote :

I would be lucky if I can find music with find! Like

    find . -ilyrics "When I find myself in times of trouble"

or

    find . -itune "EBC, EGH, HH EBC, ..."

This should search both my harddrive for OGGs and my CD shelf for CDs!

Paul Sladen (sladen) wrote :

Sergei: go for it! It should be possible to do something with the machine's webcam and Processing:

  http://processing.org/

plus some OCR. The search domain could be kept smaller by cross-referencing potential CD/Album title matches with FreeDB to look up the contents of a CD once you have the initial name match. Or perhaps initially ask the user to wave the album barcode to the computer.

A 'unity-physical-bookshelf-lens' sounds a very interesting possibility with lots of opportunity for R&D into how centralised search could fit with enabling the user to find information more easily.

Changed in command-not-found (Ubuntu):
assignee: nobody → Stephen Michael Kellat (skellat)
Changed in gnome-terminal (Ubuntu):
assignee: nobody → Stephen Michael Kellat (skellat)
Changed in command-not-found (Ubuntu):
assignee: Stephen Michael Kellat (skellat) → nobody
Changed in gnome-terminal (Ubuntu):
assignee: Stephen Michael Kellat (skellat) → nobody
Changed in ayatana-design:
status: Invalid → Incomplete
Changed in command-not-found (Ubuntu):
status: Invalid → Incomplete
Changed in gnome-terminal (Ubuntu):
status: Invalid → Incomplete
Paul Sladen (sladen) on 2012-12-19
Changed in gnome-terminal (Ubuntu):
status: Incomplete → Invalid
Changed in command-not-found (Ubuntu):
status: Incomplete → Invalid
Changed in ayatana-design:
status: Incomplete → Invalid

Well, since this is attached to Ayatana-Design it cannot be closed with
a WONTFIX due to the way Ayatana-Design is configured on Launchpad.

Due to the way Ayatana-Design is configured, this cannot be converted to
a question where it truly belongs either.

An INCOMPLETE would let it close by itself in 60 days but nobody will be
likely to leave it in that status for 60 days let alone let is sit
quietly for 60 days.

This horse has been flogged and is now rather dead. This is a wishlist
item in the end. Since this won't die, somebody should at least look at
https://developer.amazon.com/ to see what their API at least allows to
have done with it perhaps.

Paul Sladen (sladen) on 2012-12-19
no longer affects: command-not-found (Ubuntu)
no longer affects: gnome-terminal (Ubuntu)
affects: ayatana-design → command-not-found
affects: command-not-found → command-not-found (Ubuntu)
Paul Sladen (sladen) wrote :

Stephen: It's not really ideal, but I can try shunting it around to increase the likelihood of a 60-day time out happening. I'd welcome any more-ideal solutions/suggestions if somebody can make them. I have a feeling that Launchpad used to have a "null project" for shunting miscellaneous items too. (If all else fails I'm happy to move it to "ubuntu-branding", where it'll still be on my watchlist, but not on other people's to such a degree).

Paul: It'll have to be set to Incomplete for the 60 day time-out, if
memory serves. I was looking for a way to close it out myself last
night. I'd say throwing it over to ubuntu-branding may work at this point.

Drmgiver (drmgiver) on 2012-12-19
Changed in command-not-found (Ubuntu):
status: Invalid → Confirmed
Paul Sladen (sladen) wrote :

drmgiver: What would you like to see done? Could you please explain how setting it to "confirmed" helps?

The fix is to wrap this up as this requires no further action at this time.

Changed in command-not-found (Ubuntu):
assignee: nobody → Stephen Michael Kellat (skellat)
status: Confirmed → Fix Released
Changed in command-not-found (Ubuntu):
assignee: Stephen Michael Kellat (skellat) → I Love Pussy (ilovepussy)
affects: command-not-found (Ubuntu) → kiwilinux
affects: kiwilinux → octopussy (Ubuntu)
bradley haljendi (yofun111) wrote :

I motion to reopen this bug. This needs to be fixed ASAP.
I want Ads in my terminal to support the company'a.

Rodney Dawes (dobey) on 2013-06-29
affects: octopussy (Ubuntu) → command-not-found (Ubuntu)
Changed in command-not-found (Ubuntu):
assignee: I Love Pussy (ilovepussy) → Stephen Michael Kellat (skellat)
status: Fix Released → Won't Fix
bradley haljendi (yofun111) wrote :

Why wont you fix this bug?
Does anyone 2nd the motion to reopen the bug?

Ernesto (erjoalgo) wrote :

Everyone: just switch to Debian.

Thanks Ernesto, I've just switched to Debian.

Chris Peach (peachris+ubuntu) wrote :

Congratulations, Nico! So did I a year a go, and I never looked back.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches