comix.py crashed with Exception in tostring(): tostring() has been removed. Please call tobytes() instead.

Bug #1521730 reported by Brian Murray on 2015-12-01
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
comix (Ubuntu)
Medium
Brian Murray
Xenial
Medium
Brian Murray

Bug Description

Test Case
---------
1) Read a comic with comix.
2) Observe a crash after closing the comic with a Traceback regarding tostring().
With the version of the package from -proposed there will be no crash / traceback. Additionally, confirm that the version of the package from -proposed does not appear in the version list here:

https://errors.ubuntu.com/bucket/?id=/usr/share/comix/src/comix.py%3AException%3A_load%3A_add_page_number%3Apil_to_pixbuf%3Atostring

Original Bug Description
------------------------
This happened when I was reading a comic or closing comix.

ProblemType: CrashDistroRelease: Ubuntu 16.04
Package: comix 4.0.4-1
ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
Uname: Linux 4.2.0-19-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.2-0ubuntu8
Architecture: amd64
CrashCounter: 1
CurrentDesktop: Unity
Date: Tue Dec 1 10:47:55 2015
EcryptfsInUse: Yes
ExecutablePath: /usr/share/comix/src/comix.py
InstallationDate: Installed on 2013-01-16 (1049 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130116)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: python /usr/bin/comix /misc/comics/Wonder\ Woman/Wonder\ Woman\ 05\ (1987)\ (FIXED)\ (Minutemen-KangCouncil).cbz
ProcEnviron:
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/zsh
 LANGUAGE=en_US
 PATH=(custom, user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/comix', '/misc/comics/Wonder Woman/Wonder Woman 05 (1987) (FIXED) (Minutemen-KangCouncil).cbz']SourcePackage: comix
Title: comix.py crashed with Exception in tostring(): tostring() has been removed. Please call tobytes() instead.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm autopilot cdrom dip libvirtd lpadmin plugdev sambashare sbuild sudo

Brian Murray (brian-murray) wrote :
information type: Private → Public
tags: removed: need-duplicate-check
Changed in comix (Ubuntu):
importance: Undecided → Medium
Nazo (lovesyao) on 2016-04-24
Changed in comix (Ubuntu):
status: New → Confirmed
Adrianna Pińska (confluence) wrote :

This bug prevents Comix from displaying thumbnails, but does not cause it to crash on my computer (I am also on Xenial).

It looks like development of Comix has stalled, but the Fedora maintainers have continued to patch it, and have fixed this particular bug: https://bugzilla.redhat.com/show_bug.cgi?id=1290632

I converted the Fedora .rpm to a .deb with alien, and was able to install it without any complications. After this update, Comix displays thumbnails again. so it should be possible to incorporate the Fedora patches into the Ubuntu package.

Link to Fedora package: ftp://ftp.rpmfind.net/linux/RPM/fedora/updates/23/i386/c/comix-4.0.4-9.fc23.noarch.html

Adrianna Pińska (confluence) wrote :

Here's an explicit HOWTO for the .rpm workaround:

# Get the .rpm (don't worry about the i386; it's an architecture-agnostic Python application)
wget ftp://fr2.rpmfind.net/linux/fedora/linux/updates/23/i386/c/comix-4.0.4-9.fc23.noarch.rpm

# Get alien
sudo apt-get install alien

# Convert the package (must do it as root; -k to keep the right version number)
sudo alien -k comix-4.0.4-9.fc23.noarch.rpm

# Install the package
sudo dpkg -i comix_4.0.4-9.fc23_all.deb

Changed in comix (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: Confirmed → In Progress
Jeremy Bicha (jbicha) on 2016-09-30
Changed in comix (Ubuntu Xenial):
importance: Undecided → Medium
status: New → Triaged
Changed in comix (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package comix - 4.0.4-3ubuntu1

---------------
comix (4.0.4-3ubuntu1) yakkety; urgency=medium

  * debian/patches/remove_tostring.patch:
    - switch from removed tostring to tobytes. (LP: #1521730)

 -- Brian Murray <email address hidden> Fri, 30 Sep 2016 14:14:44 -0700

Changed in comix (Ubuntu):
status: In Progress → Fix Released
description: updated
description: updated

Hello Brian, or anyone else affected,

Accepted comix into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/comix/4.0.4-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in comix (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

With the version of comix from -proposed I can now see thumbnails and don't receive a crash report.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for comix has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package comix - 4.0.4-1ubuntu1

---------------
comix (4.0.4-1ubuntu1) xenial-proposed; urgency=medium

  * src/image.py:
    - switch from removed tostring to tobytes. (LP: #1521730)

 -- Brian Murray <email address hidden> Fri, 30 Sep 2016 15:29:39 -0700

Changed in comix (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.