failed to execute '/lib/udev/usb-db'

Bug #1200185 reported by Dimitri John Ledkov on 2013-07-11
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
argyll (Ubuntu)
Medium
Unassigned
colord (Ubuntu)
Medium
Unassigned
systemd (Ubuntu)
Medium
Unassigned

Bug Description

systemd-udev reports failure to execute usb-db, indeed there is no /lib/udev/usb-db on my system, yet argyll and colord reference those in the udev rules.

Changed in argyll (Ubuntu):
importance: Undecided → Medium
Changed in colord (Ubuntu):
importance: Undecided → Medium
Changed in systemd (Ubuntu):
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

/lib/udev/usb-db is history. Rules that refer to these need to be updated to use IMPORT{builtin}="hwdb --subsystem=usb" (or better yet, not refer to these internals in the first place..)

Changed in systemd (Ubuntu):
status: New → Invalid
Dimitri John Ledkov (xnox) wrote :

Thanks, pitti. Will see if I can fix above rules as per your recommendation.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package colord - 1.0.1-1ubuntu1

---------------
colord (1.0.1-1ubuntu1) saucy; urgency=low

  * Migrate from usb_id and usb_db to udev builtins usb_id and hwdb.
    (LP: #1200185)
 -- Dmitrijs Ledkovs <email address hidden> Mon, 15 Jul 2013 10:38:08 +0100

Changed in colord (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in argyll (Ubuntu):
status: New → Confirmed
Phil Wyett (u-k-i-t) wrote :

Stilling seeing this issue as of 2013-08-29 in ubuntu gnome 13.10 dev. Do we have an time on the full fix for this?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package argyll - 1.4.0-8ubuntu5

---------------
argyll (1.4.0-8ubuntu5) saucy; urgency=low

  * Use hwdb builtin, instead of the obsolete usb-db in the udev
    rules. (LP: #1200185)
 -- Dmitrijs Ledkovs <email address hidden> Thu, 29 Aug 2013 22:55:30 +0100

Changed in argyll (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers