colord-sane crashed with SIGSEGV in dbus_message_get_reply_serial()

Bug #1040680 reported by Steve Langasek
96
This bug affects 22 people
Affects Status Importance Assigned to Milestone
colord (Ubuntu)
Undecided
Unassigned

Bug Description

No idea what triggered this. Wasn't doing anything involving sane/colord at the time.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: colord 0.1.21-1
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
ApportVersion: 2.5.1-0ubuntu1
Architecture: amd64
Date: Thu Aug 23 07:22:27 2012
ExecutablePath: /usr/lib/x86_64-linux-gnu/colord/colord-sane
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
ProcCmdline: /usr/lib/x86_64-linux-gnu/colord/colord-sane
ProcEnviron:

SegvAnalysis:
 Segfault happened at: 0x7f848cf86653: movzbl (%rax),%eax
 PC (0x7f848cf86653) ok
 source "(%rax)" (0x000000bf) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: colord
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 dbus_message_get_reply_serial () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
Title: colord-sane crashed with SIGSEGV in dbus_message_get_reply_serial()
UpgradeStatus: Upgraded to quantal on 2012-06-11 (72 days ago)
UserGroups: scanner

Revision history for this message
Steve Langasek (vorlon) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 ?? () from /tmp/tmpUKNlj0/lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /tmp/tmpUKNlj0/lib/x86_64-linux-gnu/libdbus-1.so.3
 dbus_message_get_reply_serial () from /tmp/tmpUKNlj0/lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /tmp/tmpUKNlj0/lib/x86_64-linux-gnu/libdbus-1.so.3
 ?? () from /tmp/tmpUKNlj0/lib/x86_64-linux-gnu/libdbus-1.so.3

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in colord (Ubuntu):
status: New → Invalid
Revision history for this message
Apport retracing service (apport) wrote : Crash report cannot be processed

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

mountall version 2.39 required, but 2.38 is available
outdated debug symbol package for initscripts: package version 2.88dsf-13.10ubuntu13 dbgsym version 2.88dsf-13.10ubuntu11.1
outdated debug symbol package for module-init-tools: package version 3.16-1ubuntu3 dbgsym version 3.16-1ubuntu2

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-amd64-retrace
Steve Langasek (vorlon)
visibility: private → public
Revision history for this message
Rainer Rohde (rainer-rohde) wrote :

This happens to me on a regular basis... Quantal alpha .

Changed in colord (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Steve Langasek (vorlon) wrote :

but without a backtrace, the bug is not actionable for fixing.

Changed in colord (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
crf (chrisfahlman) wrote :

Happened to me too.

Changed in colord (Ubuntu):
status: Invalid → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in colord (Ubuntu):
status: New → Confirmed
Revision history for this message
Matthew Gleed (mgleed) wrote :

Same issue upon first login after reboot. Just updated my packages previous to reboot.

Revision history for this message
J Cord (j7cord) wrote :

This bug is happening every login for ubuntu 12.10 and 12.04, for me. It appears to me to be unique to ubuntu , as I get no such bug in either debian wheezy or sid. I don't know if that helps or not, I hope so. Best Wishes and Good Luck

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers