colord-sane crashed with SIGSEGV in __opendirat()

Bug #1026520 reported by Msirdian on 2012-07-19
202
This bug affects 32 people
Affects Status Importance Assigned to Milestone
colord (Ubuntu)
Medium
Chris Halse Rogers
Quantal
Medium
Chris Halse Rogers

Bug Description

happened after upgrade

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: colord 0.1.21-1
ProcVersionSignature: Ubuntu 3.5.0-4.4-generic 3.5.0-rc6
Uname: Linux 3.5.0-4-generic i686
ApportVersion: 2.4-0ubuntu2
Architecture: i386
Date: Thu Jul 19 09:16:09 2012
ExecutablePath: /usr/lib/i386-linux-gnu/colord/colord-sane
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120514)
ProcCmdline: /usr/lib/i386-linux-gnu/colord/colord-sane
ProcEnviron:

SegvAnalysis:
 Segfault happened at: 0xb734314f: cmpb $0x0,(%edx)
 PC (0xb734314f) ok
 source "$0x0" ok
 destination "(%edx)" (0x00000000) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: colord
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 opendir () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libusb-1.0.so.0
 libusb_get_device_list () from /lib/i386-linux-gnu/libusb-1.0.so.0
 ?? () from /usr/lib/libhpmud.so.0
Title: colord-sane crashed with SIGSEGV in opendir()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Msirdian (arena7) wrote :

StacktraceTop:
 __opendirat (dfd=-100, name=0x0) at ../sysdeps/unix/opendir.c:87
 __opendir (name=0x0) at ../sysdeps/unix/opendir.c:156
 usbfs_get_device_list (_discdevs=0xbfe0a7ac, ctx=0x8457e00) at ../../libusb/os/linux_usbfs.c:1088
 op_get_device_list (ctx=0x8457e00, _discdevs=0xbfe0a7ac) at ../../libusb/os/linux_usbfs.c:1280
 libusb_get_device_list (ctx=0x8457e00, list=0xbfe0a84c) at ../../libusb/core.c:604

Changed in colord (Ubuntu):
importance: Undecided → Medium
summary: - colord-sane crashed with SIGSEGV in opendir()
+ colord-sane crashed with SIGSEGV in __opendirat()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in colord (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1026520

tags: added: iso-testing
visibility: private → public
Changed in colord (Ubuntu):
importance: Medium → High
tags: added: rls-q-incoming
CSRedRat (csredrat) wrote :

Ubuntu 12.10 Alpha 3: affect me.

Chris Halse Rogers (raof) wrote :

This looks likely to be a libsane / libsane-hpio bug; I'll check the code, then reassign.

This crash is highly likely to be benign - colord-sane is deliberately split out into a separate process so that it can crash. Apart from the crash reporting dialog popping up, is there any user-visible symptom of this crash?

(I lost the crashfile before getting around to looking up this bug, so I'm not 100% sure this is the colord-sane crash that happened to me, but it looks like it fits.)

Chris, you're right, I did not see any symptoms besides report of the crash. Thanks.

CSRedRat (csredrat) wrote :

I'm have "colord-sane crashed with SIGSEGV in libusb_get_device_list()" in LiveCD Ubuntu 12.10 Alpha 3.
P.S. I cann't download Russian language support package in Installation menu with error by firefox url. In LiveCD i'm have russian language support package, but i'm have any windows and text in english.

sml (smlubuntu) wrote :

same problem with x86_64 version.
no visible problems only error message after login.

Sebastien Bacher (seb128) wrote :

Hey Chris, could you look into that issue? It's affect lot of our users

Changed in colord (Ubuntu Quantal):
assignee: nobody → Chris Halse Rogers (raof)
tags: removed: rls-q-incoming
Para Siva (psivaa) wrote :

This crash occurrs in all our automated precise2quantal upgrade tests.

tags: added: precise2quantal
tags: added: bugpattern-needed
Didier Roche (didrocks) on 2012-09-13
Changed in colord (Ubuntu Quantal):
importance: High → Medium
milestone: none → ubuntu-12.10

 status incomplete

Because the stacktrace on this is quite weird, I'm going to be
super-optimistic and hope that fixing the thread-unsafe usage of DBus in
colord-sane has magically fixed this.

Please pipe up if you see this crash with colord 0.1.21-1ubuntu1.

Changed in colord (Ubuntu):
status: Confirmed → Incomplete
twipley (smt-infp) wrote :

Not to report any problem, but just to note that, having installed the 12/09/13 quantal build about 10 hours ago, I have yet to witness a colord crash, which was so frequent when I had one of the alpha builds installed.

If this is the case, that this has been fixed, then long live magic.

Nicholas Skaggs (nskaggs) wrote :

I hate to burst bubbles here, but I received a crash on this issue today, and I am running colord 0.1.21-1ubuntu1 since 13 sept :-)

twipley (smt-infp) wrote :

[Laughters]

I too have suffered from first colord annoyance today.

Actually, apport does not bring me on this page, but on:
https://bugs.launchpad.net/ubuntu/+source/colord/+bug/1027139

Linards Ticmanis (ticmanis) wrote :

Still present in 12.10...

CSRedRat (csredrat) wrote :

Report after update 12.04.1 to 12.10 beta 2.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package colord - 0.1.21-1ubuntu2

---------------
colord (0.1.21-1ubuntu2) quantal-proposed; urgency=low

  * debian/patches/one_shot_colord-sane.patch:
    - Rework colord-sane to be spawned each time a sane scan is required.
      Works around fd leaks in libsane and its plugins, resulting in many, many
      crashes in colord-sane. (LP: #1024081, LP: #1056933, LP: #1056933,
      LP: #1026520)
  * debian/patches/initialise_gdbus_connection_sooner.patch:
    - Initialise gdbus connection in the bus_acquired callback rather than the
      name_acquired callback. The name_acquired callback is fired an
      indeterminate time *after* the name appears on the bus, so requests can
      come in before its called. If this happened, colord would crash with an
      assert(). (LP: #849472, LP: #1064352, LP: #827934)
 -- Christopher James Halse Rogers <email address hidden> Wed, 10 Oct 2012 16:41:44 +1100

Changed in colord (Ubuntu Quantal):
status: Incomplete → Fix Released
Mark (mark-k) wrote :

Has this bug really been fixed? I'm seeing it every time I boot the final Ubuntu 12.10 x86 ISO image in VirtualBox (selecting Try Ubuntu to load the Unity desktop). It gives a pretty poor first impression of Ubuntu. If the 12.10 ISO images are ever rebuilt/updated I hope this issue can be addressed.

Every time I boot, shortly after the desktop has loaded a dialog box appears, saying
  System program problem detected
  Do you want to report the problem now?

On clicking Report problem... then Show Details, this text is shown:
  ExecutablePath
    /usr/lib/i386-linux-gnu/colord/colord-sane
and there's a busy animation which goes on for seemingly ages (in fact a couple of minutes). Once that finishes, the rest of the text appears giving info about the crash. I did send an error report so won't type it all up here unless needed.

 Package
    colord 0.1.21-1ubuntu2
  ProblemType
    Crash
  Title
    colord-sane crashed with SIGSEGV in opendir()
  ApportVersion
    2.6.1-0ubuntu3
  Architecture
    i386
  CasperVersion
    1.328
  [rest of the sections omitted]

CSRedRat (csredrat) wrote :

Ubuntu 13.04 on Microsoft Hyper-V 2008 R2 SP1. Happened after reboot.

DimeDroll (dimdroll) wrote :

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Thu Jan 24 12:47:09 2013
DistroRelease: Ubuntu 12.10
ExecutablePath: /usr/lib/i386-linux-gnu/colord/colord-sane
ExecutableTimestamp: 1349865025
ProcCmdline: /usr/lib/i386-linux-gnu/colord/colord-sane
ProcCwd: /
ProcStatus:
 Name: colord-sane
 State: S (sleeping)
 Tgid: 2033
 Pid: 2033
 PPid: 2030
 TracerPid: 0
 Uid: 114 114 114 114
 Gid: 124 124 124 124
 FDSize: 32
 Groups: 124 125
 VmPeak: 53564 kB
 VmSize: 53460 kB
 VmLck: 0 kB
 VmPin: 0 kB
 VmHWM: 8456 kB
 VmRSS: 8456 kB
 VmData: 32120 kB
 VmStk: 136 kB
 VmExe: 8 kB
 VmLib: 19968 kB
 VmPTE: 84 kB
 VmSwap: 0 kB
 Threads: 3
 SigQ: 0/31104
SegvAnalysis:
 Segfault happened at: 0xb740b3bf: cmpb $0x0,(%edx)
 PC (0xb740b3bf) ok
 source "$0x0" ok
 destination "(%edx)" (0x00000000) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
SourcePackage: colord
Title: colord-sane crashed with SIGSEGV in opendir()
UpgradeStatus: Upgraded to quantal on 2013-01-17 (6 days ago)

Installed version of colord:
Version: 0.1.21-1ubuntu2
This bug still afects me, should I provide any other information or create new bug as this one is being marked as fixed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers