E: Sub-process /usr/bin/dpkg returned an error code (1)

Bug #297288 reported by Rajinder Sandhu, Bangalore
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
collectd (Ubuntu)
Invalid
Low
Unassigned
dpkg (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: dpkg

Upgraded to intrepid ubuntu 8.10 and it was working fine. For the last few days, when ever tried to install any program or upgrade the following message is getting printed on the screen and programs are not getting updated or upgraded, however program are getting downloaded alright:

Setting up collectd (4.4.1-1ubuntu1) ...
Starting statistics collection and monitoring daemon: collectdinvoke-rc.d: initscript collectd, action "start" failed.
dpkg: error processing collectd (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 collectd
E: Sub-process /usr/bin/dpkg returned an error code (1)
dads@dadz-desktop:~$

Bug report for ktorrent is attached here for your reference. Please help me to over come this,
Thanks
Rajinder Sandhu
Bangalore

Tags: bitesize
Revision history for this message
Rajinder Sandhu, Bangalore (sandy744-breakthru) wrote :
description: updated
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

This isn't a dpkg bug, so I'm closing that task. I don't quite understand the relevance of the ktorrent crash report. If you're having separate issues with ktorrent, please open a separate report for that.

Anyway, could you please try running the following:

sudo invoke-rc.d collectd stop
sudo dpkg --configure collectd

This should correct your issue

Changed in dpkg:
status: New → Invalid
Changed in collectd:
status: New → Incomplete
Revision history for this message
Rajinder Sandhu, Bangalore (sandy744-breakthru) wrote :

it has corrected my problem
Thanks Chris

Rajinder Sandhu
Bangalore

Changed in collectd:
status: Incomplete → Invalid
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Thanks, but this is still a bug though, so I'm reopening

Changed in collectd:
importance: Undecided → Low
status: Invalid → Triaged
Revision history for this message
Vincenzo Ampolo (vincenzo-ampolo) wrote :

Installing on jaunty returns no errors:

 Selecting previously deselected package collectd.
Unpacking collectd (from .../collectd_4.4.2-3ubuntu1_amd64.deb)...
Setting up libmagic1 (4.26-2ubuntu1) ...
Setting up file (4.26-2ubuntu1) ...

Installing collectd in intrepid does not return any error:

Setting up collectd (4.4.1-1ubuntu1) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place

Installing the hardy package in intrepid and then doing apt-get upgrade returns no errors:

Preparing to replace collectd 4.3.0-1 (using .../collectd_4.4.1-1ubuntu1_amd64.deb) ...
Unpacking replacement collectd ...
Setting up collectd (4.4.1-1ubuntu1) ...
Installing new version of config file /etc/collectd/collectd.conf ...
Installing new version of config file /etc/collectd/thresholds.conf ...
Installing new version of config file /etc/init.d/collectd ...

How can i reproduce this bug?

Revision history for this message
Siegfried Gevatter (rainct) wrote :

Without looking at it, it looks like this happens when you upgrade while the daemon is already running.

Revision history for this message
Daniel (daniel-rconcept) wrote :

I've exactly the same error msg (on a fresh ubuntu 8.04 LTS install)
It was the hostname of that machine which couldn't be resolved.
So I added the hostname to /etc/hosts (with it's external IP address) and after that, the installation of collectd worked fine

Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Having an unresolvable hostname is not really something we can support for network services. It makes sense that collectd would fail in that instance.

I'm closing this as Invalid, collectd seems to be working properly.

Changed in collectd (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers