missing dependencies in ipopt.pc

Bug #1659835 reported by Daniele E. Domenichelli
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
coinor-ipopt (Ubuntu)
Undecided
Unassigned

Bug Description

On Ubuntu Yakkety, some of the libraries listed by in ipopt.pc (gfortran quadmath) from coinor-libipopt-dev (3.11.9-2.1) are not available when installing the coinor-libipopt-dev package. I think (but I couldn't test it) that adding libgcc-5-dev and libgfortran-5-dev to the dependencies this issue might be fixed, but I don't think this is a good solution.

The line responsible is this:

Libs: -L${libdir} -lipopt -ldmumps_seq -lblas -L/usr/lib/gcc/x86_64-linux-gnu/5 -L/usr/lib/gcc/x86_64-linux-gnu/5/../../../x86_64-linux-gnu -L/usr/lib/gcc/x86_64-linux-gnu/5/../../../../lib -L/lib/x86_64-linux-gnu -L/lib/../lib -L/usr/lib/x86_64-linux-gnu -L/usr/lib/../lib -L/usr/lib/gcc/x86_64-linux-gnu/5/../../.. -llapack -lblas -ldmumps_seq -ldl -lgfortran -lm -lquadmath -lblas -lm -ldl

The -L paths point to /usr/lib/gcc/x86_64-linux-gnu/5, but I suppose that the correct path should be /usr/lib/gcc/x86_64-linux-gnu/6.

Perhaps the package was compiled with gcc 5 before the migration to gcc 6?

Interesting fact is that the same packages in debian (same exact version 3.11.9-2.1) contains only these libraries.

Libs: -L${libdir} -lipopt -ldmumps_seq -lblas -lblas -lm -ldl

Also interesting that linking ipopt without -lgfortran and -lquadmath does not cause any error.

description: updated
tags: added: yakkety
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers