coherence plugin dont work correctly - Karmic

Bug #435602 reported by AlexWBaule on 2009-09-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
coherence (Ubuntu)
Medium
Charlie_Smotherman
Nominated for Karmic by Miron Cuperman

Bug Description

Binary package hint: rhythmbox

I have 2 Pcs....

1 - ubuntu 9.04 - Rhythmbox with upnp enabled, works fine... read my Router Upnp Musics (WRT610N)
2 - Ubuntu 9.10 - Karmic - Rhythmbox with upnp enabled, dont work. But the Totem with upnp plugin works.

I Think is a bug in rhythmbox or coherence plugin... there is some debug that i send to get the real issue here ?

Tks.

ProblemType: Bug
Architecture: i386
Date: Wed Sep 23 23:19:03 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.12.5-0ubuntu1
ProcEnviron:
 LANGUAGE=pt_BR.UTF-8
 PATH=(custom, user)
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.31-10-generic i686

Related branches

AlexWBaule (alexwbaule) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, not sure about the issue though, to confirm by somebody using upnp or to send to GNOME where they might have idea on how to debug this one

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Miron Cuperman (devrandom) wrote :

I am seeing the same problem.

It looks like the coherence plugin doesn't activate properly. For example, I wasn't able to see anything advertised from rhythmbox using upnp-inspector. The problem is likely in the coherence rhythmbox plugin (part of the rhythmbox package).

Miron Cuperman (devrandom) wrote :
Miron Cuperman (devrandom) wrote :

Here's a better log file, with "logmode = info" in /usr/lib/rhythmbox/plugins/upnp_coherence/__init__.py .

It doesn't look like the coherence plugin is sending out discovery responses. Standalone coherence seems to advertise fine on the same machine.

AlexWBaule (alexwbaule) wrote :

yeap...is a rhythmbox bug....in coherence plugin.....

Te BASIC difference is this:

change this....
import louie

for this....
import coherence.extern.louie as louie

i made a script to update the Plugin with the last trunk from coherence.beebits.net

I Follow the wiki in coherence.beebits....

#----- CUT HERE -------
#!/bin/sh

cd /usr/lib/rhythmbox/plugins/upnp_coherence

wget "http://coherence.beebits.net/browser/trunk/Coherence/misc/Rhythmbox-Plugin/upnp_coherence/__init__.py?format=raw" -O __init__.py
wget "http://coherence.beebits.net/browser/trunk/Coherence/misc/Rhythmbox-Plugin/upnp_coherence/MediaPlayer.py?format=raw" -O MediaPlayer.py
wget "http://coherence.beebits.net/browser/trunk/Coherence/misc/Rhythmbox-Plugin/upnp_coherence/MediaStore.py?format=raw" -O MediaStore.py
wget "http://coherence.beebits.net/browser/trunk/Coherence/misc/Rhythmbox-Plugin/upnp_coherence/UpnpSource.py?format=raw" -O UpnpSource.py
#------ END CUT HERE -------

Save this in a new file , do a chmod 755 and execute it.

For me, work...now i can see my WRT610N Upnp Musics.....

Miron Cuperman (devrandom) wrote :

I can confirm that the modified import fixes the problem in my environment.

Charlie_Smotherman (cjsmo) wrote :

Alex, Miron, Seb,

Thanks for the bug report, I just found it :)
I will work up a patch for this and upload it asap.

Changing Affect to coherence
Changing status to in progress
Assigning to me

affects: rhythmbox (Ubuntu) → coherence (Ubuntu)
Changed in coherence (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Charlie_Smotherman (porthose) (cjsmo)
importance: Low → Medium
status: New → In Progress
Charlie_Smotherman (cjsmo) wrote :

Alex, Miron, Seb

I opened bug #447620 to address to rhythmbox coherence plugin issue and will be attaching a debdiff that will correct this issue in rhythmbox.

I will be closing this bug with the coherence upload.

Changed in coherence (Ubuntu):
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package coherence - 0.6.4-3ubuntu2

---------------
coherence (0.6.4-3ubuntu2) karmic; urgency=low

  * Updated Rythmbox plugin from upstream trunk so the Rythmbox plugin
    broadcasts correctly. This is need due to changes in Rythmbox.
    Files updated
    - coherence/misc/Rythmbox-Plugin/upnp_coherence/__init__.py
    - coherence/misc/Rythmbox-Plugin/upnp_coherence/MediaPlayer.py
    - coherence/misc/Rythmbox-Plugin/upnp_coherence/MediaStore.py
    - coherence/misc/Rythmbox-Plugin/upnp_coherence/UpnpSource.py (LP: #435602)

 -- Charlie Smotherman <email address hidden> Thu, 08 Oct 2009 00:12:47 -0500

Changed in coherence (Ubuntu):
status: Confirmed → Fix Released
RT (vuehue) on 2010-03-10
Changed in coherence (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers