Rhythmbox connection to Xbox360 drops

Bug #381275 reported by JK
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
coherence (Ubuntu)
Undecided
Frank Scholz

Bug Description

Binary package hint: rhythmbox

Rhythmbox in Ubuntu 9.04

Added DLNA/UPnP plugin (and installed python-coherence via synaptic package manager)

Xbox 360 displays Rhythmbox on correct IP address in the Xbox 360 Music Libary.

However, the connection times out when selecting Rhythmbox as the source from the Xbox 360 Music Library and the following message is displayed: "The connection to your computer was lost. Make sure your computer is turned on, connected to your network, and running media sharing software."

Subsequent connection testing from the Xbox 360 console shows that the Xbox 360 is connected to the network and also connected to the PC that has Rhythmbox running on it.

Wasssup??

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.12.0-0ubuntu4
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.28-11-generic i686

Revision history for this message
JK (jtk1965) wrote :
Changed in rhythmbox (Ubuntu):
status: New → Invalid
Revision history for this message
Andrew Somerville (andy-somerville) wrote :

I can confirm that this happens for me as well. It seems like a bug to me, not just a question. The issue could either be in the rhythmbox plugin or upstream in python-coherence. It's not clear.

Revision history for this message
Tina Russell (tinarussell) wrote :

Why was this marked invalid? I think we should figure out where the problem is, first.

Cam Cope (ccope)
Changed in rhythmbox (Ubuntu):
status: Invalid → Incomplete
Revision history for this message
Cam Cope (ccope) wrote :

This is still an issue in 9.10, and it's probably due to a bug in Coherence. There's a commit in the upstream changelog that mentions a fix for the Xbox that is dated 10/25/2009: http://coherence.beebits.net/browser/trunk/Coherence/ChangeLog

affects: rhythmbox (Ubuntu) → coherence (Ubuntu)
Revision history for this message
Cam Cope (ccope) wrote :

Wireshark tcpdump of the conversation between the XBox 360 and Rhythmbox with UPNP.

Frank Scholz (coherence)
Changed in coherence (Ubuntu):
assignee: nobody → Frank Scholz (coherence)
Revision history for this message
WoollyjumperJon (jonmorgan1979) wrote :

I can confirm I have the same issue on Ubuntu 9.10.
By the way this is my first post on Launchpad. Anything else I can do to help solve this let me know I'm keen to have it solved.

Revision history for this message
DavidW617 (davidw617) wrote :

This bug still affects me and I'm running Lucid Lynx.

Revision history for this message
HillClimber (launchpad-pub) wrote :

Just encountered the same bug. Using Lucid, 2.6.32-23-generic.

Revision history for this message
Jon Thysell (jonthysell) wrote :

Stack trace attached.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers