Ubuntu

python-coherence: /usr/share/dbus-1/services/org.Coherence.service should be included

Reported by Sander Jonkers on 2009-03-31
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
coherence (Ubuntu)
Low
Unassigned

Bug Description

python-coherence on Ubuntu Jaunty Beta & Daily build March 31 2009:

the file /usr/share/dbus-1/services/org.Coherence.service is missing. This results in error message like "dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.Coherence was not provided by any .service files" when using python-coherence.

The contents of /usr/share/dbus-1/services/org.Coherence.service should be

[D-BUS Service]
Name=org.Coherence
Exec=/usr/bin/coherence -o use_dbus:yes -o controlpoint:yes

See http://coherence.beebits.net/wiki/Totem for instructions to add this file.

See http://rpmfind.net/linux/RPM/fedora/devel/i386/python-Coherence-0.6.2-1.fc11.noarch.html : the fedora RPM python-coherence does contain the file /usr/share/dbus-1/services/org.Coherence.service

See https://bugs.launchpad.net/ubuntu/+source/totem/+bug/338963 for the (sub)problem the lacking file causes.

The file is already shipped with the original sources, it is just not being installed.

Andreas Moog (amoog) on 2009-03-31
tags: added: packaging
Changed in coherence (Ubuntu):
assignee: nobody → andreas-moog
importance: Undecided → Low
status: New → In Progress
Sander Jonkers (jonkers) wrote :

At " *** This bug is a duplicate of bug 338963 ***":

No, it's not a duplicate. Bug https://bugs.launchpad.net/ubuntu/+source/coherence/+bug/338963 is a separate bug. As already explained there:

bug 1 (338963): the fact that totem offers Coherence DLNA/UPnP, whereas python-coherence needs to be installed for that, which does not happen.
If is not installed by default due to CD constrains, it should not result in an ugyly error.

bug 2 (this bug here, 352653): installing python-coherence reveals a bug in bug-python itself: the missing file. To avoid confusion (!) I've reported a separate bug report for the second bug, see https://bugs.launchpad.net/ubuntu/+source/coherence/+bug/352653

By solving only bug 1 in totem, you will still have bug 2 in python-coherence.
By solving only bug 2 in python-coherence, you will still have bug 1 in totem.
So, two separate bugs. Only if you solve both bugs, both bugs will be gone.

 "duplicate" message (hopefully) removed.

Sander Jonkers (jonkers) wrote :

oops, typo:

"installing python-coherence reveals a bug in bug-python itself"

should read

"installing python-coherence reveals a bug in *python-coherence* itself"

Andreas Moog (amoog) wrote :

debdiff attached:
coherence (0.6.2-1ubuntu2) jaunty; urgency=low

  * debian/python-coherence.install
    - install org.Coherence.service to dbus-services (LP: #352653)

 -- Andreas Moog <email address hidden> Mon, 06 Apr 2009 22:17:12 +0200

Changed in coherence (Ubuntu):
assignee: andreas-moog → nobody
Andreas Moog (amoog) wrote :
Changed in coherence (Ubuntu):
status: In Progress → Triaged
Andreas Moog (amoog) on 2009-04-07
description: updated
James Westby (james-w) wrote :

Hi Andreas,

A quick glance at your fix suggests it is good.

Charlie asked whether anyone would be able to take care of bug 338963
as well in his absence. Have you had a look at that one? Do you think it
would be feasible to fix that at the same time?

Thanks,

James

Andreas Moog (amoog) wrote :

Hi James,

bug 338963 can be fixed by moving the coherence-plugin to totem-plugins-extra, which contains all plugins in need of universe/multiverse to work. Thanks to seb128 for pointing me to that package.

The fix here can be uploaded, it is a seperate issue.

James Westby (james-w) wrote :

Oops, reading again, it seems we don't need a release
team ACK for this upload, sorry for the extra mail.

Thanks,

James

James Westby (james-w) on 2009-04-10
Changed in coherence (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package coherence - 0.6.2-1ubuntu2

---------------
coherence (0.6.2-1ubuntu2) jaunty; urgency=low

  * debian/python-coherence.install
    - install org.Coherence.service to dbus-services (LP: #352653)

 -- Andreas Moog <email address hidden> Mon, 06 Apr 2009 22:17:12 +0200

Changed in coherence (Ubuntu):
status: Fix Committed → Fix Released
Nikolaus Filus (nfilus) wrote :

re-opened for lucid lynx. File is missing again in package python-coherence_0.6.6.2-1_all

Changed in coherence (Ubuntu):
status: Fix Released → In Progress
Charlie_Smotherman (cjsmo) wrote :

Nikolaus,

Thank you for the bug report :)

Could you please re-check your system, in python-coherence-0.6.6.2-1 /misc/org.Coherence.service is present in the tarball and debian/install installs it into /usr/share/dbus-1/services/

I am going to re-test install/upgrade, just to make sure. :)

Best regards
Charlie Smotherman (porthose)

Nikolaus Filus (nfilus) wrote :

Hi Charlie,
I redownloaded and rechecked the package. You can see the file is missing in the file list at http://packages.ubuntu.com/lucid/all/python-coherence/filelist.

Thanks for your attention.

Charlie_Smotherman (cjsmo) wrote :

Nikolaus

I physically downloaded the source package and checked the tarball, and /misc/org.Coherence.service is present, and debian/install appears to be correct. However when I rebuilt the package and looked at the .deb /misc/org.Coherence.service is not there. This seems to be a problem with debian/install not doing the right thing :(

I'll upload a new version as soon as I get this worked out. Thank you for the report :)

Best regards

Charlie Smotherman (porthose)

Changed in coherence (Ubuntu):
assignee: nobody → Charlie_Smotherman (porthose) (cjsmo)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package coherence - 0.6.6.2-1ubuntu1

---------------
coherence (0.6.6.2-1ubuntu1) lucid; urgency=low

  * Added dh_install call to override_dh_install in debian/rules so
     dh_install will install /misc/org.Coherence.service into
     /usr/share/dbus-1/service. (LP: #352653)
 -- Charlie Smotherman <email address hidden> Sat, 23 Jan 2010 18:39:15 -0500

Changed in coherence (Ubuntu):
status: In Progress → Fix Released
Changed in coherence (Ubuntu):
assignee: Charlie_Smotherman (porthose) (cjsmo) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers