package python-coherence 0.6.2-1 failed to install/upgrade: subprocess post-installation script returned error exit status 1

Bug #347220 reported by Chris Jones on 2009-03-23
52
This bug affects 3 people
Affects Status Importance Assigned to Milestone
coherence (Debian)
Fix Released
Undecided
Unassigned
coherence (Ubuntu)
Medium
Unassigned

Bug Description

While upgrading a jaunty machine this morning:

Setting up python-coherence (0.6.2-1) ...
file does not exist: /usr/lib/python2.6/dist-packages/coherence/web/static/MochiKit.js
pycentral: pycentral pkginstall: error byte-compiling files (158)
pycentral pkginstall: error byte-compiling files (158)
dpkg: error processing python-coherence (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 python-coherence

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage: subprocess post-installation script returned error exit status 1
Package: python-coherence 0.6.2-1
PackageArchitecture: all
SourcePackage: coherence
Title: package python-coherence 0.6.2-1 failed to install/upgrade: subprocess post-installation script returned error exit status 1
Uname: Linux 2.6.28-11-generic i686

Related branches

Chris Jones (cmsj) wrote :
ariendj (ariendj) wrote :

I get the same error on Jaunty AMD64.

Sense Egbert Hofstede (sense) wrote :

I can confirm this bug, I'm experiencing this myself and there is a duplicate bug report.

Changed in coherence (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Rob Martin (robmartin) wrote :

can also confirm

Matthew McGowan (mmcg069) wrote :

i can confirm as well

+1 on my side ....

Changed in coherence:
status: Unknown → New
Charlie_Smotherman (cjsmo) wrote :

The actual problem is that libjs-mochikit installs to

/usr/share/javascript/mochikit/MockiKit

and not

/usr/share/javascript/mochikit/mochikit

Yes the capital "M" and "K" make a difference.

The sym link should be

/usr/share/javascript/mochikit/MochiKit.js /usr/share/pyshared/coherence/web/static/MochiKit.js

Changed in coherence (Ubuntu):
status: Confirmed → New
Xavier Fung (xavier114fch) wrote :

Ditto.

Setting up python-coherence (0.6.2-1) ...
file does not exist: /usr/lib/python2.5/site-packages/coherence/web/static/MochiKit.js
pycentral: pycentral pkginstall: error byte-compiling files (158)
pycentral pkginstall: error byte-compiling files (158)
dpkg: error processing python-coherence (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 python-coherence
E: Sub-process /usr/bin/dpkg returned an error code (1)

Chris Jones (cmsj) on 2009-03-24
Changed in coherence (Ubuntu):
status: New → Confirmed
Charlie_Smotherman (cjsmo) wrote :

Have tested this patch in an updated jaunty install. Attaching build logs and install logs. Please review.

Charlie_Smotherman (cjsmo) wrote :
Charlie_Smotherman (cjsmo) wrote :
Changed in coherence (Ubuntu):
status: Confirmed → New
Charlie_Smotherman (cjsmo) wrote :

Made changes per Lany's request attached new diff

Charlie_Smotherman (cjsmo) wrote :

changed changelog new diff attached

Luca Falavigna (dktrkranz) wrote :

Sponsored.

Changed in coherence (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package coherence - 0.6.2-1ubuntu1

---------------
coherence (0.6.2-1ubuntu1) jaunty; urgency=low

   * Changed debian/links to /usr/share/javascript/mochikit/MochiKit
     (LP: #347220)

 -- Charlie Smotherman <email address hidden> Mon, 23 Mar 2009 19:23:44 -0500

Changed in coherence:
status: Fix Committed → Fix Released
Changed in coherence (Debian):
importance: Unknown → Undecided
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.