Autopkgtest regression trigerred by Ruby 2.7

Bug #1866877 reported by Lucas Kanashiro
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
coderay (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

coderay version 1.1.2-2 has a regression in all architectures triggered by ruby-defaults/1:2.7~0.

autopkgtest log on amd64 as an example:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal/focal/amd64/c/coderay/20200305_182504_fb5da@/log.gz

Revision history for this message
Lucas Kanashiro (lucaskanashiro) wrote :

I uploaded coderay version 1.1.2-3 to Debian unstable [1] and it fixes this regression:

autopkgtest [19:13:22]: @@@@@@@@@@@@@@@@@@@@ summary
gem2deb-test-runner PASS

So when it lands in Debian unstable we just need to sync it.

[1] https://tracker.debian.org/news/1108174/accepted-coderay-112-3-source-into-unstable/

Revision history for this message
Lucas Kanashiro (lucaskanashiro) wrote :

Here it is my sync request for coderay version 1.1.2-3:

https://bugs.launchpad.net/ubuntu/+source/coderay/+bug/1867054

Revision history for this message
Lucas Kanashiro (lucaskanashiro) wrote :

Version 1.1.2-3 is already in Focal, so this test failure was already fixed.

Changed in coderay (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers