cobbler crashed with IOError in check_setup(): [Errno 5] Input/output error

Bug #840188 reported by Dave Walker
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cobbler (Ubuntu)
Medium
Andres Rodriguez

Bug Description

On upgrade this was encountered, believe it's in a respawn loop.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: cobbler 2.1.0+git20110602-0ubuntu23
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
NonfreeKernelModules: nvidia wl
Architecture: amd64
Date: Sat Sep 3 00:57:39 2011
ExecutablePath: /usr/bin/cobbler
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64+mac (20101218)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/cobbler profile list
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/cobbler', 'profile', 'list']
SourcePackage: cobbler
Title: cobbler crashed with IOError in check_setup(): [Errno 5] Input/output error
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

######################

caused by cobbler-web failing to install:

Module wsgi already enabled
ln: creating symbolic link `/usr/share/cobbler/webroot/cobbler_webui_content/Ubuntu-R.ttf': File exists
dpkg: error processing cobbler-web (--configure):
 subprocess installed post-installation script returned error exit status 1

Related branches

Revision history for this message
Dave Walker (davewalker) wrote :
tags: removed: need-duplicate-check
Dave Walker (davewalker)
visibility: private → public
description: updated
Changed in cobbler (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
Robie Basak (racb)
Changed in cobbler (Ubuntu):
importance: Undecided → Medium
Changed in cobbler (Ubuntu):
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cobbler - 2.1.0+git20110602-0ubuntu24

---------------
cobbler (2.1.0+git20110602-0ubuntu24) oneiric; urgency=low

  * debian/cobbler-web.postinst: Correctly handle creation/validation of
    links for the Ubuntu font for cobbler-web. (LP: #840188)
 -- Andres Rodriguez <email address hidden> Tue, 06 Sep 2011 14:11:49 -0400

Changed in cobbler (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers