Reposync dependency and permissions

Bug #710757 reported by Tony Lucas
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cobbler (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: cobbler

createrepo is not listed as a dependency but is if you are going to use repo's at all.

Also, one of the final steps of reposync is:

    cmd1 = "chown -R root:apache %s" % repo_path
        utils.subprocess_call(self.logger, cmd1)

Which fails because apache/httpd is running as www-data.

action_reposync.py is full of hardcoded issues like that.

Revision history for this message
Andres Rodriguez (andreserl) wrote :

Hi Tony!

Thank you for reporting bugs and trying to make Ubuntu better.

Could you please provide a Step by Step to be able to reproduce this bug, and if you can a trace?

Thank you!

Changed in cobbler (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Revision history for this message
Tony Lucas (tony-flexiant) wrote :

Install natty
apt-get update
apt-get install cobbler

(Add a repo, a fake empty one will do, it makes no difference):

cobbler repo add --name=test --mirror=/root/random (which is empty)
cobbler reposync

debug:

task started: 2011-02-02_151219_reposync
task started (id=Reposync, time=Wed Feb 2 15:12:19 2011)
hello, reposync
run, reposync, run!
running: rsync -rltDv --delete --exclude-from=/etc/cobbler/rsync.exclude /root/random/ /var/www/cobbler/repo_mirror/testrepo
received on stdout: sending incremental file list
./

sent 27 bytes received 15 bytes 84.00 bytes/sec
total size is 0 speedup is 0.00

recieved on stderr:
running: createrepo -c cache -s sha /var/www/cobbler/repo_mirror/testrepo
received on stdout:
recieved on stderr: /bin/sh: createrepo: not found

creating: /var/www/cobbler/repo_mirror/testrepo/config.repo
running: chown -R root:apache /var/www/cobbler/repo_mirror/testrepo
received on stdout:
recieved on stderr: chown: invalid group: `root:apache'

running: chmod -R 755 /var/www/cobbler/repo_mirror/testrepo
received on stdout:
recieved on stderr:
*** TASK COMPLETE ***

Fails both with not finding createrepo, as it's not installed, and the group is wrong for chown as well. That said it doesn't notice it's failed!

Revision history for this message
Chuck Short (zulcss) wrote :

This is the expected behavior when using cobbler with ubuntu since you are using createrepo. Createrepo is listed as a suggests so it will not get installed automatically.

Changed in cobbler (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cobbler - 2.1.0~bzr1998-0ubuntu1

---------------
cobbler (2.1.0~bzr1998-0ubuntu1) natty; urgency=low

  * New upstream release.
  * Dropped:
    - debian/patches/01-ubuntu-webroot.patch: Accepted upstream.
    - debian/patches/04-logfile-check.patch: Accepted upstream.
    - debian/patches/05_fix_init_paths.patch: Accepted upstream.
    - debian/patches/11_support-other-wol-tools.patch: Accepted upstream.
    - debian/patches/22_re-enable_debmirror.patch: Accepted upstream.
    - debian/patches/03-localboot-value.patch: Accepted upstream.
   * debian/control: Add python-all as a build dependency.
   * debian/patches/05_cobbler_fix_reposync_permissions.patch:
     Fix reposync permissions. (LP: #710757)
   * debian/patches/12_fix_dhcp_restart.patch: Fix dhcp restart.
     (LP: #709723)
 -- Chuck Short <email address hidden> Fri, 28 Jan 2011 14:39:12 -0500

Changed in cobbler (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers