Koan should not have dependency on cobbler

Bug #707113 reported by Konrad Scherer
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cobbler (Ubuntu)
Low
Dave Walker

Bug Description

Binary package hint: cobbler

The koan package currently depends on cobbler. This means that to install just koan, unnecessary programs like apache2, etc are also installed. Koan is a very simple python package that talks to the main cobbler server over XMLRPC.

It does have a dependency on libvirtd which is not captured in the current dependency hierarchy.

Related branches

Revision history for this message
Dave Walker (davewalker) wrote :

Confirmed, thanks for spotting this.

Changed in cobbler (Ubuntu):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Dave Walker (davewalker)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cobbler - 2.1.0~bzr1988-0ubuntu1

---------------
cobbler (2.1.0~bzr1988-0ubuntu1) natty; urgency=low

  [Chuck Short]
  * New upstram release.
  * Re-added get-orig-source to make it easier to make a tarball.
  * Dropped 02_install-layout.patch
  * Added Debian/README.Source
  * Reworked webroot patch
  * debian/cobbler-common.install: Don't put the init script
    in /etc/cobbler. (LP: #705441)
  * debian/patches/05_fix_init_paths.patch: Don't hard code init paths
    (LP: #706995)

  [Dave Walker (Daviey)]
  * debian/control: For binary package koan, do not depend on cobbler as it should
    be functional separately. However, the additional dependency of libvirt-bin
    has been added. (LP: #707113)

  [ Clint Byrum ]
  * debian/patches/series: remove 02_install-layout.patch
 -- Clint Byrum <email address hidden> Tue, 25 Jan 2011 16:46:04 -0800

Changed in cobbler (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers