cobbler fails to install with error code 1

Bug #1001846 reported by airtonix
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cobbler (Ubuntu)
High
Andres Rodriguez
Precise
High
Unassigned
Quantal
High
Andres Rodriguez

Bug Description

From http://ubuntuforums.org/showthread.php?t=1982943:

Setting up cobbler (2.2.2-0ubuntu33) ...
Usage: ip addr {add|change|replace} IFADDR dev STRING [ LIFETIME ]
                                                      [ CONFFLAG-LIST ]
       ip addr del IFADDR dev STRING
       ip addr {show|flush} [ dev STRING ] [ scope SCOPE-ID ]
                            [ to PREFIX ] [ FLAG-LIST ] [ label PATTERN ]
IFADDR := PREFIX | ADDR peer PREFIX
          [ broadcast ADDR ] [ anycast ADDR ]
          [ label STRING ] [ scope SCOPE-ID ]
SCOPE-ID := [ host | link | global | NUMBER ]
FLAG-LIST := [ FLAG-LIST ] FLAG
FLAG := [ permanent | dynamic | secondary | primary |
           tentative | deprecated | dadfailed | temporary |
           CONFFLAG-LIST ]
CONFFLAG-LIST := [ CONFFLAG-LIST ] CONFFLAG
CONFFLAG := [ home | nodad ]
LIFETIME := [ valid_lft LFT ] [ preferred_lft LFT ]
LFT := forever | SECONDS
dpkg: error processing cobbler (--configure):
 subprocess installed post-installation script returned error exit status 255
Errors were encountered while processing:
 cobbler
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: cobbler 2.2.2-0ubuntu33
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: rr64x zfs zcommon znvpair zavl zunicode
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Sun May 20 13:42:26 2012
InstallationMedia: Ubuntu-Server 12.04 LTS "Precise Pangolin" - Release amd64 (20120424.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_AU:en
 TERM=screen
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: cobbler
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
airtonix (airtonix-gmail) wrote :
Aditya V (kroq-gar78)
description: updated
summary: - apt-get install fails
+ cobbler fails to install with error code 1
Dave Walker (davewalker)
Changed in cobbler (Ubuntu):
importance: Undecided → High
assignee: nobody → Andres Rodriguez (andreserl)
Revision history for this message
Andres Rodriguez (andreserl) wrote :

Hi there,

Thank you for taking the time to report bugs and trying to make Ubuntu better.

I am a little confused on why this bug report is present. I'm wondering whether you were using any special HW configuration or any special OS configuration as I have been unable to reproduce this bug report, and having had installed cobbler many times on various different architectures, and not once I had these issues, I was wondering if there's something I'm missing.

Regards,

Revision history for this message
Andres Rodriguez (andreserl) wrote :

Oh, forgot to say. Please edit the following file:

sudo vim /var/lib/dpkg/info/cobbler.config

and add 'x' to the first line:

#! /bin/sh -e

So it looks like:

#! /bin/sh -ex

Once this is done, do:

sudo dpkg-reconfigure cobbler

Answer the questions and please paste the output as that information will help us determine what the issue might be.

Revision history for this message
airtonix (airtonix-gmail) wrote : Re: [Bug 1001846] Re: cobbler fails to install with error code 1

Thanks for the reply, i'll perform these actions but please for the love of
all that is sane never suggest to use vim, it is a most horribly
frustrating text editor.
this isn't gentoo after all.
On May 22, 2012 11:50 PM, "Andres Rodriguez" <email address hidden>
wrote:

> Oh, forgot to say. Please edit the following file:
>
> sudo vim /var/lib/dpkg/info/cobbler.config
>
> and add 'x' to the first line:
>
> #! /bin/sh -e
>
> So it looks like:
>
> #! /bin/sh -ex
>
> Once this is done, do:
>
> sudo dpkg-reconfigure cobbler
>
> Answer the questions and please paste the output as that information
> will help us determine what the issue might be.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1001846
>
> Title:
> cobbler fails to install with error code 1
>
> Status in “cobbler” package in Ubuntu:
> New
>
> Bug description:
> From http://ubuntuforums.org/showthread.php?t=1982943:
>
> Setting up cobbler (2.2.2-0ubuntu33) ...
> Usage: ip addr {add|change|replace} IFADDR dev STRING [ LIFETIME ]
> [ CONFFLAG-LIST ]
> ip addr del IFADDR dev STRING
> ip addr {show|flush} [ dev STRING ] [ scope SCOPE-ID ]
> [ to PREFIX ] [ FLAG-LIST ] [ label PATTERN ]
> IFADDR := PREFIX | ADDR peer PREFIX
> [ broadcast ADDR ] [ anycast ADDR ]
> [ label STRING ] [ scope SCOPE-ID ]
> SCOPE-ID := [ host | link | global | NUMBER ]
> FLAG-LIST := [ FLAG-LIST ] FLAG
> FLAG := [ permanent | dynamic | secondary | primary |
> tentative | deprecated | dadfailed | temporary |
> CONFFLAG-LIST ]
> CONFFLAG-LIST := [ CONFFLAG-LIST ] CONFFLAG
> CONFFLAG := [ home | nodad ]
> LIFETIME := [ valid_lft LFT ] [ preferred_lft LFT ]
> LFT := forever | SECONDS
> dpkg: error processing cobbler (--configure):
> subprocess installed post-installation script returned error exit status
> 255
> Errors were encountered while processing:
> cobbler
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: cobbler 2.2.2-0ubuntu33
> ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
> Uname: Linux 3.2.0-24-generic x86_64
> NonfreeKernelModules: rr64x zfs zcommon znvpair zavl zunicode
> ApportVersion: 2.0.1-0ubuntu7
> Architecture: amd64
> Date: Sun May 20 13:42:26 2012
> InstallationMedia: Ubuntu-Server 12.04 LTS "Precise Pangolin" - Release
> amd64 (20120424.1)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=en_AU:en
> TERM=screen
> PATH=(custom, user)
> LANG=en_AU.UTF-8
> SHELL=/bin/bash
> SourcePackage: cobbler
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/cobbler/+bug/1001846/+subscriptions
>

Revision history for this message
airtonix (airtonix-gmail) wrote :

$ sudo dpkg-reconfigure cobbler
/usr/sbin/dpkg-reconfigure: cobbler is broken or not fully installed

Revision history for this message
airtonix (airtonix-gmail) wrote :

$ sudo apt-get install cobbler
Reading package lists... Done
Building dependency tree
Reading state information... Done
cobbler is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up cobbler (2.2.2-0ubuntu33) ...
+ . /usr/share/debconf/confmodule
+ [ ! 1 ]
+ [ -z ]
+ exec
+ [ ]
+ exec
+ DEBCONF_REDIR=1
+ export DEBCONF_REDIR
+ db_version 2.0
+ _db_cmd VERSION 2.0
+ _db_internal_IFS=

+ IFS=
+ printf %s\n VERSION 2.0
+ IFS=

+ IFS=
 read -r _db_internal_line
+ RET=2.0
+ return 0
+ [ configure = configure ]
+ [ -z ]
+ db_input low cobbler/password
+ _db_cmd INPUT low cobbler/password
+ _db_internal_IFS=

+ IFS=
+ printf %s\n INPUT low cobbler/password
+ IFS=

+ IFS=
 read -r _db_internal_line
+ RET=30 question skipped
+ return 30
+ true
+ db_go
+ _db_cmd GO
+ _db_internal_IFS=

+ IFS=
+ printf %s\n GO
+ IFS=

+ IFS=
 read -r _db_internal_line
+ RET=ok
+ return 0
+ read Iface Destination Gateway Flags RefCnt Use Metric Mask MTU Window IRTT
+ [ Mask = 00000000 ]
+ read Iface Destination Gateway Flags RefCnt Use Metric Mask MTU Window IRTT
+ [ 00FFFFFF = 00000000 ]
+ read Iface Destination Gateway Flags RefCnt Use Metric Mask MTU Window IRTT
+ [ 00FFFFFF = 00000000 ]
+ read Iface Destination Gateway Flags RefCnt Use Metric Mask MTU Window IRTT
+ [ FFFFFFFF = 00000000 ]
+ read Iface Destination Gateway Flags RefCnt Use Metric Mask MTU Window IRTT
+ interface=
+ LC_ALL=C /sbin/ip -4 addr list dev scope global
Usage: ip addr {add|change|replace} IFADDR dev STRING [ LIFETIME ]
                                                      [ CONFFLAG-LIST ]
       ip addr del IFADDR dev STRING
       ip addr {show|flush} [ dev STRING ] [ scope SCOPE-ID ]
                            [ to PREFIX ] [ FLAG-LIST ] [ label PATTERN ]
IFADDR := PREFIX | ADDR peer PREFIX
          [ broadcast ADDR ] [ anycast ADDR ]
          [ label STRING ] [ scope SCOPE-ID ]
SCOPE-ID := [ host | link | global | NUMBER ]
FLAG-LIST := [ FLAG-LIST ] FLAG
FLAG := [ permanent | dynamic | secondary | primary |
           tentative | deprecated | dadfailed | temporary |
           CONFFLAG-LIST ]
CONFFLAG-LIST := [ CONFFLAG-LIST ] CONFFLAG
CONFFLAG := [ home | nodad ]
LIFETIME := [ valid_lft LFT ] [ preferred_lft LFT ]
LFT := forever | SECONDS
+ ipaddr=
dpkg: error processing cobbler (--configure):
 subprocess installed post-installation script returned error exit status 255
Errors were encountered while processing:
 cobbler
E: Sub-process /usr/bin/dpkg returned an error code (1)

Revision history for this message
Scott Moser (smoser) wrote :

airtonix,
  could you please provide /proc/net/route of the system that you're seeing this issue on?

roaksoax,
  I've marked this as 'confirmed'. the postinst script is failing. Additionally, if I'm reading it right,
   a.) it would fail even if the value had been pre-seeded (ie, there was no reason to try to detect).
   b.) it tries to handle "failed to get address" case (by db_input) but due to 'set -e', the script fails when $interface is empty.

Changed in cobbler (Ubuntu):
status: New → Confirmed
Revision history for this message
airtonix (airtonix-gmail) wrote :

On Fri 25 May 2012 00:17:19 CST, Scott Moser wrote:
> airtonix,
> could you please provide /proc/net/route of the system that you're seeing this issue on?
>
> roaksoax,
> I've marked this as 'confirmed'. the postinst script is failing. Additionally, if I'm reading it right,
> a.) it would fail even if the value had been pre-seeded (ie, there was no reason to try to detect).
> b.) it tries to handle "failed to get address" case (by db_input) but due to 'set -e', the script fails when $interface is empty.
>
> ** Changed in: cobbler (Ubuntu)
> Status: New => Confirmed
>

Scott,

Iface Destination Gateway Flags RefCnt Use Metric
Mask MTU Window IRTT
eth1 0000000A 00000000 0001 0 0 0
00FFFFFF 0 0 0
virbr0 007AA8C0 00000000 0001 0 0 0
00FFFFFF 0 0 0
ppp0 AED710CB 00000000 0005 0 0 0
FFFFFFFF 0 0 0

Revision history for this message
Andres Rodriguez (andreserl) wrote :

Hi There,

Sorry for the late reply. Would you be able to test the following patch in order to verify this has been fixed? The patch can be found in [1].

Once the patch is applied and you should be able to do:

sudo apt-get -f install

or

sudo dpkg --configure -a

and the installation will resume. Once this is done, please check that the server: and next_server: value have been updated correctly in /etc/cobbler/settings.

Thanks again!
[1]: http://paste.ubuntu.com/1037548/

Revision history for this message
Henrik Blidh (henrik-n1b) wrote :

Hello,

I have had the same problem, with the same error output as above. I had a fresh install of 12.04 server, updated once and nothing else extra installed. I applied the "-ex" modification and the patch described, continued the installation, reconfigured the packages and now it seems to work; server and next_server got the correct values in /etc/cobbler/settings.

Thank you very much for your help.
Henrik

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cobbler - 2.2.2-0ubuntu34

---------------
cobbler (2.2.2-0ubuntu34) quantal; urgency=low

  * debian/cobbler.config: Do not fail to install if cannot determine
    default IP address. (LP: #1001846)
 -- Andres Rodriguez <email address hidden> Fri, 29 Jun 2012 16:29:21 -0400

Changed in cobbler (Ubuntu Quantal):
status: Confirmed → Fix Released
Revision history for this message
Kate Stewart (kate.stewart) wrote :

milestone this and prioiritize it for precise, so we can confirm fixed. (or fix it).

Changed in cobbler (Ubuntu Precise):
importance: Undecided → High
milestone: none → ubuntu-12.04.1
Dave Walker (davewalker)
Changed in cobbler (Ubuntu Precise):
milestone: ubuntu-12.04.1 → precise-updates
Revision history for this message
Bryan Fullerton (fehwalker) wrote :

Confirmed issue still exists in current precise.

Changed in cobbler (Ubuntu Precise):
status: New → Confirmed
Revision history for this message
Bryan Fullerton (fehwalker) wrote :

Pushed branch with same fix as done on quantal, tested locally with pbuilder, seems to resolve issue.

Let me know if I'm doing this wrong, it's my first time. :)

Changed in cobbler (Ubuntu Precise):
assignee: nobody → Bryan Fullerton (fehwalker)
status: Confirmed → In Progress
Changed in cobbler (Ubuntu Precise):
status: In Progress → Fix Committed
Revision history for this message
James Page (james-page) wrote :

Hi Bryan

I've marked this bug as 'In Progress' for the time being; cobbler currently has a pending SRU in proposed and this fix needs to be re-based ontop of that once it lands (see comments in merge proposal).

In the meantime it would be great if you could populate the bug report with the information the Stable Release Updates team require before they will accept a fix into precise-proposed:

https://wiki.ubuntu.com/StableReleaseUpdates

Cheers

James

Revision history for this message
Bryan Fullerton (fehwalker) wrote :

I'm planning to work on documentation updates until Raring string freeze, so if someone else wants to pick this up before then feel free.

Changed in cobbler (Ubuntu Precise):
assignee: Bryan Fullerton (fehwalker) → nobody
status: Fix Committed → Confirmed
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Now that -proposed is clear, Please update the description as per https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

Specifically please list exact steps to reproduce the problem such that it is easy to test that proposed patch resolves the issue on precise as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers