Ubuntu

cmus crashes due to "segmentation fault" while building a library

Reported by Thrilway on 2010-09-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cmus (Ubuntu)
Medium
Johannes W

Bug Description

Binary package hint: cmus

Sysem: Ubuntu 10.04.1 LTS
cmus 2.2.0-4ubuntu3

Expected:
cmus builds a library

What happened instead:
cmus crashed and reported a "segmentation fault"

dmesg reported:
"cmus[15930]: segfault at 0 ip 00d94ef7 sp b65f05a0 error 4 in flac.so[d94000+2000]"

Alessio Treglia (quadrispro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug seems fixed in the latest development version of Ubuntu - Maverick Meerkat.
Please re-open if not so.

Changed in cmus (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released
Thrilway (dan-milway) wrote :

I've upgraded to Maverick and the issue persists

Changed in cmus (Ubuntu):
status: Fix Released → New

What version of cmus are you using?

cmus 2.3.3-2build1

On Fri, Oct 15, 2010 at 12:36 PM, Gregory Petrosyan <
<email address hidden>> wrote:

> What version of cmus are you using?
>
> --
> cmus crashes due to "segmentation fault" while building a library
> https://bugs.launchpad.net/bugs/635231
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “cmus” package in Ubuntu: New
>
> Bug description:
> Binary package hint: cmus
>
> Sysem: Ubuntu 10.04.1 LTS
> cmus 2.2.0-4ubuntu3
>
> Expected:
> cmus builds a library
>
> What happened instead:
> cmus crashed and reported a "segmentation fault"
>
> dmesg reported:
> "cmus[15930]: segfault at 0 ip 00d94ef7 sp b65f05a0 error 4 in
> flac.so[d94000+2000]"
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/cmus/+bug/635231/+subscribe
>

On Fri, Oct 15, 2010 at 11:03 PM, Thrilway <email address hidden> wrote:
> cmus 2.3.3-2build1

Thanks!

Can you please build a debug version of cmus from source
(http://gitorious.org/cmus)? You'll need PulseAudio, FLAC and ncursesw
-dev packages from the Ubuntu repository to do it:

./configure DEBUG=2
make
sudo make install

After this, can you run it under GDB in order to get stacktrace? Also,
~/cmus-debug.txt can contain helpful information.

Or, if that sounds like a lot of work, can you please find a guilty
.flac file (using binary search) and send it to me, so that I can
reproduce the problem?

                Gregory

Thrilway (dan-milway) wrote :

Here's the stacktrace.

Dan

On Fri, Oct 15, 2010 at 5:43 PM, Gregory Petrosyan <
<email address hidden>> wrote:

> On Fri, Oct 15, 2010 at 11:03 PM, Thrilway <email address hidden>
> wrote:
> > cmus 2.3.3-2build1
>
> Thanks!
>
> Can you please build a debug version of cmus from source
> (http://gitorious.org/cmus)? You'll need PulseAudio, FLAC and ncursesw
> -dev packages from the Ubuntu repository to do it:
>
> ./configure DEBUG=2
> make
> sudo make install
>
> After this, can you run it under GDB in order to get stacktrace? Also,
> ~/cmus-debug.txt can contain helpful information.
>
> Or, if that sounds like a lot of work, can you please find a guilty
> .flac file (using binary search) and send it to me, so that I can
> reproduce the problem?
>
> Gregory
>
> --
> cmus crashes due to "segmentation fault" while building a library
> https://bugs.launchpad.net/bugs/635231
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “cmus” package in Ubuntu: New
>
> Bug description:
> Binary package hint: cmus
>
> Sysem: Ubuntu 10.04.1 LTS
> cmus 2.2.0-4ubuntu3
>
> Expected:
> cmus builds a library
>
> What happened instead:
> cmus crashed and reported a "segmentation fault"
>
> dmesg reported:
> "cmus[15930]: segfault at 0 ip 00d94ef7 sp b65f05a0 error 4 in
> flac.so[d94000+2000]"
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/cmus/+bug/635231/+subscribe
>

Do other players handle this file well?

From stacktrace, it looks like cmus assumes that the file has more channels than it actually does, and this leads to segfault when accessing non-existing buffer.

Thrilway (dan-milway) wrote :

Rhythmbox adds it to the library and plays it without issue.
neither vlc or xine could play it.

On Sun, Oct 17, 2010 at 2:48 PM, Gregory Petrosyan <
<email address hidden>> wrote:

> Do other players handle this file well?
>
> >From stacktrace, it looks like cmus assumes that the file has more
> channels than it actually does, and this leads to segfault when
> accessing non-existing buffer.
>
> --
> cmus crashes due to "segmentation fault" while building a library
> https://bugs.launchpad.net/bugs/635231
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “cmus” package in Ubuntu: New
>
> Bug description:
> Binary package hint: cmus
>
> Sysem: Ubuntu 10.04.1 LTS
> cmus 2.2.0-4ubuntu3
>
> Expected:
> cmus builds a library
>
> What happened instead:
> cmus crashed and reported a "segmentation fault"
>
> dmesg reported:
> "cmus[15930]: segfault at 0 ip 00d94ef7 sp b65f05a0 error 4 in
> flac.so[d94000+2000]"
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/cmus/+bug/635231/+subscribe
>

Johannes W (jmuc) on 2011-03-27
Changed in cmus (Ubuntu):
assignee: nobody → Johannes W (jmuc)
Johannes W (jmuc) on 2011-03-27
Changed in cmus (Ubuntu):
status: New → Confirmed
Johannes W (jmuc) wrote :

I sent a patch to cmus-devel (attached), so hopefully the bug can be closed soon. Thanks for reporting!

tags: added: patch
Johannes W (jmuc) wrote :

I'm closing the bug since it is fixed in the latest development version of Ubuntu - Oneiric Ocelot:
https://launchpad.net/ubuntu/oneiric/+source/cmus

For older versions of Ubuntu, you can use the package from my PPA:
https://launchpad.net/~jmuc/+archive/cmus

Changed in cmus (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments