zlib.h version fix should be cherry-picked

Bug #692595 reported by Steveire on 2010-12-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cmake (Ubuntu)
High
Unassigned
Maverick
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: cmake

KDevelop is so slow as to be unusable if loading any project which uses zlib. The reason is a change in the version string in zlib.h to have four components instead of three.

http://www.itk.org/Bug/view.php?id=11049

http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=4dfa612e068fc82b444e1df53364b85c405264d9;hp=5c16024fbb3388f8345683263c584f5518fdfa55

Please cherry-pick the fix into an update for maverick

git cherry-pick 5850b8b79a813dbe8ad380c88878260cae3d7cbc

Thanks.

TEST CASE: Open a project that uses zlib in kdevelop. Watch it be insanely slow and unusable. Install package from -proposed. Try again and be productive.

Scott Kitterman (kitterman) wrote :

Confirmed that we have the relevant zlib version in both Maverick and Natty.

Changed in cmake (Ubuntu):
importance: Undecided → High
milestone: none → natty-alpha-2
status: New → Confirmed
Changed in cmake (Ubuntu Maverick):
status: New → Confirmed
importance: Undecided → High
milestone: none → maverick-updates
tags: added: maverick regression-release
Scott Kitterman (kitterman) wrote :

cmake 2.8.3 sync'ed into Natty fixes this.

Changed in cmake (Ubuntu Natty):
status: Confirmed → Fix Released
Scott Kitterman (kitterman) wrote :

Fix uploaded for maverick-proposed. Now we need to wait for ubuntu-sru to review and accept the change.

description: updated

Accepted cmake into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in cmake (Ubuntu Maverick):
status: Confirmed → Fix Committed
tags: added: verification-needed
Steveire (steveire) wrote :

I'm not sure I can test the package in proposed, because I have backports enabled, and I seem to already have cmake 2.8.3 through that.

Steveire (steveire) wrote :

I downgraded to cmake-2.8.2-2 and kdevelop was still working at acceptable speeds:

stephen@bishop:~/Random/cmakedebs$ ls
cmake_2.8.2-2ubuntu0.1_i386.deb cmake-data_2.8.2-2ubuntu0.1_all.deb
stephen@bishop:~/Random/cmakedebs$ sudo dpkg -i *.deb
[sudo] password for stephen:
dpkg: warning: downgrading cmake from 2.8.3-1~maverick1 to 2.8.2-2ubuntu0.1.
(Reading database ... 270667 files and directories currently installed.)
Preparing to replace cmake 2.8.3-1~maverick1 (using cmake_2.8.2-2ubuntu0.1_i386.deb) ...
Unpacking replacement cmake ...
dpkg: warning: downgrading cmake-data from 2.8.3-1~maverick1 to 2.8.2-2ubuntu0.1.
Preparing to replace cmake-data 2.8.3-1~maverick1 (using cmake-data_2.8.2-2ubuntu0.1_all.deb) ...
remove/cmake-data: Purging byte-compiled files for emacs22
Unpacking replacement cmake-data ...
Setting up cmake-data (2.8.2-2ubuntu0.1) ...
emacsen-common: Handling install of emacsen flavor emacs
emacsen-common: Handling install of emacsen flavor emacs22
emacsen-common: byte-compiling for emacs22
Wrote /etc/emacs22/site-start.d/00debian-vars.elc
Wrote /usr/share/emacs22/site-lisp/debian-startup.elc
install/cmake-data: Byte-compiling for emacs22
Wrote /usr/share/emacs22/site-lisp/cmake-data/cmake-mode.elc
Processing triggers for man-db ...
Setting up cmake (2.8.2-2ubuntu0.1) ...
stephen@bishop:~/Random/cmakedebs$ apt-cache policy cmake
cmake:
  Installed: 2.8.2-2ubuntu0.1
  Candidate: 2.8.3-1~maverick1
  Version table:
     2.8.3-1~maverick1 0
        500 http://de.archive.ubuntu.com/ubuntu/ maverick-backports/main i386 Packages
 *** 2.8.2-2ubuntu0.1 0
        100 /var/lib/dpkg/status
     2.8.2-2 0
        500 http://de.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

Scott Kitterman (kitterman) wrote :

Thank you for verifying the fix.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cmake - 2.8.2-2ubuntu0.1

---------------
cmake (2.8.2-2ubuntu0.1) maverick-proposed; urgency=low

  * Cherry pick 5850b8b79a813dbe8ad380c88878260cae3d7cbc from cmake 2.8.3 to
    fix zlib.h processing to that using kdevelop for projects that use zlib is
    not unusably slow (LP: #692595)
 -- Scott Kitterman <email address hidden> Mon, 20 Dec 2010 11:25:26 -0500

Changed in cmake (Ubuntu Maverick):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers