std::bad_alloc during SVN update in CTest

Bug #1835723 reported by Miroslav Matějů on 2019-07-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cmake (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
* Users using ctest cmake feature

[Test Case]
* Compile in a row
git clone https://github.com/gismo/gismo/
cd gismo
mkdir build
cd build
cmake .. -DGISMO_BUILD_UNITTESTS=ON
make -j 8

after some attempts it might fail

[Regression Potential]
* Low, this is part of upstream codebase since years, and its a crash fix

[Other Info]
After I upgraded my testing server from 16.04 to Ubuntu 18.04.2 LTS the last week, I keep getting errors during SVN update while running CTest (version 3.10.2) which cause CTest to quit too early:

terminate called after throwing an instance of 'std::bad_alloc'
  what(): std::bad_alloc
Aborted (core dumped)

This does not affect every run, yet it happens pretty often – I found this error in 6 out of 8 runs during the last night.

CMake’s bug tracker claims this to have been fixed in CMake 3.11 (https://gitlab.kitware.com/cmake/cmake/issues/17854) but Ubuntu 18.04 is sticking with 3.10.

Installing the most recent CMake 3.14.5 from https://cmake.org/download/ (as per https://askubuntu.com/a/952929/250300) fixed the issue for me.

Changed in cmake (Ubuntu):
status: New → Fix Released

@Miroslav, please add a simpler test case instead of the upstream one!

description: updated

Hello Miroslav, or anyone else affected,

Accepted cmake into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cmake/3.10.2-1ubuntu2.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cmake (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

I installed the new cmake on my main bionic laptop, no regressions so far!

Looks like gismo didn't crash cmake in my tests!

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cmake - 3.10.2-1ubuntu2.18.04.1

---------------
cmake (3.10.2-1ubuntu2.18.04.1) bionic; urgency=medium

  * debian/patches/1893.patch:
    - cherry-pick upstream fix for ctest update bug
      LP: #1835723

 -- Gianfranco Costamagna <email address hidden> Sat, 13 Jul 2019 09:20:52 +0200

Changed in cmake (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cmake has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers