cmake: upstream patch should use 10 instead of 1.10 for java version comparison

Bug #1766649 reported by Tiago Stürmer Daitx on 2018-04-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cmake (Ubuntu)
High
Gianfranco Costamagna

Bug Description

The patch debian/patches/3c08d2075fae7ef62838f18e1af5d398c6401572.diff in cmake version 3.10.2-1ubuntu1 from upstream uses "1.10" for version comparison which won't work for OpenJDK because from openjdk-9 upwards the version has dropped the leading "1.".

This means the current comparison fails and cmake cannot properly detect when javah is unavaiable, causing packages that depend on it to FTBFS (eg. ceph).

Tiago Stürmer Daitx (tdaitx) wrote :

update the upstream patch to use "10" instead of "1.10" for version comparison.

tags: added: patch
description: updated

The attachment "cmake_3.10.2-1ubuntu1_debdiff_3.10.2-1ubuntu2.patch" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

Uploaded, where is the upstrea bug?

Changed in cmake (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → LocutusOfBorg (costamagnagianfranco)
tags: added: block-proposed
tags: removed: block-proposed

Adding block because this seems to be not working properly

tags: added: block-proposed
Tiago Stürmer Daitx (tdaitx) wrote :

Bug has been reported upstream at https://gitlab.kitware.com/cmake/cmake/issues/17938

Steve Langasek (vorlon) wrote :

block-proposed is for critical regressions that must not be allowed to reach the release pocket.

tags: removed: block-proposed
Steve Langasek (vorlon) wrote :

Also, from what we've been able to determine on IRC, the only evidence of this "not working" was a test build of ceph in a ppa which did not have -proposed enabled in its dependencies; so that doesn't add any new information about whether this works.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cmake - 3.10.2-1ubuntu2

---------------
cmake (3.10.2-1ubuntu2) bionic; urgency=medium

  * Fix java version comparison in upstream commit. LP: #1766649.
    - FindJava: use "10" instead of "1.10".

 -- Tiago Stürmer Daitx <email address hidden> Tue, 24 Apr 2018 15:47:53 +0000

Changed in cmake (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers