QGIS compilation fails only on Wily

Bug #1527722 reported by Luigi Pirelli
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
cmake (Ubuntu)
Undecided
Unassigned

Bug Description

As stated in this pull request, seems that QGIS compilation fail only under Wily due to some problem in the Ubuntu compilation stack

https://github.com/qgis/QGIS/pull/2587

this happen only uçon Wily (15.10) and notin other Ubuntu versions or other distribution like Debian.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1527722/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Revision history for this message
Jürgen E. Fischer (jef-norbit) wrote :

only wily/amd64 is affected - wily/i386 works fine, as do precise, trusty, vivid and Debian jessie, stretch and unstable.

Revision history for this message
Jürgen E. Fischer (jef-norbit) wrote :

 but it's unclear if the bug is in cmake, make or some other part of the toolchain.

summary: - QGIS compilation fail only on Wily
+ QGIS compilation fail only on Wily/amd64
affects: ubuntu → qgis (Ubuntu)
Revision history for this message
Jürgen E. Fischer (jef-norbit) wrote : Re: QGIS compilation fail only on Wily/amd64

Brian: Are you positive this is a qgis problem? As said it only appears on wily/amd64 and it doesn't even apply to qgis 2.8 (which builds fine even on wily/amd64). I think it's related to automoc - so something in the conjunction of cmake and Qt - hence the unspecific assignment to "ubuntu"

Revision history for this message
Johan Van de Wauw (johanvdw) wrote :

Can you post a buildlog where compilation fails?

I suppose this is actually the same bug which we had in debian testing:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=806324#74

"
 The problem is just that libQtUiTools.a has been built with the
 binutils from unstable, which introduce new relocation types. The .o
 object files (and thus static libraries) generated by binutils from
 unstable therefore can't be processed by the one from testing.
"

Revision history for this message
Luigi Pirelli (luipir) wrote :

Hi Johan

I'll provide buildlog soon... please let me know if it's enough the stdout of the QGIS build process of do you need more?

Revision history for this message
Jürgen E. Fischer (jef-norbit) wrote :

build log of wily-amd64 from the master nightly.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qgis (Ubuntu):
status: New → Confirmed
Revision history for this message
Jürgen E. Fischer (jef-norbit) wrote :

Downgrading to vivid's cmake helps, while upgrading to xenial's cmake doesn't.

affects: qgis (Ubuntu) → cmake (Ubuntu)
Revision history for this message
Jürgen E. Fischer (jef-norbit) wrote :

Now it also affects i386.

summary: - QGIS compilation fail only on Wily/amd64
+ QGIS compilation fails only on Wily
Revision history for this message
Luigi Pirelli (luipir) wrote :

viral ;)

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Hi, can you please try xenial cmake again? we bringed 3.5.1 a few minutes ago.

Changed in cmake (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Jürgen E. Fischer (jef-norbit) wrote :

it builds fine with xenial's cmake.

Changed in cmake (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.