clutter-imcontext version 0.1.4-2 FTBFS on armhf in precise

Bug #935054 reported by Andreas Moog on 2012-02-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
clutter-imcontext (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

This is a semi-automatic report based on the latest archive rebuild results [1].
Apologies if it reaches you in error.

Excerpt from the buildlog:

checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) none
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for glib-genmarshal... /usr/bin/glib-genmarshal
checking for CLUTTER... no
configure: error: Package requirements (glib-2.0
   clutter-1.0 >= 1.0.0) were not met:

Package x11-xcb was not found in the pkg-config search path.
Perhaps you should add the directory containing `x11-xcb.pc'
to the PKG_CONFIG_PATH environment variable
Package 'x11-xcb', required by 'egl', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables CLUTTER_CFLAGS
and CLUTTER_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
make: *** [debian/stamp-autotools] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20120206-1721
FAILED [dpkg-buildpackage died]

The full buidlog can be found at https://launchpad.net/ubuntu/+archive/test-rebuild-20120201/+build/3141981/+files/buildlog_ubuntu-precise-armhf.clutter-imcontext_0.1.4-2_FAILEDTOBUILD.txt.gz.

[1] http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20120201-precise.html

Andreas Moog (ampelbein) on 2012-02-18
Changed in clutter-imcontext (Ubuntu):
importance: Undecided → High
tags: added: arm-porting-queue
Logan Rosen (logan) wrote :

This appears to be an issue that was fixed. It built properly in a later 0.1.4-2build1: https://launchpad.net/ubuntu/+source/clutter-imcontext/0.1.4-2build1/+build/3247940

Changed in clutter-imcontext (Ubuntu):
status: New → Fix Released
Changed in clutter-imcontext (Ubuntu Precise):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers