The io.elementary.camera package installs on Ubuntu Disk 19.04 normally, but does not open the video image.

Bug #1818902 reported by Edson José dos Santos on 2019-03-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
clutter-gst-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Hello guys

I installed the io.elementary.camera package from Elementary OS on Ubuntu Disk 19.04 normally, but message appears that it does not recognize the webcam. Note I have the Juno Elementary OS installed on the same machine and the Webcam works normally.

I installed through the repository:

sudo add-apt-repository ppa: elementary-os / daily
sudo apt update
sudo apt install io.elementary.camera

In the description, there is the option pantheon-camera, but this one says to be with broken package and does not install. Could it be this that does not let the webcam work? Look!

sudo apt install pantheon-camera
[sudo] password for edson:
Reading package lists ... Ready
Building dependency tree
Reading status information ... Ready
Some packages could not be installed. This may mean that
you asked for an impossible situation or, if you are using the
unstable distribution, that some required packages have not been created yet or have been removed from Incoming.
The following information may help resolve the situation:

The following packages have mismatched dependencies:
pantheon-camera: Depends: io.elementary.camera but will not install
E: Impossible to fix problems, you kept (hold) broken packages.

Note When I enter synaptcis there is no broken package.

If you uninstall io.elementary.camera and try to install the pantheon-camera the same broken package information appears.

The installation of io.elementary.camera is performed successfully on Ubuntu 19.04 Disk, but does not appear the image of the video and nor does it recognize the webcam, video attachments.

When you try to open the camera through the terminal the following error message appears:

edson @ edson-p6540br: ~ $ io.elementary.camera

(io.elementary.camera:10218): Clutter-WARNING **: 16: 43: 29.698: Whoever translated default: LTR did so wrongly.

(io.elementary.camera:10218): Clutter-Gst-CRITICAL **: 16: 43: 29.753: Unable to setup device without element factory, node and name set 0x55a19aa51200 0x7fc2ec00e240 (nil)
edson @ edson-p6540br: ~ $

I ask you to forward the responsible team so that the correction can be carried out.

Thank you

There is no broken package regarding the pantheon-camera or io.elementary.camera

Manfred Hampl (m-hampl) wrote :

Not related to camera-app (Ubuntu) but io.elementary.camera from the elementary OS PPA.

Changed in camera-app (Ubuntu):
status: New → Invalid
Chris Mayo (chris-mayo) wrote :

I think a change in Ubuntu broke ClutterGstCamera.

I don't use io.elementary.camera but have my own program that also uses ClutterGstCamera. Up until about a month ago it was working fine on 18.04. Now it gives the same error:

Clutter-Gst-CRITICAL **: Unable to setup device without element factory, node and name set 0x2c83820 0x2fe26f0 (nil)

It doesn't work on 19.04 either. Still works on Gentoo Linux.

affects: camera-app (Ubuntu) → clutter-gst-3.0 (Ubuntu)
Changed in clutter-gst-3.0 (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers