clutter apps (e.g. totem, gnome-maps, pinpoint) colours are wrong (red/blue swapped) in Gnome Shell 3.25 Wayland

Bug #1712986 reported by Daniel van Vugt on 2017-08-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Medium
clutter-gst-3.0 (Ubuntu)
Undecided
Unassigned
mutter (Ubuntu)
Undecided
Unassigned

Bug Description

clutterautovideosink (e.g. totem) colours are wrong (red/blue swapped) in Gnome Shell 3.25 Wayland sessions

summary: - clutterautovideosink: Colours are bright and wrong when using gnome-
- shell 3.26 (was fine in gnome-shell 3.24)
+ clutterautovideosink: Colours are wrong (red/blue swapped) when using
+ gnome-shell 3.26 (was fine in gnome-shell 3.24)
description: updated
Changed in clutter-gst:
importance: Unknown → Medium
status: Unknown → Confirmed
summary: - clutterautovideosink: Colours are wrong (red/blue swapped) when using
- gnome-shell 3.26 (was fine in gnome-shell 3.24)
+ clutterautovideosink (e.g. totem) colours are wrong (red/blue swapped)
+ in Gnome Shell 3.25 Wayland
description: updated
Changed in clutter-gst-3.0 (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
affects: clutter-gst → clutter
Changed in clutter-gst-3.0 (Ubuntu):
status: New → Invalid
summary: - clutterautovideosink (e.g. totem) colours are wrong (red/blue swapped)
- in Gnome Shell 3.25 Wayland
+ clutter apps (e.g. totem, gnome-maps) colours are wrong (red/blue
+ swapped) in Gnome Shell 3.25 Wayland
Changed in clutter-gst-3.0 (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
summary: - clutter apps (e.g. totem, gnome-maps) colours are wrong (red/blue
- swapped) in Gnome Shell 3.25 Wayland
+ clutter apps (e.g. totem, gnome-maps, pinpoint) colours are wrong
+ (red/blue swapped) in Gnome Shell 3.25 Wayland
amano (jyaku) wrote :

Probably fixed by https://github.com/GNOME/mutter/commit/06d09890147b48bfa23f122ff86cf7fc43ff84f2 which made it to the master branch two days after 3.25.91.

Jeremy Bicha (jbicha) wrote :

amano, thanks for the hint.

I've pushed that commit to the GNOME3 Staging PPA. Since this bug doesn't affect Ubuntu directly, I'm closing this bug now.

no longer affects: gnome-shell (Ubuntu)
no longer affects: clutter (Ubuntu)
Changed in mutter (Ubuntu):
status: New → Fix Released
affects: clutter → mutter
Changed in mutter:
importance: Medium → Unknown
status: Confirmed → Unknown
Changed in mutter:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.