Ubuntu

multiarch: package libclutter-1.0-0 1.8.2-2 failed to install/upgrade: './usr/share/doc/libclutter-1.0-0/README.gz' is different from the same file on the system

Reported by seeker5528 on 2011-12-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
clutter-1.0 (Ubuntu)
High
Sebastien Bacher
Precise
High
Sebastien Bacher

Bug Description

While attempting to install amd64 version of package on multiarch enabled i386 system the installation failed.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libclutter-1.0-0 1.8.2-2
ProcVersionSignature: Ubuntu 3.2.0-3.8-generic 3.2.0-rc4
Uname: Linux 3.2.0-3-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Wed Dec 7 19:43:11 2011
DpkgTerminalLog:
 Unpacking libclutter-1.0-0:amd64 (from .../libclutter-1.0-0_1.8.2-2_amd64.deb) ...
 dpkg: error processing /var/cache/apt/archives/libclutter-1.0-0_1.8.2-2_amd64.deb (--unpack):
  './usr/share/doc/libclutter-1.0-0/README.gz' is different from the same file on the system
DuplicateSignature:
 Unpacking libclutter-1.0-0:amd64 (from .../libclutter-1.0-0_1.8.2-2_amd64.deb) ...
 dpkg: error processing /var/cache/apt/archives/libclutter-1.0-0_1.8.2-2_amd64.deb (--unpack):
  './usr/share/doc/libclutter-1.0-0/README.gz' is different from the same file on the system
ErrorMessage: './usr/share/doc/libclutter-1.0-0/README.gz' is different from the same file on the system
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
SourcePackage: clutter-1.0
Title: package libclutter-1.0-0 1.8.2-2 failed to install/upgrade: './usr/share/doc/libclutter-1.0-0/README.gz' is different from the same file on the system
UpgradeStatus: Upgraded to precise on 2011-05-04 (217 days ago)

seeker5528 (seeker5528) wrote :
tags: removed: need-duplicate-check
Jean-Baptiste Lallement (jibel) wrote :

Confirmed on Precise on an amd64 system with libclutter already installed

$ apt-get install libclutter-1.0-0:i386
[...]
Selecting previously unselected package libclutter-1.0-0:i386.
Unpacking libclutter-1.0-0:i386 (from .../libclutter-1.0-0_1.8.2-2_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libclutter-1.0-0_1.8.2-2_i386.deb (--unpack):
 './usr/share/doc/libclutter-1.0-0/README.gz' is different from the same file on the system
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Changed in clutter-1.0 (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in clutter-1.0 (Ubuntu Precise):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: rls-mgr-p-tracking
Martin Pitt (pitti) on 2011-12-12
Changed in clutter-1.0 (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
status: Triaged → In Progress
Martin Pitt (pitti) on 2011-12-12
Changed in clutter-1.0 (Ubuntu Precise):
assignee: Martin Pitt (pitti) → Sebastien Bacher (seb128)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clutter-1.0 - 1.8.2-2ubuntu1

---------------
clutter-1.0 (1.8.2-2ubuntu1) precise; urgency=low

  * Don't compress README to workaround the gzip bug which leads to different
    checksums between architectures and breaks multiarch installs (lp: #901522)
 -- Sebastien Bacher <email address hidden> Mon, 12 Dec 2011 22:23:36 +0100

Changed in clutter-1.0 (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers