UnityLauncherQuicklistMenu clutter_actor_queue_relayout() warning

Bug #599718 reported by Sebastien Bacher on 2010-06-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Mirco Müller
clutk (Ubuntu)
Low
Mirco Müller
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Running unity 0.2.12 on a GNOME session (ie running "unity" under GNOME, compiz is still running), when moving the mouse over the launchers I get those warnings displayed

"(unity:19156): Clutter-WARNING **: The actor 'UnityLauncherQuicklistMenu' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended

(unity:19156): Clutter-WARNING **: The actor 'UnityLauncherQuicklistMenuItem' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended

(unity:19156): Clutter-WARNING **: The actor 'UnityLauncherQuicklistMenu' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended"

Related branches

Changed in unity (Ubuntu):
importance: Undecided → Low
Mirco Müller (macslow) on 2010-07-02
Changed in unity:
importance: Undecided → Low
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
Changed in unity (Ubuntu):
assignee: nobody → Gord Allott (gordallott)
Changed in unity:
milestone: none → 2010-07-15
Changed in unity (Ubuntu):
milestone: none → maverick-alpha-3
Mirco Müller (macslow) on 2010-07-02
Changed in unity:
assignee: Gord Allott (gordallott) → Mirco Müller (macslow)
Changed in unity (Ubuntu):
assignee: Gord Allott (gordallott) → Mirco Müller (macslow)
Neil J. Patel (njpatel) wrote :

Some comments:

We shouldn't be creating new actors in the allocate cycle, rather just update the ones initially created. In the same way, no queue_redraws or queue_relayouts in the allocation cycle either.

The QuickList code needs to cleaned up in this regard. Also, there is a small trick to be done when updating cairo drawables, please see the panel/panel-background.vala to see how we have to handle the resizing of ClutterCairoTextures to avoid annoying Clutter (until Clutter gains support for doing it properly).

Changed in unity:
importance: Low → Medium
Mirco Müller (macslow) wrote :

I'll look into the flickering issue and try to reproduce it here (nvidia-gpu, lucid). My maverick machine (intel-gpu) is currently not able to run any GL-app due to LP: #605825.

Neil J. Patel (njpatel) on 2010-07-16
Changed in unity:
milestone: 2010-07-15 → 2010-07-22
Mirco Müller (macslow) wrote :

queue'ing of redraw()s and relayout()s for quicklist-items have been fixed and already merged into trunk. But some queue-relayout()s for quicklist-menu still remain (and hide themselves well), thus I marked it as "In Progress" and not yet "Fix Committed".

Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.20-0ubuntu1

---------------
unity (0.2.20-0ubuntu1) maverick; urgency=low

  * New upstream release.
    - Right click and selecting application doesn't launch it (LP: #592817)
    - Add some hint that the Ubuntu circle is click-able (LP: #592787)
    - Remove unpinned launchers when quitting the app (LP: #608492)
    - add to launcher isn't changed to remove from launcher (LP: #606266)
    - quicklist should be hidden when drag and drop a launcher (LP: #606258)
    - Fix reorganizing launchers (LP: #600738)
    - Removing active application makes the application closes (LP: #598175)
    - UnityLauncherQuicklistMenu clutter_actor_queue_relayout() warning
      (LP: #599718)
  * debian/control:
    - bump libclutk-dev to latest
  * debian/patches/01_add_dbusmenu_vapi_file.patch:
    - add missing file
  * debian/patches/02_disable_expandable_menu.patch:
    - disable latest changes making mutter respawning with some intel card
 -- Didier Roche <email address hidden> Thu, 22 Jul 2010 22:37:56 +0200

Changed in unity (Ubuntu):
status: In Progress → Fix Released
David Barth (dbarth) on 2010-07-26
Changed in unity:
milestone: 2010-07-22 → 2010-07-29
David Barth (dbarth) on 2010-08-09
Changed in unity (Ubuntu):
milestone: maverick-alpha-3 → ubuntu-10.10-beta
Changed in unity:
milestone: 2010-07-29 → 2010-08-12
Changed in unity:
milestone: 2010-08-12 → 2010-08-19
Neil J. Patel (njpatel) on 2010-08-20
Changed in unity:
milestone: 2010-08-19 → 2010-08-26
Mirco Müller (macslow) on 2010-08-30
Changed in unity:
milestone: 2010-08-26 → 2010-09-02
Mirco Müller (macslow) wrote :

Improved/additional fix for clutk linked to this bug. Some issues of that branch still need to be ironed out though.

Mirco Müller (macslow) on 2010-09-03
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2010-09-03
Changed in unity:
status: Fix Committed → Fix Released
David Barth (dbarth) wrote :

Re-opening to get the additional branch in.

Changed in unity:
milestone: 2010-09-02 → 2010-09-09
status: Fix Released → In Progress
Didier Roche (didrocks) wrote :

reopening the ubuntu task so.

Changed in unity (Ubuntu):
status: Fix Released → Triaged
Mirco Müller (macslow) on 2010-09-08
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2010-09-09
affects: unity (Ubuntu) → clutk (Ubuntu)
Didier Roche (didrocks) on 2010-09-10
Changed in clutk (Ubuntu):
status: Triaged → Fix Released
Omer Akram (om26er) on 2010-09-13
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers