Lucid netbook-launcher segfaults when started

Bug #495066 reported by Ronald McCollam on 2009-12-10
108
This bug affects 17 people
Affects Status Importance Assigned to Milestone
clutk (Ubuntu)
Critical
Didier Roche
Lucid
Critical
Didier Roche

Bug Description

Binary package hint: netbook-launcher

When booting in live mode from a USB stick with the 20091209 build of UNR, the launcher is not displayed. Opening a terminal and running netbook-launcher produces a segmentation fault:

ubuntu@ubuntu:~$ netbook-launcher

(netbook-launcher:4598): GLib-WARNING **: g_set_prgname() called multiple times

(netbook-launcher:4598): GLib-WARNING **: g_set_prgname() called multiple times
(netbook-launcher:4598): libnetbook-launcher-DEBUG: CONFIG: Low graphics mode: False
(netbook-launcher:4598): libnetbook-launcher-DEBUG: CONFIG: Font dpi: 96.000000
(netbook-launcher:4598): libnetbook-launcher-DEBUG: CONFIG: Font changed: Sans 10

(netbook-launcher:4598): libnetbook-launcher-DEBUG: CONFIG: Connecting to ConsoleKit for suspend/resume restarting
(netbook-launcher:4598): liblauncher-DEBUG: launcher-menu.c:361
ORPHAN: Ubuntu Software Center
(netbook-launcher:4598): liblauncher-DEBUG: Workarea: (0, 25) (0, 0)
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try adjusting the vblank_mode configuration parameter.
Segmentation fault

ProblemType: Bug
Architecture: i386
Date: Thu Dec 10 14:31:13 2009
DistroRelease: Ubuntu 10.04
GConfNonDefault:
 /apps/netbook-launcher/disable_single_instance=false
 /apps/netbook-launcher/force_low_graphics=false
LiveMediaBuild: Ubuntu-Netbook-Remix 10.04 "Lucid Lynx" - Alpha i386 (20091209)
MachineType: TOSHIBA TOSHIBA NB100
Package: netbook-launcher 2.1.12-0ubuntu3
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/netbook-remix.seed boot=casper apparmor=0 initrd=/casper/initrd.lz quiet splash --
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-7.10-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5~3ubuntu2
 libgl1-mesa-glx 7.6.1~rc2-1ubuntu1
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.1-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu2
SourcePackage: netbook-launcher
Tags: lucid ubuntu-unr lucid ubuntu-unr
Uname: Linux 2.6.32-7-generic i686
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
XorgLogOld: Error: [Errno 2] No such file or directory: '/var/log/Xorg.0.log.old'
dmi.bios.date: 09/15/2008
dmi.bios.vendor: INSYDE
dmi.bios.version: 1.10
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Insyde
dmi.chassis.version: None
dmi.modalias: dmi:bvnINSYDE:bvr1.10:bd09/15/2008:svnTOSHIBA:pnTOSHIBANB100:pvrPLL10E-00D01YG3:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnInsyde:ct10:cvrNone:
dmi.product.name: TOSHIBA NB100
dmi.product.version: PLL10E-00D01YG3
dmi.sys.vendor: TOSHIBA
fglrx: Not loaded
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.32-7-generic

Related branches

Ronald McCollam (fader) wrote :
tags: added: iso-testing
Steve Langasek (vorlon) on 2009-12-10
Changed in netbook-launcher (Ubuntu Lucid):
importance: Undecided → High
importance: High → Critical
milestone: none → lucid-alpha-2
mstfa cmly (mstfacmly) on 2009-12-10
description: updated
Changed in netbook-launcher (Ubuntu Lucid):
status: New → Confirmed
mstfa cmly (mstfacmly) wrote :

I can confirm this to occur on an HP Mini 1000.

Carl Heymann (ch-heymann) wrote :

Also happening to me on an MSI Wind U100. I'm seeing lines like this repeated on /var/log/messages.

Dec 13 19:18:37 netbook kernel: [ 99.108665] netbook-launche[1958]: segfault at 0 ip 00d5af83 sp bfaf515c error 4 in libc-2.10.1.so[ce8000+13e000]

netbook-launcher doesn't stop, and keeps on using CPU. I can keep on using the computer though, but the netbook remix interface doesn't start up.

Matt Drake (mattduckman) wrote :

here's backtrace of the crash

Martin Pitt (pitti) wrote :

Neil, until Didier starts, would you have some time to look into this? Thanks!

Changed in netbook-launcher (Ubuntu Lucid):
assignee: nobody → Didier Roche (didrocks)
George Kontis (giormatsis) wrote :

I get this error with seamonkey

(seamonkey-bin:4402): GLib-WARNING **: g_set_prgname() called multiple times

Omer Akram (om26er) wrote :

plz resolve this one.

Antti Kaihola (akaihola) wrote :

Identical symptoms on a Dell Mini 9 with http://cdimage.ubuntu.com/ubuntu-netbook-remix/daily-live/20091223/lucid-netbook-i386.iso

Same messages in .xsession-errors as shown in the bug description, and the netbook launcher never appears.

bob gray (sooner-inbox) wrote :

Same problem.

Omer Akram (om26er) wrote :

can this be related with mesa?

Antti Kaihola (akaihola) wrote :

On my Dell Mini 9, the Live CD behaves as described above.

However, when installed onto the internal SSD, Ubuntu Netbook automatically logs in to the standard GNOME desktop by default instead of the netbook interface. If I log out and select the Netbook interface, I get the symptoms described in the description of this bug.

I did the install from a USB stick created with unetbootin with all default choices except the Finnish locale and enabling popularity contest.

I tested both the live and installed desktop using http://cdimage.ubuntu.com/ubuntu-netbook-remix/daily-live/20100102/lucid-netbook-i386.iso

Omer Akram (om26er) wrote :

6days to alpha2 and still no news?

Didier Roche (didrocks) wrote :

Thanks all for your interest in Ubuntu Netbook Edition. This bug will be fixed in alpha2.
(For the record, I'll be full time on it beginning next week)

Martin Pitt (pitti) wrote :

clutk (0.2.8-0ubuntu2) lucid; urgency=low

  * clutk/ctk-text.c: fix LP: #495066 - Lucid netbook-launcher segfaults
    when started; make ctk_text_new NULL safe

-- Alexander Sack <email address hidden> Fri, 08 Jan 2010 13:50:30 +0100

affects: netbook-launcher (Ubuntu Lucid) → clutk (Ubuntu Lucid)
Changed in clutk (Ubuntu Lucid):
status: Confirmed → Fix Released
Omer Akram (om26er) wrote :

yes, its fixed thanx.

mexlinux (mcanedo) wrote :

This is happening to me in karmic

Owais Lone (loneowais) wrote :

Any backport available for Karmic?

RachaelB (8-launchpad-rlb-me) wrote :

netbook-launcher *was* working fine... now it isnt in Karmic :(

extract from syslog:

netbook-launche[2457]: segfault at 0 ip 00c86f93 sp bfd0e54c error 4 in libc-2.10.1.so[c14000+13e000}

Ryan Waldroop (ryan.waldroop) wrote :

This bug is back. Running 2010-02-09 lucid-netbook-i386.iso.

Didier Roche (didrocks) wrote :

Ryan: there has been some transitional work on yesterday's image. Can you confirm it's no more the case on 2010-02-10?

James Miller (bladeon) wrote :

I am encountering this bug in the latest version of netbook remix. On initial install it worked fine, when I installed fglrx, netbook remix started to segfault. I can otherwise use the system fine, just netbook-launcher is failing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers