netbook-launcher crashed with SIGSEGV in g_cclosure_marshal_VOID__PARAM()

Bug #420478 reported by ashane on 2009-08-28
246
This bug affects 48 people
Affects Status Importance Assigned to Milestone
CluTK
Critical
Neil J. Patel
Ubuntu Netbook Remix Launcher
Undecided
Unassigned
clutk (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

Binary package hint: netbook-launcher

My first bug report! Crashed when I was downloading from repos!

ProblemType: Crash
Architecture: i386
Date: Fri Aug 28 12:43:20 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/netbook-launcher
Package: netbook-launcher 2.1.4-0ubuntu1
ProcCmdline: netbook-launcher
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-8.28-generic
SegvAnalysis:
 Segfault happened at: 0xa141a5: cmp %edi,(%eax)
 PC (0x00a141a5) ok
 source "%edi" ok
 destination "(%eax)" (0x6d6f6e67) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: netbook-launcher
StacktraceTop:
 ?? () from /usr/lib/libclutk-0.2.so.0
 g_cclosure_marshal_VOID__PARAM ()
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
Tags: ubuntu-unr
Title: netbook-launcher crashed with SIGSEGV in g_cclosure_marshal_VOID__PARAM()
Uname: Linux 2.6.31-8-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

ashane (davidshaneaustin-98) wrote :

StacktraceTop:on_gtk_font_changed (settings=0x96b0520, pspec=0x969b278,
IA__g_cclosure_marshal_VOID__PARAM (closure=0x9d9b678,
IA__g_closure_invoke (closure=0x9d9b678, return_value=0x0,
signal_emit_unlocked_R (node=<value optimized out>,
IA__g_signal_emit_valist (instance=0x96b0520, signal_id=1,

Changed in netbook-launcher (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Paul Larson (pwlars) wrote :

Thanks for taking the time to report this bug and help make Ubuntu better. There have been some significant changes to netbook-launcher and the libraries it uses since this bug was opened, that very likely have resolved this already. Please retest with the latest version and let us know if it's fixed for you. Thanks in advance.

visibility: private → public
Changed in netbook-launcher (Ubuntu):
importance: Medium → High
status: New → Incomplete

It may be fixed, but a new one has taken its place. I get a crash now when I exit the package manager.

Paul Larson (pwlars) wrote :

@charles are you sure it's identical? Did you use apport to open a bug for the new crash?

Tuna Soncul (tsoncul) wrote :

I had this bug on karmic-alpha6, while doing an update. The crash happened as the new software was being installed.

The bug is intermittent, as I have successfully used the Update Manager before on the same installation. If it's any help, the package being updated at the time was one of the OpenOffice packages - not sure which.

Neil J. Patel (njpatel) on 2009-09-23
Changed in netbook-remix-launcher:
milestone: none → ubuntu-9.10-beta-freeze
Neil J. Patel (njpatel) on 2009-09-24
Changed in netbook-remix-launcher:
status: New → Confirmed
Neil J. Patel (njpatel) on 2009-09-24
Changed in netbook-remix-launcher:
status: Confirmed → In Progress
Loïc Minier (lool) on 2009-09-25
Changed in netbook-launcher (Ubuntu Karmic):
milestone: none → ubuntu-9.10
dan13 (dangotofree) wrote :

I had this bug on karmic-alpha6, while doing an update. The crash happened as the new software was being installed

Paul Larson (pwlars) wrote :

There are still several reports of this coming in, setting it back

Changed in netbook-launcher (Ubuntu Karmic):
status: Incomplete → Triaged
Neil J. Patel (njpatel) on 2009-10-02
Changed in clutk:
status: New → Fix Committed
Changed in netbook-remix-launcher:
status: In Progress → Invalid
Changed in clutk:
milestone: none → 0.2.8
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Critical
Neil J. Patel (njpatel) wrote :

This ended up being a bug in CluTK rather than netbook-launcher, CtkText instances we're still receiving signals from GtkSettings after they were finalised. The fix was to disconnect the signal in CtkText finalize function.

A reliable way to reproduce this was to use the Main Menu Editor program (System->Preferences) to change the menu layout, and then use Appearance (System->Preferences) to change the system application font.

This has been fixed in clutk-0.2.8, which hopefully should be uploaded early next week.

Changed in clutk:
status: Fix Committed → Fix Released
Paul Larson (pwlars) wrote :

This *should* be fixed in the latest version. If you are still seeing this problem, please run update-manager to pull the latest packages and retest. Thanks!

affects: netbook-launcher (Ubuntu Karmic) → clutk (Ubuntu Karmic)
Changed in clutk (Ubuntu Karmic):
status: Triaged → Incomplete
Neil J. Patel (njpatel) on 2009-10-08
Changed in clutk (Ubuntu Karmic):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers