Cannot scroll to bottom of system menu

Bug #414353 reported by Corey Burger on 2009-08-16
126
This bug affects 26 people
Affects Status Importance Assigned to Milestone
CluTK
Medium
Gord Allott
clutk (Ubuntu)
Medium
Gord Allott

Bug Description

Binary package hint: netbook-launcher

Using Alpha 4 UNR. In the system menu includes a large number of items, forcing the user to scroll. However, the scroll does not allow the user to view the bottom of the screen. This is a bug specific to the system category, as the favourites, when it has enough tools to force scrolling, doesn't exhibit the same behaviour. Possibly this is due to the two categories within the system category

Related branches

description: updated
tags: added: karmic
summary: - Unable to scroll fully
+ Cannot scroll to bottom of system menu
Neil J. Patel (njpatel) on 2009-08-17
Changed in netbook-launcher (Ubuntu):
status: New → Triaged
Paul Larson (pwlars) wrote :

Thank you for taking the time to report this bug and help make Ubuntu better. I'm unable to reproduce this bug in the latest development release. Could you please update, or use the latest livecd image to retest this and let us know if you are still able to reproduce the problem? If so, a screenshot might be useful to help understand what is going on. Thanks!

Changed in netbook-launcher (Ubuntu):
importance: Undecided → Low
status: Triaged → Incomplete

I can confirmed this bug. It`s present on my notebook (running Ubuntu 9.10 with all updates at this moment) .
Screenshot in attachment.

Paul Larson (pwlars) wrote :

Marking confirmed based on the previous feedback. Any possibility this could depend on which language is being used? I'm still not able to reproduce it so far.

Changed in netbook-launcher (Ubuntu):
importance: Low → Medium
status: Incomplete → Confirmed

> Any possibility this could depend on which language is being used?\
No. I cange locale to en_us, bug still present.

I can`t speack C programming language, but it`s look like error in scroll box upper value calculation algorythm (launcher_iconview_set_category function from launcher-iconview.c file). I think, that author of first message said right.

If menu contains some like this (--- - group separator):
A B C D
E F G H
I J
---
K L M N
O P Q R
S T Y

row variable is 4, but must be 5. And I can`t found place with group separator height calculation.

Forgive me if I am wrong, but I newer wrote in C or similar language and smoke this sources only 5 minutes :)

Bug gone away for me.
I don`t know, how it happens exactly.

Tor Klingberg (tor-klingberg) wrote :

This happens to me too. It only happens when I am using a larger external screen, not with the netbook screen. Perhaps it only happens when there are five icons in each row. See screenshot.

David Barth (dbarth) on 2009-10-29
Changed in netbook-remix-launcher:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Low
status: New → Confirmed
Changed in netbook-launcher (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)

I can also confirm this bug. Happens only with native widescreen resolution of my netbook. If I change the resolution to smaller than native 1280x800, then the scroll bar works as it should.

This error manifests itself if the total number of items in the last rows of each group is less then or equal to the number of columns

linuxwarrior (linuxwarrior) wrote :

I confirm the bug on the eee box connected to a 1280x768 display. Using English. Screenshot attached

Jeroen van der Vegt (ajvdvegt) wrote :

I can confirm this bug as well on a 1024x600 display (with nl_NL language). I have merely four icons per rows, and only one on the bottom row.

Scrolling back upwards with the arrow key seems weird as well, as sometimes the screen doesn't scroll upwards correctly. After arriving at the top row, I have to press the left and right arrows a few times before the top icons are fully visible (I cannot test this behaviour at the bottom row as I only see one icon in the bottom row). The category divider seems to cause issues sometimes when scrolling up using the arrow keys as well.

ohiomoto (ohiomoto) wrote :

I can also confirm this bug.

I recently upgraded 2 laptops to 9.10. Everything went smooth, but there is an issue with the way the menu items are displayed on one of them. For example, I added a new menu item "Trunk" to the "Folders" menu, but the menu didn't expand. This resulted in the "Volumes" menu being written over top of my "Desktop" menu item.

Also, my Systems>Administration menu is not showing all of the menu items. The items are on the menu as I am sometimes able to find them with the pointer even though I can't see them. The are just below the viewable area, but I cannot scroll down any further. I suspect that the items have spilled out of the menu panel as my my "Desktop" folder did, but I'm only able to scroll down far enough to show last row of the panel. Removing menu items does not solve the problem.

I have removed and reinstalled the netbook remix packages without success.

This in on a 14" screen running 1280x800 resolution, NVIDIA GeForce 8400M GS card. I have tried activating both available drivers and there is no difference. If I use 1024x768, the menus work as they should. There seems to be an issue with 9.10 at 1280x800. 9.04 worked fine on this machine.

ohiomoto (ohiomoto) wrote :
ohiomoto (ohiomoto) wrote :
Paul Larson (pwlars) on 2009-11-10
tags: added: regression-release
Iain Buclaw (ibuclaw) wrote :

I can confirm this bug happened to me, but am reporting here because today, I've noticed the complete reversal of this bug.

Only recent updates I've had relating to netbook-launcher are:
libclutter-gtk (0.10-0 0.10.2-0ubuntu1 => 0.10-0_0.10.2-0ubuntu2)
libgnome-desktop (2.28.1-0ubuntu2 => 2.28.1-0ubuntu3)

Both were updated on 2009-11-11 @ 08:07:24

Attached is an image of what it now looks like for me.

Oren_B (oren.barnea) wrote :

I can't scroll to the bottom of the system menu using the arrow keys, but it works fine when I scroll using the touchpad's right edge to scroll.
Dell Mini 10v, 1024x600.

Iain Buclaw (ibuclaw) wrote :

Hmm, perhaps I have a different issue, this is what I've found so far in the behaviour of the netbook-launcher iconview on a Samsung N110.

Res: 640x480
 2 Columns
 3 Rows per group of icons
 All icons showing. (Albeit, with a large gap after every third row)

Res: 800x600
 3 Columns
 3 Rows
 Only first 9 icons showing. (With a large gap on the bottom (3rd) row)

Res: 1024x600
 4 Columns
 3 Rows
 Only first 12 icons showing. (With a large gap on the bottom (4th) row)

This behaviour seems to coincide with these functions in nl-config.c

static gint
get_rows_for_height (gint height)
{
  gint rows = 3;

  if (height < 600)
    rows = 3;
  else if (height < 1025)
    rows = 4;
  else
    rows = 5;

  return rows;
}

static gint
get_cols_for_width (gint width)
{
  gint cols = 3;

  if (width < 801)
    cols = 3;
  else if (width < 1025)
    cols = 4;
  else
    cols = 5;

  return cols;
}

But altering them seems to make no difference?

Can anyone confirm?

Regards
Iain

Robert Vandewater (rlvlcv) wrote :

Affected on both UNR and Ubuntu 9.10 desktop with netbook-launcher. Toshiba M750-S7202 tablet.

Eddie (erwin-gjaltemaonline) wrote :

@Iain Bucław
I am experiencng the same bug on my eeepc 701.
With res of 800x480
omly 2 icons per colum and after 3th row (only in system tab!) a big gap.
after the gap all icons overlap eachother :o

Eddie (erwin-gjaltemaonline) wrote :

and the overlap of icons

Eddie (erwin-gjaltemaonline) wrote :

The gap isn't an patch, but image!
Don't know how i managed to enable the "patch-mode" (sorry, not native English ;) ), i can't edit the post.
So sorry...

deseven (de7) wrote :

I can confirm this bug too.
Lenovo S10 - 1024*600 (int) and 1280*1024 (ext)

Bug present in Ubuntu 10.04.

tags: added: lucid

And in Files&Folders menu

Peter (maubp) wrote :

I'm also seeing this with the mobile remix on an Acer Aspire Revo, with monitor at 1280x768 via VGA. Using English (UK). I have five icons per row (which seems to be important from earlier comments).

Because of this I can't see the icons for the Ubuntu software center, update manager, or users and groups, but I can just *click* on their border region.

Jarda Benkovsky (edheldil001) wrote :

I have the same issue on Dell Latitude E4200, 1280x800 resolution, 5 icons on a row. The last row in System->Administration is only partially visible (it has 5 icons too, so it does not even have to be the LAST row).

Also in Files&Folders, the Desktop icon is displayed below the Folders frame, which is only one row of icons high.

checkeys (ronzegers) wrote :

Same here on a Toshiba Satelite L300-11C 15" with a 1280x800px resolution and 5 icons on a row.

Also a weird problem in Files&Folders, the Desktop icon is displayed below the Folders frame, which is only one row of icons high.

Kai Mast (kai-mast) wrote :

Have this bug on the ASUS Eee 901

sxpa (sxpa86) wrote :

I have the same bug on my Acer Aspire One AO532h (both overlapping and scrolling). The resolution is 1280x720. This bug appears directly after installing of the system, Ubuntu 9.10 UNR. If I start netbook-launcher using 1024x768 resolution (using -w parameter, for example), all is fine.

sxpa (sxpa86) wrote :

netbook-launcher version is 2.1.12.

sxpa (sxpa86) wrote :

It seems, that this bug depends on width of the left menu. When Educational section was added, the bug disappeared (the menu became a little larger). My system language is Russian.

Didier Roche (didrocks) wrote :

Can you please try with last lucid version, adding this ppa: https://launchpad.net/~ubuntu-desktop/+archive/ppa and then upgrading to get last clutk?

There is a proposed patch which should fix that.
Thanks for trying. I'm putting the bug report as Incomplete waiting for feedback.

Changed in netbook-launcher (Ubuntu):
assignee: Neil J. Patel (njpatel) → nobody
status: Confirmed → Incomplete
Changed in netbook-remix-launcher:
assignee: Neil J. Patel (njpatel) → nobody
status: Confirmed → Incomplete

2 Didier Roche:
Bug was looking fixed for me (HP Pavilion tx2640er, 1280x800). Thank you.

Didier Roche (didrocks) on 2010-03-11
Changed in netbook-launcher (Ubuntu):
milestone: none → ubuntu-10.04-beta-1
Didier Roche (didrocks) on 2010-03-11
affects: netbook-launcher (Ubuntu) → clutk (Ubuntu)
affects: netbook-remix-launcher → clutk
Changed in clutk (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) on 2010-03-11
Changed in clutk:
status: Incomplete → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clutk - 0.3.8.is.0.2.10-0ubuntu1

---------------
clutk (0.3.8.is.0.2.10-0ubuntu1) lucid; urgency=low

  * New upstream release:
    - Fix netbook-launcher crashed with SIGFPE in clutter_actor_allocate()
      (LP: #445995)
    - Map/unmap and check that ctk icon children are valid
    - Use GNOME simplified autogen.sh (LP: #456901)
    - Reinitialize to 0 some coordonates to avoid overlapping icons and
      weird behavior in multines scheme
      (LP: #424231, #414353, #435805, #459367, #445829, #447715, #480219)
    - apply to trunk asac fix to fix netbook-launcher segfault on start;
      make ctk_text_new NULL safe
  * debian/control:
    - bump Standards-Version to latest
 -- Didier Roche <email address hidden> Thu, 11 Mar 2010 17:04:19 +0100

Changed in clutk (Ubuntu):
status: Incomplete → Fix Released
Еггог (sergey-nr) wrote :

This bug not fixed for me with last package clutk update (0.3.8.is.0.2.10-0ubuntu1). My system UNR 10.04 full updated on 22 Mar 2010 (beta 1), but problem with cannot scroll to bottom of system menu not resolved. My netbook Acer AO531h with 10' HD 1280x720 screen resolution and intel 945 GME graphics adapter. xdpyinfo reports: 1280x720 (338x190 mm) 96x96 dpi

Didier Roche (didrocks) wrote :

ok, so the fix didn't work. Put the priority to high and reopening the bug.

Changed in clutk (Ubuntu):
status: Fix Released → Triaged
assignee: Didier Roche (didrocks) → nobody
Changed in clutk:
status: Fix Released → Triaged
Changed in clutk (Ubuntu):
importance: Medium → High
Changed in clutk:
importance: Low → High
Didier Roche (didrocks) on 2010-03-23
Changed in clutk (Ubuntu):
importance: High → Medium
Changed in clutk:
importance: High → Medium
David Barth (dbarth) on 2010-03-23
Changed in clutk:
assignee: nobody → David Barth (dbarth)
assignee: David Barth (dbarth) → nobody
assignee: nobody → Gord Allott (gordallott)
Changed in clutk (Ubuntu):
assignee: nobody → Gord Allott (gordallott)
Jan Arne Petersen (jpetersen) wrote :

There is a patch attached in the branch.

Еггог (sergey-nr) wrote :

Today after update this bug was looking fixed for me (Acer Aspire One 531h, 1280x720). Thank you.

Didier Roche (didrocks) wrote :

Your changes seems good, merged into trunk. Thanks a lot!

Changed in clutk:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2010-04-01
Changed in clutk (Ubuntu):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clutk - 0.3.8.is.0.2.12-0ubuntu1

---------------
clutk (0.3.8.is.0.2.12-0ubuntu1) lucid; urgency=low

  * New upstream release:
    - fix scrolling to bottom of system menu (Jan Arne Petersen)
      (LP: #414353)
 -- Didier Roche <email address hidden> Thu, 01 Apr 2010 17:44:46 +0200

Changed in clutk (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-04-08
Changed in clutk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers