ubuntu-cloudimg-query in precise cannot query for quantal

Bug #1062671 reported by Clint Byrum on 2012-10-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-utils
Undecided
Unassigned
pyjuju
High
Unassigned
cloud-utils (Ubuntu)
Medium
Unassigned

Bug Description

This seems like a fundamental problem for a tool that will be supported for the next 4.5 years and, at least in theory, 9 releases.

++ ubuntu-cloudimg-query quantal released amd64 --format '%{url}\n'
confused by argument: quantal

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: cloud-utils 0.25-0ubuntu5
ProcVersionSignature: User Name 3.2.0-31.50-virtual 3.2.28
Uname: Linux 3.2.0-31-virtual x86_64
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
Date: Sat Oct 6 03:46:34 2012
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: cloud-utils
UpgradeStatus: No upgrade log present (probably fresh install)

Clint Byrum (clint-fewbar) wrote :
Clint Byrum (clint-fewbar) wrote :

This affects LXC, as this means it cannot spawn new releases of ubuntu with the ubuntu-cloud template, and thus juju. I'm just adding them for tracking of the issue.

Changed in juju:
status: New → Triaged
importance: Undecided → High
James Page (james-page) wrote :

Clint

I've not been able to reproduce this - it seems to work just fine (tested on 12.04):

ubuntu-cloudimg-query quantal released amd64 --format '%{url}\n'
https://cloud-images.ubuntu.com/server/releases/quantal/beta-2/ubuntu-12.10-beta2-server-cloudimg-amd64.tar.gz

Changed in cloud-utils (Ubuntu):
status: New → Incomplete
Clint Byrum (clint-fewbar) wrote :
Download full text (3.7 KiB)

I can reproduce over and over in a clean chroot:

$ schroot -c precise-amd64 -u root
(precise-amd64)root@clint-MacBookPro:~# apt-get install cloud-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libapt-inst1.3 libdb4.8
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  euca2ools file libmagic1 libyaml-0-2 python-boto python-crypto python-m2crypto python-paramiko python-yaml
Suggested packages:
  python-crypto-dbg python-crypto-doc
The following NEW packages will be installed:
  cloud-utils euca2ools file libmagic1 libyaml-0-2 python-boto python-crypto python-m2crypto python-paramiko
  python-yaml
0 upgraded, 10 newly installed, 0 to remove and 0 not upgraded.
Need to get 2319 kB of archives.
After this operation, 16.2 MB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://127.0.0.1/ubuntu/ precise/main libyaml-0-2 amd64 0.1.4-2 [56.9 kB]
Get:2 http://127.0.0.1/ubuntu/ precise/main python-m2crypto amd64 0.21.1-2ubuntu2 [157 kB]
Get:3 http://127.0.0.1/ubuntu/ precise/main libmagic1 amd64 5.09-2 [217 kB]
Get:4 http://127.0.0.1/ubuntu/ precise/main file amd64 5.09-2 [19.7 kB]
Get:5 http://127.0.0.1/ubuntu/ precise/main python-boto all 2.2.2-0ubuntu2 [443 kB]
Get:6 http://127.0.0.1/ubuntu/ precise-updates/main euca2ools all 2.0.0~bzr516-0ubuntu3.1 [179 kB]
Get:7 http://127.0.0.1/ubuntu/ precise-updates/main python-crypto amd64 2.4.1-1ubuntu0.1 [293 kB]
Get:8 http://127.0.0.1/ubuntu/ precise/main python-paramiko all 1.7.7.1-2 [796 kB]
Get:9 http://127.0.0.1/ubuntu/ precise/main python-yaml amd64 3.10-2 [122 kB]
Get:10 http://127.0.0.1/ubuntu/ precise/main cloud-utils all 0.25-0ubuntu5 [35.1 kB]
Fetched 2319 kB in 4s (559 kB/s)
Selecting previously unselected package libyaml-0-2.
(Reading database ... 14967 files and directories currently installed.)
Unpacking libyaml-0-2 (from .../libyaml-0-2_0.1.4-2_amd64.deb) ...
Selecting previously unselected package python-m2crypto.
Unpacking python-m2crypto (from .../python-m2crypto_0.21.1-2ubuntu2_amd64.deb) ...
Selecting previously unselected package libmagic1.
Unpacking libmagic1 (from .../libmagic1_5.09-2_amd64.deb) ...
Selecting previously unselected package file.
Unpacking file (from .../archives/file_5.09-2_amd64.deb) ...
Selecting previously unselected package python-boto.
Unpacking python-boto (from .../python-boto_2.2.2-0ubuntu2_all.deb) ...
Selecting previously unselected package euca2ools.
Unpacking euca2ools (from .../euca2ools_2.0.0~bzr516-0ubuntu3.1_all.deb) ...
Selecting previously unselected package python-crypto.
Unpacking python-crypto (from .../python-crypto_2.4.1-1ubuntu0.1_amd64.deb) ...
Selecting previously unselected package python-paramiko.
Unpacking python-paramiko (from .../python-paramiko_1.7.7.1-2_all.deb) ...
Selecting previously unselected package python-yaml.
Unpacking python-yaml (from .../python-yaml_3.10-2_amd64.deb) ...
Selecting previously unselected package cloud-utils.
Unpacking cloud-utils (from .../cloud-utils_0.25-0ubuntu5_all.deb) ...
Setting up libyaml-0-...

Read more...

Clint Byrum (clint-fewbar) wrote :

Looks like missing dependencies. Namely, distro-info, once that is installed:

(precise-amd64)root@clint-MacBookPro:~# ubuntu-cloudimg-query quantal
/usr/bin/ubuntu-cloudimg-query: 61: /usr/bin/ubuntu-cloudimg-query: wget: not found
failed to get https://cloud-images.ubuntu.com/query/quantal/server/released-dl.current.txt

And then with any release:

failed to get https://cloud-images.ubuntu.com/query/lucid/server/released-dl.current.txt

Because ca-certificates is missing:

So, this boils down to three missing deps... distro-info, wget, and ca-certificates.

Changed in cloud-utils (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
Changed in juju:
status: Triaged → Invalid
Changed in cloud-utils:
status: New → Invalid
Scott Moser (smoser) wrote :

the distro-info is not a dependency its a Suggests.
wget and ca-certificates is valid though.

Scott Moser (smoser) wrote :

ah. the distro-info is aRecommends. and that is present in quantal.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-utils - 0.26-0ubuntu2

---------------
cloud-utils (0.26-0ubuntu2) raring; urgency=low

  * debian/copyright: fix formatting
  * sync to trunk at revno 216
    * support for GPT partitions in growpart via sgdisk (LP: #1087526)
    * depend on wget and ca-certificates for ubuntu-cloudimg-query
      (LP: #1062671)
    * fix sfdisk parsing (LP: #1007415)
 -- Scott Moser <email address hidden> Mon, 04 Feb 2013 15:18:49 -0500

Changed in cloud-utils (Ubuntu):
status: Triaged → Fix Released
no longer affects: lxc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers