grub-legacy-ec2 missing dependency: ucf

Bug #960336 reported by Kamal Mostafa on 2012-03-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cloud-init (Ubuntu)
Medium
Unassigned

Bug Description

Package grub-legacy-ec2 needs an explicit "Depends: ucf", since the script 'update-grub-legacy-ec2' uses ucf.

The failure occurs when preparing a very minimal installation with a sequence like:
    debootstrap --variant=minbase . . .
    apt-get install grub-legacy-ec2

Note that --variant=minbase is key to demonstrating the failure. Debootstrap with the default (unset) --variant ends up installing ucf for something else, hiding the problem.

Related branches

James Page (james-page) on 2012-03-22
Changed in cloud-init (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cloud-init (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.6.3-0ubuntu3

---------------
cloud-init (0.6.3-0ubuntu3) quantal; urgency=low

  * grub-legacy-ec2: add missing dependency on ucf (LP: #960336).
 -- Robie Basak <email address hidden> Sun, 24 Jun 2012 05:10:13 +0100

Changed in cloud-init (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers