cloud-final job did not run in ec2-automated-tests

Bug #745946 reported by Scott Moser on 2011-03-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
cloud-init (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: cloud-init

In natty beta-1 testing, we had 2 occurrences where it appears the upstart job cloud-final did not run after 15 minutes of waiting.

This occurred once on eu-west-1 and ap-southeast-1. both were m1.small (i386).
I will attach the console output of each. Note, that in that console output, the '[]' is from the 'timezone' cloud-config plugin. This gives us info that cloud-init-config had gotten past the 'apt-update-upgrade' plugin.

cloud-config upstart job has:
  start on (filesystem and started rsyslog)

cloud-config-final upstart job has:
  start on (stopped rc RUNLEVEL=[2345] and stopped cloud-config)

[1] http://jenkins.qa.ubuntu-uk.org/view/natty-ec2/job/natty_ec2_eu-west-1_all-zones/2/artifact/eu-west-1b/i386/m1.small/instance-store/i-61c41d17/3c839fcb-ba33-4017-9a5c-ed33f5a7a532-timeout.console.txt/*view*/
[2] http://jenkins.qa.ubuntu-uk.org/view/natty-ec2/job/natty_ec2_ap-southeast-1_multi-part-ud/2/artifact/None/i386/m1.small/instance-store/i-1318d146/bd75f3a3-e373-42ce-af7d-6d5f4f45d53a-timeout.console.txt/*view*/

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: cloud-init 0.6.1-0ubuntu4
ProcVersionSignature: User Name 2.6.38-7.39-virtual 2.6.38
Uname: Linux 2.6.38-7-virtual i686
Architecture: i386
Date: Wed Mar 30 18:27:30 2011
Ec2AMI: ami-183b424a
Ec2AMIManifest: ubuntu-images-testing-ap-southeast-1/ubuntu-natty-daily-i386-server-20110329.manifest.xml
Ec2AvailabilityZone: ap-southeast-1b
Ec2InstanceType: m1.small
Ec2Kernel: aki-13d5aa41
Ec2Ramdisk: unavailable
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: cloud-init
UpgradeStatus: No upgrade log present (probably fresh install)

Scott Moser (smoser) wrote :
Scott Moser (smoser) wrote :
Scott Moser (smoser) wrote :
tags: added: iso-testing
Scott Moser (smoser) wrote :

it would seem to me that the most likely cause for cloud-final not running would be something blocked in sysvinit scripts.

Scott Moser (smoser) on 2011-03-31
Changed in cloud-init (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
summary: - cloud-final job did not run
+ cloud-final job did not run in ec2-automated-tests
Dave Walker (davewalker) on 2011-04-18
tags: added: server-nrs
James Page (james-page) wrote :
Scott Moser (smoser) wrote :

I'm closing this for the moment. I suspect it was related to bug 1124384.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers