[ec2-test] ud-multipart-01 test failed on included files

Bug #570950 reported by Scott Moser on 2010-04-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on EC2
Low
Unassigned
cloud-init (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: cloud-init

results.us-west-1-x86_64-ami-7f97c63a.log :

running user-data remote test for ud-multipart-01 (i-db8f919e/ec2-184-72-14-232.us-west-1.compute.amazonaws.com)
PASS: /root/OUTPUT-my-user-script-1.sh exists
PASS: /root/OUTPUT-my-user-script-2.sh exists
PASS: /root/OUTPUT-my-upstart-job.conf exists
PASS: /root/OUTPUT-upstartjob1.txt exists
FAIL: /root/OUTPUT-include-compressed-script-01.txt does not exist
FAIL: /root/OUTPUT-include-script-01.txt does not exist
PASS: /etc/init/my-upstart-job.conf exists
PASS: /etc/init/upstartjob1.txt.conf exists
PASS: pastebinit installed (1.1-1)
WARNING: failures in test-remote for ud-multipart-01

I really can't explain the above. There is nothing else in the console log (attached) that indicates failure to include that url, and other scripts that would have been run were run.

Note, I've subsequently re-run this test (with the instance that reported this bug) and it passed.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: cloud-init 0.5.10-0ubuntu1
ProcVersionSignature: User Name 2.6.32-305.9-ec2 2.6.32.11+drm33.2
Uname: Linux 2.6.32-305-ec2 i686
Architecture: i386
Date: Tue Apr 27 20:49:00 2010
Ec2AMI: ami-5f4d672b
Ec2AMIManifest: (unknown)
Ec2AvailabilityZone: eu-west-1b
Ec2InstanceType: m1.small
Ec2Kernel: aki-b37c56c7
Ec2Ramdisk: unavailable
PackageArchitecture: all
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: cloud-init

Scott Moser (smoser) wrote :
Changed in cloud-init (Ubuntu):
status: New → Triaged
importance: Undecided → Low
tags: added: iso-testing
Scott Moser (smoser) wrote :

I've seen this again today, and I believe that the reason for it is that the launchpad code view is down or times out. The code that processes includes will just get a "timeout" page, and use it as if there was no error.

Scott Moser (smoser) wrote :

I've verified that the reason for this failure is launchpad failure.
recent changes to the test suite collect user-data.txt.i from the instance (the processed user data). I'll attach it here, but the problem is that #included files contain:
"Sorry, there was a problem connecting to the Launchpad server"

Scott Moser (smoser) wrote :

Also saw today:
<html>
<head><title>Oops! OOPS-1755CB14</title></head>
<body>
<h1>Oops!</h1>
<p>Something broke while generating the page.
Please try again in a few minutes, and if the problem persists file a bug at
<a href="https://bugs.launchpad.net/launchpad-code"
>https://bugs.launchpad.net/launchpad-code</a>
and quote OOPS-ID <strong>OOPS-1755CB14</strong>
</p></body></html>

to fix this, cloud-init should probably retry on 404 or error at least a couple times.

Scott Moser (smoser) on 2011-08-24
Changed in ubuntu-on-ec2:
importance: Undecided → Low
status: New → Triaged
summary: - ud-multipart-01 test failed on included files
+ [ec2-test] ud-multipart-01 test failed on included files
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers