sru cloud-init (21.1-19 to 21.2-3) Bionic, Focal, Groovy, and Hirsute

Bug #1927491 reported by James Falcon
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned
Hirsute
Undecided
Unassigned

Bug Description

== Begin SRU Template ==
[Impact]
This release sports both bug-fixes and new features and we would like to
make sure all of our supported customers have access to these
improvements. The notable ones are:

 - Add \r\n check for SSH keys in Azure (#889)
 - Azure: adding support for consuming userdata from IMDS (#884) [Anh Vo]
 - Fix chef module run failure when chef_license is set (#868) [Ben Hughes]
 - Azure: Retry net metadata during nic attach for non-timeout errs (#878)
   [aswinrajamannar]
 - Azure: Retrieve username and hostname from IMDS (#865) [Thomas Stringer]
 - Azure: eject the provisioning iso before reporting ready (#861) [Anh Vo]
 - Use `partprobe` to re-read partition table if available (#856)
   [Nicolas Bock]
 - fix error on upgrade caused by new vendordata2 attributes (#869)
 - add prefer_fqdn_over_hostname config option (#859) [hamalq]
 - azure: Removing ability to invoke walinuxagent (#799) [Anh Vo]
 - Add Vultr support (#827) [David Dymko]
 - Fix unpickle for source paths missing run_dir (#863) [lucasmoura]
 - bringup_static_routes: fix gateway check (#850) [Petr Fedchenkov]
 - Fix mis-detecting network configuration in initramfs cmdline (#844)
 - tools/write-ssh-key-fingerprints: do not display empty header/footer
   (#817) [dermotbradley]
 - Azure helper: Ensure Azure http handler sleeps between retries (#842)
   [Johnson Shi]

See the changelog entry below for a full list of changes and bugs.

[Test Case]
The following development and SRU process was followed:
https://wiki.ubuntu.com/CloudinitUpdates

The cloud-init team will be in charge of attaching the artifacts and
console output of the appropriate run to the bug. cloud-init team
members will not mark ‘verification-done’ until this has happened.

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned integration tests are attached to this bug.

== End SRU Template ==

    - Update test characters in substitution unit test (#893)
    - cc_disk_setup.py: remove UDEVADM_CMD definition as not used (#886)
      [dermotbradley]
    - Add AlmaLinux OS support (#872) [Andrew Lukoshko]
    - Release 21.2 (#890) (LP: #1927254)
    - Add \r\n check for SSH keys in Azure (#889)
    - Revert "Add support to resize rootfs if using LVM (#721)" (#887)
      (LP: #1922742)
    - Add Vultaire as contributor (#881) [Paul Goins]
    - Azure: adding support for consuming userdata from IMDS (#884) [Anh Vo]
    - test_upgrade: modify test_upgrade_package to run for more sources (#883)
    - Fix chef module run failure when chef_license is set (#868) [Ben Hughes]
    - Azure: Retry net metadata during nic attach for non-timeout errs (#878)
      [aswinrajamannar]
    - Azure: Retrieve username and hostname from IMDS (#865) [Thomas Stringer]
    - Azure: eject the provisioning iso before reporting ready (#861) [Anh Vo]
    - Use `partprobe` to re-read partition table if available (#856)
      [Nicolas Bock] (LP: #1920939)
    - fix error on upgrade caused by new vendordata2 attributes (#869)
      (LP: #1922739)
    - add prefer_fqdn_over_hostname config option (#859)
      [hamalq] (LP: #1921004)
    - Emit dots on travis to avoid timeout (#867)
    - doc: Replace remaining references to user-scripts as a config module
      (#866) [Ryan Harper]
    - azure: Removing ability to invoke walinuxagent (#799) [Anh Vo]
    - Add Vultr support (#827) [David Dymko]
    - Fix unpickle for source paths missing run_dir (#863)
      [lucasmoura] (LP: #1899299)
    - sysconfig: use BONDING_MODULE_OPTS on SUSE (#831) [Jens Sandmann]
    - bringup_static_routes: fix gateway check (#850) [Petr Fedchenkov]
    - add hamalq user (#860) [hamalq]
    - Add support to resize rootfs if using LVM (#721)
      [Eduardo Otubo] (LP: #1799953)
    - Fix mis-detecting network configuration in initramfs cmdline (#844)
      (LP: #1919188)
    - tools/write-ssh-key-fingerprints: do not display empty header/footer
      (#817) [dermotbradley]
    - Azure helper: Ensure Azure http handler sleeps between retries (#842)
      [Johnson Shi]
    - Fix chef apt source example (#826) [timothegenzmer]

James Falcon (falcojr)
tags: added: verification-needed-bionic verification-needed-focal verification-needed-groovy verification-needed-hirsute
James Falcon (falcojr)
summary: - sru cloud-init (21.1-19 to 21.2-0) Bionic, Focal, Groovy, and Hirsute
+ sru cloud-init (21.1-19 to 21.2-3) Bionic, Focal, Groovy, and Hirsute
James Falcon (falcojr)
description: updated
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello James, or anyone else affected,

Accepted cloud-init into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/21.2-3-g899bfaa9-0ubuntu2~21.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cloud-init (Ubuntu Hirsute):
status: New → Fix Committed
tags: added: verification-needed
Changed in cloud-init (Ubuntu Groovy):
status: New → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote :

This was also accepted for groovy but the comment was not added due to a a Launchpad timeout.

Changed in cloud-init (Ubuntu Focal):
status: New → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello James, or anyone else affected,

Accepted cloud-init into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/21.2-3-g899bfaa9-0ubuntu2~20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cloud-init (Ubuntu Bionic):
status: New → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello James, or anyone else affected,

Accepted cloud-init into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/21.2-3-g899bfaa9-0ubuntu2~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
James Falcon (falcojr) wrote :

Attach file maas-sru-21.2-3.txt.

Revision history for this message
James Falcon (falcojr) wrote :

Attach file curtin-cloudinit-sru-21.2-3.txt.

Revision history for this message
James Falcon (falcojr) wrote :

Attach file nocloud-lxd-sru-21.2-3.txt.

Revision history for this message
James Falcon (falcojr) wrote :

Attach file nocloud-nocloud-kvm-sru-21.2-3.txt.

Revision history for this message
Alexander Balderson (asbalderson) wrote :

+1 from SQA running deploys against openstack/ceph on both focal and bionic
openstack results can be seen at:
https://solutions.qa.canonical.com/testplans/testplaninstance/3a227faa-70b0-4fb6-be4d-0ea79dfe1845

Chad Smith (chad.smith)
Changed in cloud-init (Ubuntu):
status: New → In Progress
Revision history for this message
James Falcon (falcojr) wrote :

Attach file azure-sru-21.2-3.tar.gz.

Revision history for this message
James Falcon (falcojr) wrote :

Attach file ec2-sru-21.2-3.tar.gz.

Revision history for this message
James Falcon (falcojr) wrote :

Attach file gce-sru-21.2-3.tar.gz.

Revision history for this message
James Falcon (falcojr) wrote :

Attach file openstack-sru-21.2-3.tar.gz.

Revision history for this message
James Falcon (falcojr) wrote :

Attach file oracle-sru-21.2-3.tar.gz.

James Falcon (falcojr)
tags: added: verification-done verification-done-bionic verification-done-focal verification-done-groovy verification-done-hirsute
removed: verification-needed verification-needed-bionic verification-needed-focal verification-needed-groovy verification-needed-hirsute
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for cloud-init has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in cloud-init (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 21.2-3-g899bfaa9-0ubuntu2~21.04.1

---------------
cloud-init (21.2-3-g899bfaa9-0ubuntu2~21.04.1) hirsute; urgency=medium

  * d/cloud-init.templates: Add Vultr datasource support
  * drop the following cherry-picks now included:
    + cpick-83f6bbfb-Fix-unpickle-for-source-paths-missing-run_dir-863
    + cpick-d132356c-fix-error-on-upgrade-caused-by-new-vendordata2
  * New upstream snapshot. (LP: #1927491)
    - Update test characters in substitution unit test (#893)
    - cc_disk_setup.py: remove UDEVADM_CMD definition as not used (#886)
      [dermotbradley]
    - Add AlmaLinux OS support (#872) [Andrew Lukoshko]
    - Release 21.2 (#890)
    - Add \r\n check for SSH keys in Azure (#889)
    - Revert "Add support to resize rootfs if using LVM (#721)" (#887)
    - Add Vultaire as contributor (#881) [Paul Goins]
    - Azure: adding support for consuming userdata from IMDS (#884) [Anh Vo]
    - test_upgrade: modify test_upgrade_package to run for more sources (#883)
    - Fix chef module run failure when chef_license is set (#868) [Ben Hughes]
    - Azure: Retry net metadata during nic attach for non-timeout errs (#878)
      [aswinrajamannar]
    - Azure: Retrieve username and hostname from IMDS (#865) [Thomas Stringer]
    - Azure: eject the provisioning iso before reporting ready (#861) [Anh Vo]
    - Use `partprobe` to re-read partition table if available (#856)
      [Nicolas Bock]
    - fix error on upgrade caused by new vendordata2 attributes (#869)
    - add prefer_fqdn_over_hostname config option (#859) [hamalq]
    - Emit dots on travis to avoid timeout (#867)
    - doc: Replace remaining references to user-scripts as a config module
      (#866) [Ryan Harper]
    - azure: Removing ability to invoke walinuxagent (#799) [Anh Vo]
    - Add Vultr support (#827) [David Dymko]
    - Fix unpickle for source paths missing run_dir (#863) [lucasmoura]
    - sysconfig: use BONDING_MODULE_OPTS on SUSE (#831) [Jens Sandmann]
    - bringup_static_routes: fix gateway check (#850) [Petr Fedchenkov]
    - add hamalq user (#860) [hamalq]
    - Add support to resize rootfs if using LVM (#721) [Eduardo Otubo]
    - Fix mis-detecting network configuration in initramfs cmdline (#844)
    - tools/write-ssh-key-fingerprints: do not display empty header/footer
      (#817) [dermotbradley]
    - Azure helper: Ensure Azure http handler sleeps between retries (#842)
      [Johnson Shi]
    - Fix chef apt source example (#826) [timothegenzmer]

 -- James Falcon <email address hidden> Wed, 12 May 2021 10:52:15 -0500

Changed in cloud-init (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 21.2-3-g899bfaa9-0ubuntu2~18.04.1

---------------
cloud-init (21.2-3-g899bfaa9-0ubuntu2~18.04.1) bionic; urgency=medium

  * d/cloud-init.templates: Add Vultr datasource support
  * drop the following cherry-picks now included:
    + cpick-83f6bbfb-Fix-unpickle-for-source-paths-missing-run_dir-863
    + cpick-d132356c-fix-error-on-upgrade-caused-by-new-vendordata2
  * New upstream snapshot. (LP: #1927491)
    - Update test characters in substitution unit test (#893)
    - cc_disk_setup.py: remove UDEVADM_CMD definition as not used (#886)
      [dermotbradley]
    - Add AlmaLinux OS support (#872) [Andrew Lukoshko]
    - Release 21.2 (#890)
    - Add \r\n check for SSH keys in Azure (#889)
    - Revert "Add support to resize rootfs if using LVM (#721)" (#887)
    - Add Vultaire as contributor (#881) [Paul Goins]
    - Azure: adding support for consuming userdata from IMDS (#884) [Anh Vo]
    - test_upgrade: modify test_upgrade_package to run for more sources (#883)
    - Fix chef module run failure when chef_license is set (#868) [Ben Hughes]
    - Azure: Retry net metadata during nic attach for non-timeout errs (#878)
      [aswinrajamannar]
    - Azure: Retrieve username and hostname from IMDS (#865) [Thomas Stringer]
    - Azure: eject the provisioning iso before reporting ready (#861) [Anh Vo]
    - Use `partprobe` to re-read partition table if available (#856)
      [Nicolas Bock]
    - fix error on upgrade caused by new vendordata2 attributes (#869)
    - add prefer_fqdn_over_hostname config option (#859) [hamalq]
    - Emit dots on travis to avoid timeout (#867)
    - doc: Replace remaining references to user-scripts as a config module
      (#866) [Ryan Harper]
    - azure: Removing ability to invoke walinuxagent (#799) [Anh Vo]
    - Add Vultr support (#827) [David Dymko]
    - Fix unpickle for source paths missing run_dir (#863) [lucasmoura]
    - sysconfig: use BONDING_MODULE_OPTS on SUSE (#831) [Jens Sandmann]
    - bringup_static_routes: fix gateway check (#850) [Petr Fedchenkov]
    - add hamalq user (#860) [hamalq]
    - Add support to resize rootfs if using LVM (#721) [Eduardo Otubo]
    - Fix mis-detecting network configuration in initramfs cmdline (#844)
    - tools/write-ssh-key-fingerprints: do not display empty header/footer
      (#817) [dermotbradley]
    - Azure helper: Ensure Azure http handler sleeps between retries (#842)
      [Johnson Shi]
    - Fix chef apt source example (#826) [timothegenzmer]

 -- James Falcon <email address hidden> Tue, 11 May 2021 12:24:46 -0500

Changed in cloud-init (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 21.2-3-g899bfaa9-0ubuntu2~20.04.1

---------------
cloud-init (21.2-3-g899bfaa9-0ubuntu2~20.04.1) focal; urgency=medium

  * d/cloud-init.templates: Add Vultr datasource support
  * drop the following cherry-picks now included:
    + cpick-83f6bbfb-Fix-unpickle-for-source-paths-missing-run_dir-863
    + cpick-d132356c-fix-error-on-upgrade-caused-by-new-vendordata2
  * New upstream snapshot. (LP: #1927491)
    - Update test characters in substitution unit test (#893)
    - cc_disk_setup.py: remove UDEVADM_CMD definition as not used (#886)
      [dermotbradley]
    - Add AlmaLinux OS support (#872) [Andrew Lukoshko]
    - Release 21.2 (#890)
    - Add \r\n check for SSH keys in Azure (#889)
    - Revert "Add support to resize rootfs if using LVM (#721)" (#887)
    - Add Vultaire as contributor (#881) [Paul Goins]
    - Azure: adding support for consuming userdata from IMDS (#884) [Anh Vo]
    - test_upgrade: modify test_upgrade_package to run for more sources (#883)
    - Fix chef module run failure when chef_license is set (#868) [Ben Hughes]
    - Azure: Retry net metadata during nic attach for non-timeout errs (#878)
      [aswinrajamannar]
    - Azure: Retrieve username and hostname from IMDS (#865) [Thomas Stringer]
    - Azure: eject the provisioning iso before reporting ready (#861) [Anh Vo]
    - Use `partprobe` to re-read partition table if available (#856)
      [Nicolas Bock]
    - fix error on upgrade caused by new vendordata2 attributes (#869)
    - add prefer_fqdn_over_hostname config option (#859) [hamalq]
    - Emit dots on travis to avoid timeout (#867)
    - doc: Replace remaining references to user-scripts as a config module
      (#866) [Ryan Harper]
    - azure: Removing ability to invoke walinuxagent (#799) [Anh Vo]
    - Add Vultr support (#827) [David Dymko]
    - Fix unpickle for source paths missing run_dir (#863) [lucasmoura]
    - sysconfig: use BONDING_MODULE_OPTS on SUSE (#831) [Jens Sandmann]
    - bringup_static_routes: fix gateway check (#850) [Petr Fedchenkov]
    - add hamalq user (#860) [hamalq]
    - Add support to resize rootfs if using LVM (#721) [Eduardo Otubo]
    - Fix mis-detecting network configuration in initramfs cmdline (#844)
    - tools/write-ssh-key-fingerprints: do not display empty header/footer
      (#817) [dermotbradley]
    - Azure helper: Ensure Azure http handler sleeps between retries (#842)
      [Johnson Shi]
    - Fix chef apt source example (#826) [timothegenzmer]

 -- James Falcon <email address hidden> Tue, 11 May 2021 12:22:24 -0500

Changed in cloud-init (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 21.2-3-g899bfaa9-0ubuntu2~20.10.1

---------------
cloud-init (21.2-3-g899bfaa9-0ubuntu2~20.10.1) groovy; urgency=medium

  * d/cloud-init.templates: Add Vultr datasource support
  * drop the following cherry-picks now included:
    + cpick-83f6bbfb-Fix-unpickle-for-source-paths-missing-run_dir-863
    + cpick-d132356c-fix-error-on-upgrade-caused-by-new-vendordata2
  * New upstream snapshot. (LP: #1927491)
    - Update test characters in substitution unit test (#893)
    - cc_disk_setup.py: remove UDEVADM_CMD definition as not used (#886)
      [dermotbradley]
    - Add AlmaLinux OS support (#872) [Andrew Lukoshko]
    - Release 21.2 (#890)
    - Add \r\n check for SSH keys in Azure (#889)
    - Revert "Add support to resize rootfs if using LVM (#721)" (#887)
    - Add Vultaire as contributor (#881) [Paul Goins]
    - Azure: adding support for consuming userdata from IMDS (#884) [Anh Vo]
    - test_upgrade: modify test_upgrade_package to run for more sources (#883)
    - Fix chef module run failure when chef_license is set (#868) [Ben Hughes]
    - Azure: Retry net metadata during nic attach for non-timeout errs (#878)
      [aswinrajamannar]
    - Azure: Retrieve username and hostname from IMDS (#865) [Thomas Stringer]
    - Azure: eject the provisioning iso before reporting ready (#861) [Anh Vo]
    - Use `partprobe` to re-read partition table if available (#856)
      [Nicolas Bock]
    - fix error on upgrade caused by new vendordata2 attributes (#869)
    - add prefer_fqdn_over_hostname config option (#859) [hamalq]
    - Emit dots on travis to avoid timeout (#867)
    - doc: Replace remaining references to user-scripts as a config module
      (#866) [Ryan Harper]
    - azure: Removing ability to invoke walinuxagent (#799) [Anh Vo]
    - Add Vultr support (#827) [David Dymko]
    - Fix unpickle for source paths missing run_dir (#863) [lucasmoura]
    - sysconfig: use BONDING_MODULE_OPTS on SUSE (#831) [Jens Sandmann]
    - bringup_static_routes: fix gateway check (#850) [Petr Fedchenkov]
    - add hamalq user (#860) [hamalq]
    - Add support to resize rootfs if using LVM (#721) [Eduardo Otubo]
    - Fix mis-detecting network configuration in initramfs cmdline (#844)
    - tools/write-ssh-key-fingerprints: do not display empty header/footer
      (#817) [dermotbradley]
    - Azure helper: Ensure Azure http handler sleeps between retries (#842)
      [Johnson Shi]
    - Fix chef apt source example (#826) [timothegenzmer]

 -- James Falcon <email address hidden> Tue, 11 May 2021 12:07:28 -0500

Changed in cloud-init (Ubuntu Groovy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers