WARNINGs and failures in log on OVH public cloud

Bug #1792415 reported by Scott Moser on 2018-09-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
Medium
Unassigned
cloud-init (Ubuntu)
Medium
Unassigned

Bug Description

Part of "make OVH work right" was brought up by Tobias in
 https://code.launchpad.net/~tobijk/cloud-init/+git/cloud-init/+merge/354752

After that, though we still see some warnings in the logs that is attached.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: cloud-init 18.3-39-g757247f9-0ubuntu1 [modified: usr/lib/python3/dist-packages/cloudinit/sources/helpers/openstack.py]
ProcVersionSignature: Ubuntu 4.18.0-7.8-generic 4.18.5
Uname: Linux 4.18.0-7-generic x86_64
ApportVersion: 2.20.10-0ubuntu9
Architecture: amd64
CloudName: Other
Date: Thu Sep 13 16:37:09 2018
Ec2AMI: ami-00014f37
Ec2AMIManifest: FIXME
Ec2AvailabilityZone: nova
Ec2InstanceType: s1-2
Ec2Kernel: unavailable
Ec2Ramdisk: unavailable
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
SourcePackage: cloud-init
UpgradeStatus: No upgrade log present (probably fresh install)
cloud-init-log-warnings:
 2018-09-13 16:34:54,017 - util.py[WARNING]: Getting data from <class 'cloudinit.sources.DataSourceOpenStack.DataSourceOpenStackLocal'> failed
 cloudinit.util.ProcessExecutionError: Unexpected error while running command.
 Stderr: Error: Nexthop has invalid gateway.
 2018-09-13 16:34:56,266 - openstack.py[DEBUG]: Failed reading optional path http://169.254.169.254/openstack/latest/user_data due to: 404 Client Error: Not Found for url: http://169.254.169.254/openstack/latest/user_data
user_data.txt:

Related branches

Scott Moser (smoser) wrote :
Scott Moser (smoser) wrote :
Download full text (3.8 KiB)

Below is cloud-init log entries around the warning.

Here are the contents of the lease file that dhclient wrote:
# cat /run/dhclient-lease-file
lease {
  interface "ens3";
  fixed-address 54.36.113.86;
  option subnet-mask 255.255.255.255;
  option routers 54.36.112.1;
  option dhcp-lease-time 86400;
  option dhcp-message-type 5;
  option domain-name-servers 213.186.33.99;
  option dhcp-server-identifier 54.36.112.1;
  option interface-mtu 1500;
  option domain-name "openstacklocal";
  renew 5 2018/09/14 03:08:26;
  rebind 5 2018/09/14 13:45:08;
  expire 5 2018/09/14 16:45:08;
}

2018-09-13 16:45:08,843 - util.py[DEBUG]: Reading from /var/tmp/cloud-init/cloud-init-dhcp-seeuch_6/dhcp.leases (quiet=False)
2018-09-13 16:45:08,843 - util.py[DEBUG]: Read 442 bytes from /var/tmp/cloud-init/cloud-init-dhcp-seeuch_6/dhcp.leases
2018-09-13 16:45:08,844 - util.py[DEBUG]: Reading from /var/tmp/cloud-init/cloud-init-dhcp-seeuch_6/dhcp.leases (quiet=False)
2018-09-13 16:45:08,844 - util.py[DEBUG]: Read 442 bytes from /var/tmp/cloud-init/cloud-init-dhcp-seeuch_6/dhcp.leases
2018-09-13 16:45:08,844 - dhcp.py[DEBUG]: Received dhcp lease on ens3 for 54.36.113.86/255.255.255.255
2018-09-13 16:45:08,844 - __init__.py[DEBUG]: Attempting setup of ephemeral network on ens3 with 54.36.113.86/32 brd 54.36.113.86
2018-09-13 16:45:08,844 - util.py[DEBUG]: Running command ['ip', '-family', 'inet', 'addr', 'add', '54.36.113.86/32', 'broadcast', '54.36.113.86', 'dev', 'ens3'] with allowed return codes [0] (shell=False, capture=True)
2018-09-13 16:45:08,848 - util.py[DEBUG]: Running command ['ip', '-family', 'inet', 'link', 'set', 'dev', 'ens3', 'up'] with allowed return codes [0] (shell=False, capture=True)
2018-09-13 16:45:08,850 - util.py[DEBUG]: Running command ['ip', 'route', 'show', '0.0.0.0/0'] with allowed return codes [0] (shell=False, capture=True)
2018-09-13 16:45:08,853 - util.py[DEBUG]: Running command ['ip', '-4', 'route', 'add', 'default', 'via', '54.36.112.1', 'dev', 'ens3'] with allowed return codes [0] (shell=False, capture=True)
2018-09-13 16:45:08,856 - handlers.py[DEBUG]: finish: init-local/search-OpenStackLocal: FAIL: no local data found from DataSourceOpenStackLocal
2018-09-13 16:45:08,856 - util.py[WARNING]: Getting data from <class 'cloudinit.sources.DataSourceOpenStack.DataSourceOpenStackLocal'> failed
2018-09-13 16:45:08,856 - util.py[DEBUG]: Getting data from <class 'cloudinit.sources.DataSourceOpenStack.DataSourceOpenStackLocal'> failed
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/cloudinit/sources/__init__.py", line 601, in find_source
    if s.update_metadata([EventType.BOOT_NEW_INSTANCE]):
  File "/usr/lib/python3/dist-packages/cloudinit/sources/__init__.py", line 490, in update_metadata
    result = self.get_data()
  File "/usr/lib/python3/dist-packages/cloudinit/sources/__init__.py", line 182, in get_data
    return_value = self._get_data()
  File "/usr/lib/python3/dist-packages/cloudinit/sources/DataSourceOpenStack.py", line 131, in _get_data
    with EphemeralDHCPv4(self.fallback_interface):
  File "/usr/lib/python3/dist-packages/cloudinit/net/dhcp.py", line 63, in __enter__
    ephipv4.__enter__()
  Fi...

Read more...

This bug is fixed with commit 12066fc8 to cloud-init on branch master.
To view that commit see the following URL:
https://git.launchpad.net/cloud-init/commit/?id=12066fc8

Changed in cloud-init:
status: New → Fix Committed
Scott Moser (smoser) on 2018-09-14
Changed in cloud-init (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in cloud-init:
importance: Undecided → Medium

This bug is believed to be fixed in cloud-init in version 18.4. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in cloud-init:
status: Fix Committed → Fix Released
Scott Moser (smoser) wrote :

This bug is fixed in 18.10

This bug was fixed in the package cloud-init - 18.4-0ubuntu1
---------------

cloud-init (18.4-0ubuntu1) cosmic; urgency=medium

  * New upstream release.
    - release 18.4 (LP: #1795741)
    - tests: allow skipping an entire cloud_test without running.
    - tests: disable lxd tests on cosmic
    - cii-tests: use unittest2.SkipTest in ntp_chrony due to new deps
    - lxd: adjust to snap installed lxd.
    - docs: surface experimental doc in instance-data.json
    - tests: fix ec2 integration tests. process meta_data instead of meta-data
    - Add support for Infiniband network interfaces (IPoIB). [Mark Goddard]
    - cli: add cloud-init query subcommand to query instance metadata
    - tools/tox-venv: update for new features.
    - pylint: ignore warning assignment-from-no-return for _write_network
    - stages: Fix bug causing datasource to have incorrect sys_cfg.
      (LP: #1787459)
    - Remove dead-code _write_network distro implementations.
    - net_util: ensure static configs have netmask in translate_network result
      [Thomas Berger] (LP: #1792454)
    - Fall back to root:root on syslog permissions if other options fail.
      [Robert Schweikert]
    - tests: Add mock for util.get_hostname. [Robert Schweikert] (LP: #1792799)

 -- Chad Smith <email address hidden> Tue, 02 Oct 2018 19:55:23 -0600

Changed in cloud-init (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers