OpenNebula DataSource adds null gateway6 to netplan config

Bug #1768547 reported by Corey Melanson on 2018-05-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
Medium
Unassigned
cloud-init (Ubuntu)
Medium
Unassigned

Bug Description

Hello,

In Ubuntu 18.04 with cloud-init 18.2-14-g6d48d265-0ubuntu1, the OpenNebula data source generates an invalid netplan yaml file if the IPv6 gateway is not defined in context.sh:
network:
    ethernets:
        eth0:
            addresses:
            - 10.22.33.44/22
            gateway4: 10.22.33.1
            gateway6: null
            match:
                macaddress: 02:00:00:00:aa:bb
            nameservers:
                addresses:
                - 10.22.22.22
                - 10.33.33.33
    version: 2

Netplan will not apply this config:
# netplan try
Error in network definition //etc/netplan/50-cloud-init.yaml line 11 column 22: invalid IPv6 address 'null'

This is due to a typo in DataSourceOpenNebula.py, attached is a patch which fixes it.

Cheers,
Corey Melanson

Related branches

Corey Melanson (cmelanson) wrote :

The attachment "DataSourceOpenNebula.py.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Scott Moser (smoser) wrote :

Hi Corey,

Thanks for finding this bug, reporting it and even finding the fix.

If you'd like to have your name in the cloud-init changelog for the fix,
please:
a.) sign the merge canonical contributors agreement
b.) submit a merge proposal

there is information on how to do each at
 http://cloudinit.readthedocs.io/en/latest/topics/hacking.html

If you aren't interested in following through with that, just let me know
and I'll work out a fix and submit a merge proposal.

If you have any questions, please feel free to ask here or in FreeNode IRC
#cloud-init.

Thanks,
Scott

Changed in cloud-init:
status: New → Confirmed
Changed in cloud-init (Ubuntu):
status: New → Confirmed
Changed in cloud-init:
importance: Undecided → Medium
Changed in cloud-init (Ubuntu):
importance: Undecided → Medium
Corey Melanson (cmelanson) wrote :

Hey Scott,

Sorry for the delay... Appreciate the offer, but you can just merge it or whatever I don't need my name in the change log.

Cheers,
Corey

Akihiko Ota (sw37th) wrote :

Hi Corey, Scott,

Sorry my mistake. I have merged your patch to my launchpad
repository, and create a merge request to the master branch.

I fixed its unittest as well. Please confirm.

This bug is fixed with commit 01cfa711 to cloud-init on branch master.
To view that commit see the following URL:
https://git.launchpad.net/cloud-init/commit/?id=01cfa711

Changed in cloud-init:
status: Confirmed → Fix Committed

This bug is believed to be fixed in cloud-init in version 18.4. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in cloud-init:
status: Fix Committed → Fix Released
Scott Moser (smoser) wrote :

This bug was fixed in

This bug was fixed in the package cloud-init - 18.4-0ubuntu1
---------------

cloud-init (18.4-0ubuntu1) cosmic; urgency=medium

  * New upstream release.
    - release 18.4 (LP: #1795741)
    - tests: allow skipping an entire cloud_test without running.
    - tests: disable lxd tests on cosmic
    - cii-tests: use unittest2.SkipTest in ntp_chrony due to new deps
    - lxd: adjust to snap installed lxd.
    - docs: surface experimental doc in instance-data.json
    - tests: fix ec2 integration tests. process meta_data instead of meta-data
    - Add support for Infiniband network interfaces (IPoIB). [Mark Goddard]
    - cli: add cloud-init query subcommand to query instance metadata
    - tools/tox-venv: update for new features.
    - pylint: ignore warning assignment-from-no-return for _write_network
    - stages: Fix bug causing datasource to have incorrect sys_cfg.
      (LP: #1787459)
    - Remove dead-code _write_network distro implementations.
    - net_util: ensure static configs have netmask in translate_network result
      [Thomas Berger] (LP: #1792454)
    - Fall back to root:root on syslog permissions if other options fail.
      [Robert Schweikert]
    - tests: Add mock for util.get_hostname. [Robert Schweikert] (LP: #1792799)

 -- Chad Smith <email address hidden> Tue, 02 Oct 2018 19:55:23 -0600

Changed in cloud-init (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers