sru cloud-init (17.1.46-g7acc9e86-0ubuntu1) update to 17.2-35-gf576b2a2-0ubuntu1~16.04.1

Bug #1747059 reported by Chad Smith on 2018-02-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
Artful
Medium
Unassigned

Bug Description

== Begin SRU Template ==

Updated 02/12/2018: SRU-verification exposed a bug in get_instance_id on EC2 and 17.2.35 publishes a fix for that upgrade path issue.

    - EC2: Fix get_instance_id called against cached datasource pickle.

[Impact]
This release provides both bug-fixes and new features and we would like to
make sure all of our supported customers have access to these
improvements. Notable changes for Ubuntu stable releases are:

    - debian/grub-legacy-ec2.install: install post(inst|rm) files correctly.
      [Simon Deziel] (LP: #1581416)
    - OVF: Extend well-known labels to include OVFENV. (LP: #1698669)
    - Fix potential cases of uninitialized variables. (LP: #1744796)
    - Azure VM Preprovisioning support. [Douglas Jordan] (LP: #1734991)
    - btrfs: support resizing if root is mounted ro.
      [Robert Schweikert] (LP: #1734787)
    - OpenNebula: Improve network configuration support.
      [Akihiko Ota] (LP: #1719157, #1716397, #1736750)
    - GCE: Improvements and changes to ssh key behavior for default user.
      [Max Illfelder] (LP: #1670456, #1707033, #1707037, #1707039)
    - subp: make ProcessExecutionError have expected types in stderr, stdout.
    - Recognize uppercase vfat disk labels [James Penick] (LP: #1598783)
    - Do not log warning on config files that represent None. (LP: #1742479)
    - MAAS: add check_instance_id based off oauth tokens. (LP: #1712680)
    - cli: cloud-init clean handles symlinks [Chad Smith] (LP: #1741093)
    - Azure: Only bounce network when necessary. [Chad Smith] (LP: #1722668)
    - cli: Fix error in cloud-init modules --mode=init. (LP: #1736600)
    - debian/patches/ds-identify-behavior-xenial.patch: refresh patch
    - ds-identify: failure in NoCloud due to unset variable usage.
      (LP: #1737704)
    - ec2: Use instance-identity doc for region and instance-id
      [Andrew Jorgensen]
    - setup.py: Do not include rendered files in SOURCES.txt
    - OVF: improve ds-identify to support finding OVF iso transport.
    - Datasources: Formalize DataSource get_data and related properties.
      [Chad Smith]
    - cli: Add clean and status subcommands [Chad Smith]

See the === Changelog === entry below for a full list of changes and bugs.

[Test Case]
The following development and SRU process was followed:
https://wiki.ubuntu.com/CloudinitUpdates

The cloud-init team will be in charge of attaching the artifacts and
console output of the appropriate run to the bug. cloud-init team
members will not mark ‘verification-done’ until this has happened.

* Automated Test Results
automated lxd results are run by jenkins nightly CI
 * https://jenkins.ubuntu.com/server/job/cloud-init-ci-nightly/

* Automated nocloud/kvm Results:
 * xenial: https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1747059/+attachment/5061384/+files/nocloud-kvm-sru-17.2.35.txt
 * artful: https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1747059/+attachment/5061384/+files/nocloud-kvm-sru-17.2.35.txt

solutions testing team results:
 * xenial:
    - https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1747059/+attachment/5059910/+files/maas_hp_gen9_install.log
    - https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1747059/+attachment/5059911/+files/maas_pod_kvm_install.log

MAAS team results:
 * xenial: Success: https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1747059/comments/16

Manual test artifacts from:
 * EC2:
   - xenial & artful: https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1747059/+attachment/5061274/+files/ec2-sru-17.2.35.txt
 * nocloud:
    - Xenial & Artful: https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1747059/+attachment/5061384/+files/nocloud-kvm-sru-17.2.35.txt
 * lxd: https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1747059/+attachment/5061385/+files/nocloud-lxd-sru-17.2.35.txt
 * gce: https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1747059/+attachment/5060895/+files/gce-sru-17.2.35.txt
 * azure: https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1747059/+attachment/5061273/+files/azure-sru-17.2.35.txt

Additional manual test results related to this SRU
https://github.com/cloud-init/ubuntu-sru/tree/master/20180202

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned integration tests are attached to this bug.

[Other Info]

[Discussion]

== End SRU Template ==

== Changelog ==
cloud-init (17.2-35-gf576b2a2-0ubuntu1~16.04.1) UNRELEASED; urgency=medium

  * New upstream snapshot.
    - tests: add support for logs with lxd from snap and future lxd 3.
      (LP: #1745663)
    - EC2: Fix get_instance_id called against cached datasource pickle.
      [Chad Smith] (LP: #1748354)
    - cli: fix cloud-init status to report running when before result.json
      (LP: #1747965)
    - net: accept network-config in netplan format for renaming interfaces
      (LP: #1709715)
    - Fix ssh keys validation in ssh_util [Tatiana Kholkina]

cloud-init (17.2-30-gf7deaf15-0ubuntu1~16.04.1) UNRELEASED; urgency=medium

  * New upstream snapshot.
    - docs: Update RTD content for cloud-init subcommands.
    - OVF: Extend well-known labels to include OVFENV. (LP: #1698669)
    - Fix potential cases of uninitialized variables. (LP: #1744796)
    - tests: Collect script output as binary, collect systemd journal, fix lxd.
    - HACKING.rst: mention setting user name and email via git config.
    - Azure VM Preprovisioning support. [Douglas Jordan] (LP: #1734991)
    - tools/read-version: Fix read-version when in a git worktree.
    - docs: Fix typos in docs and one debug message. [Florian Grignon]
    - btrfs: support resizing if root is mounted ro.
      [Robert Schweikert] (LP: #1734787)
    - OpenNebula: Improve network configuration support.
      [Akihiko Ota] (LP: #1719157, #1716397, #1736750)
    - tests: Fix EC2 Platform to return console output as bytes.
    - tests: Fix attempted use of /run in a test case.
    - GCE: Improvements and changes to ssh key behavior for default user.
      [Max Illfelder] (LP: #1670456, #1707033, #1707037, #1707039)
    - subp: make ProcessExecutionError have expected types in stderr, stdout.
    - tests: when querying ntp server, do not do dns resolution.
    - Recognize uppercase vfat disk labels [James Penick] (LP: #1598783)
    - tests: remove zesty as supported OS to test
    - Do not log warning on config files that represent None. (LP: #1742479)
    - tests: Use git hash pip dependency format for pylxd.
    - tests: add integration requirements text file
    - MAAS: add check_instance_id based off oauth tokens. (LP: #1712680)
    - tests: update apt sources list test
    - tests: clean up image properties
    - tests: rename test ssh keys to avoid appearance of leaking private keys.
    - tests: Enable AWS EC2 Integration Testing
    - cli: cloud-init clean handles symlinks (LP: #1741093)
    - SUSE: Add a basic test of network config rendering. [Robert Schweikert]
    - Azure: Only bounce network when necessary. (LP: #1722668)
    - lint: Fix lints seen by pylint version 1.8.1.
    - cli: Fix error in cloud-init modules --mode=init. (LP: #1736600)
    - release 17.2
    - ds-identify: failure in NoCloud due to unset variable usage.
      (LP: #1737704)
    - tests: fix collect_console when not implemented
    - ec2: Use instance-identity doc for region and instance-id
      [Andrew Jorgensen]
    - tests: remove leaked tmp files in config drive tests.
    - setup.py: Do not include rendered files in SOURCES.txt
    - SUSE: remove delta in systemd local template for SUSE [Robert Schweikert]
    - tests: move to using tox 1.7.5
    - OVF: improve ds-identify to support finding OVF iso transport.
    - VMware: Support for user provided pre and post-customization scripts
      [Maitreyee Saikia]
    - citest: In NoCloudKVM provide keys via metadata not userdata.
    - pylint: Update pylint to 1.7.1, run on tests/ and tools and fix
      complaints.
    - Datasources: Formalize DataSource get_data and related properties.
    - cli: Add clean and status subcommands
    - tests: consolidate platforms into specific dirs

cloud-init (17.1-46-g7acc9e68-0ubuntu1~16.04.2) UNRELEASED; urgency=medium

  * debian/patches/ds-identify-behavior-xenial.patch: refresh patch.
  * debian/grub-legacy-ec2.install: install post(inst|rm) files correctly.
    [Simon Deziel] (LP: #1581416)

Scott Moser (smoser) on 2018-02-02
Changed in cloud-init (Ubuntu):
status: New → Fix Released
importance: Undecided → Medium
Changed in cloud-init (Ubuntu Xenial):
status: New → Confirmed
Changed in cloud-init (Ubuntu Artful):
status: New → Confirmed
Changed in cloud-init (Ubuntu Xenial):
importance: Undecided → Medium
Changed in cloud-init (Ubuntu Artful):
importance: Undecided → Medium

Hello Chad, or anyone else affected,

Accepted cloud-init into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/17.2-30-gf7deaf15-0ubuntu1~17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cloud-init (Ubuntu Artful):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-artful
Łukasz Zemczak (sil2100) wrote :

Hello Chad, or anyone else affected,

Accepted cloud-init into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/17.2-30-gf7deaf15-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cloud-init (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed-xenial

Discovered SRU blocker for EC2 upgrade path LP: #1748354.

We will be adding a fix to this SRU bug including changelog for this branch.

Scott Moser (smoser) on 2018-02-12
description: updated
Chad Smith (chad.smith) on 2018-02-12
description: updated
summary: sru cloud-init (17.1.46-g7acc9e86-0ubuntu1) update to
- 17.2.30-gf7deaf15-0ubuntu1
+ 17.2-35-gf576b2a2-0ubuntu1~16.04.1

An upload of cloud-init to artful-proposed has been rejected from the upload queue for the following reason: "Please re-upload with full changelog since -updates in the _source.changes file. Thanks!".

Chris Halse Rogers (raof) wrote :

An upload of cloud-init to xenial-proposed has been rejected from the upload queue for the following reason: "Please re-upload with full changelog in _source.changes. Thanks!".

Hello Chad, or anyone else affected,

Accepted cloud-init into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/17.2-35-gf576b2a2-0ubuntu1~17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Chris Halse Rogers (raof) wrote :

Hello Chad, or anyone else affected,

Accepted cloud-init into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/17.2-35-gf576b2a2-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Chad Smith (chad.smith) wrote :

EC2 manual SRU verification 17.2.35 artful and xenial

description: updated
John George (jog) wrote :

MAAS bare metal deploy SRU verification for xenial

John George (jog) wrote :

MAAS kvm deploy SRU verification for xenial

Chad Smith (chad.smith) wrote :

Successful GCE xenial and artful upgrade and fresh install test logs

Chad Smith (chad.smith) wrote :

Azure successful manual upgrade/fresh test re-run on 17.2.35

Chad Smith (chad.smith) wrote :

Ec2 manual upgrade/fresh re-run on 17.2.35

Chad Smith (chad.smith) wrote :

lxc kvm manual test logs xenial and artful

Chad Smith (chad.smith) wrote :

lxc automated test logs xenial and artful

description: updated
Andres Rodriguez (andreserl) wrote :

I've run both manual and automated tests for Xenial and we haven't identified any regressions.

Chad Smith (chad.smith) on 2018-02-27
description: updated
tags: added: verification-done verification-done-artful verification-done-xenial
removed: verification-needed verification-needed-artful verification-needed-xenial
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package cloud-init - 17.2-35-gf576b2a2-0ubuntu1~17.10.1

---------------
cloud-init (17.2-35-gf576b2a2-0ubuntu1~17.10.1) artful-proposed; urgency=medium

  * New upstream snapshot. (LP: #1747059)
    - tests: add support for logs with lxd from snap and future lxd 3.
    - EC2: Fix get_instance_id called against cached datasource pickle.
    - cli: fix cloud-init status to report running when before result.json
    - net: accept network-config in netplan format for renaming interfaces
    - Fix ssh keys validation in ssh_util [Tatiana Kholkina]

cloud-init (17.2-30-gf7deaf15-0ubuntu1~17.10.1) artful-proposed; urgency=medium

  * New upstream snapshot. (LP: #1747059)
    - docs: Update RTD content for cloud-init subcommands.
    - OVF: Extend well-known labels to include OVFENV.
    - Fix potential cases of uninitialized variables.
    - tests: Collect script output as binary, collect systemd journal, fix lxd.
    - HACKING.rst: mention setting user name and email via git config.
    - Azure VM Preprovisioning support. [Douglas Jordan]
    - tools/read-version: Fix read-version when in a git worktree.
    - docs: Fix typos in docs and one debug message. [Florian Grignon]
    - btrfs: support resizing if root is mounted ro. [Robert Schweikert]
    - OpenNebula: Improve network configuration support. [Akihiko Ota]
    - tests: Fix EC2 Platform to return console output as bytes.
    - tests: Fix attempted use of /run in a test case.
    - GCE: Improvements and changes to ssh key behavior for default user.
      [Max Illfelder]
    - subp: make ProcessExecutionError have expected types in stderr, stdout.
    - tests: when querying ntp server, do not do dns resolution.
    - Recognize uppercase vfat disk labels [James Penick]
    - tests: remove zesty as supported OS to test
    - Do not log warning on config files that represent None.
    - tests: Use git hash pip dependency format for pylxd.
    - tests: add integration requirements text file
    - MAAS: add check_instance_id based off oauth tokens.
    - tests: update apt sources list test [Joshua Powers]
    - tests: clean up image properties
    - tests: rename test ssh keys to avoid appearance of leaking private keys.
    - tests: Enable AWS EC2 Integration Testing
    - cli: cloud-init clean handles symlinks
    - SUSE: Add a basic test of network config rendering. [Robert Schweikert]
    - Azure: Only bounce network when necessary.
    - lint: Fix lints seen by pylint version 1.8.1.
    - cli: Fix error in cloud-init modules --mode=init.
    - release 17.2
    - ds-identify: failure in NoCloud due to unset variable usage.
    - tests: fix collect_console when not implemented
    - ec2: Use instance-identity doc for region and instance-id
      [Andrew Jorgensen]
    - tests: remove leaked tmp files in config drive tests.
    - setup.py: Do not include rendered files in SOURCES.txt
    - SUSE: remove delta in systemd local template for SUSE [Robert Schweikert]
    - tests: move to using tox 1.7.5
    - OVF: improve ds-identify to support finding OVF iso transport.
    - VMware: Support for user provided pre and post-customization scripts
      [Maitreyee Saikia]
    ...

Read more...

Changed in cloud-init (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cloud-init has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Chad Smith (chad.smith) wrote :

Regression discovered on GCE please hold xenial publish of cloud-init if possible.
https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1752729

Chad Smith (chad.smith) wrote :

We'll publish a cherry pick to xenial and artful that'll have this fix

tags: added: verification-failed-xenial
removed: verification-done-xenial

Hello Chad, or anyone else affected,

Accepted cloud-init into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/17.2-35-gf576b2a2-0ubuntu1~16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
removed: verification-done verification-failed-xenial
Chad Smith (chad.smith) on 2018-03-02
tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 17.2-35-gf576b2a2-0ubuntu1~16.04.2

---------------
cloud-init (17.2-35-gf576b2a2-0ubuntu1~16.04.2) xenial-proposed; urgency=medium

  * cherry-pick 40e7738: GCE: fix reading of user-data that is not
    base64 encoded. (LP: #1752711)

cloud-init (17.2-35-gf576b2a2-0ubuntu1~16.04.1) xenial-proposed; urgency=medium

  * New upstream snapshot. (LP: #1747059)
    - tests: add support for logs with lxd from snap and future lxd 3.
    - EC2: Fix get_instance_id called against cached datasource pickle.
    - cli: fix cloud-init status to report running when before result.json
    - net: accept network-config in netplan format for renaming interfaces
    - Fix ssh keys validation in ssh_util [Tatiana Kholkina]

 -- Chad Smith <email address hidden> Thu, 01 Mar 2018 16:05:39 -0700

Changed in cloud-init (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers