cloud-init depends on ifupdown, holding it in the artful images

Bug #1705639 reported by Steve Langasek on 2017-07-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init (Ubuntu)
High
Scott Moser

Bug Description

cloud-init in artful has a versioned dependency on ifupdown (>= 0.6.10ubuntu5). This looks like it was probably added to ensure cloud-init had access to the static-network-up upstart event.

That release of ifupdown was included in oneiric, which is EOL. So the versioned dependency can be dropped without negative impact. And cloud-init does not depend on ifupdown functionality in recent Ubuntu releases, and in fact this dependency currently causes ifupdown to be held in the cloud images when we want to drop it.

Please remove the dependency on ifupdown in artful.

Related bugs:
 * bug 1698181: Switch to netplan renderer in Artful

Steve Langasek (vorlon) on 2017-07-21
Changed in cloud-init (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-17.07
Scott Moser (smoser) on 2017-07-21
Changed in cloud-init (Ubuntu):
status: New → In Progress
assignee: nobody → Scott Moser (smoser)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.7.9-221-g7e41b2a7-0ubuntu3

---------------
cloud-init (0.7.9-221-g7e41b2a7-0ubuntu3) artful; urgency=medium

  * debian/control: replace Depends on ifupdown with 'nplan | ifupdown'.
    (LP: #1705639)
  * debian/control: drop versioned dependencies on old packages.

 -- Scott Moser <email address hidden> Fri, 21 Jul 2017 12:32:33 -0400

Changed in cloud-init (Ubuntu):
status: In Progress → Fix Released
Scott Moser (smoser) on 2017-08-01
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers