default user should be in the lxd group

Bug #1539317 reported by Ben Howard on 2016-01-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
Medium
Unassigned
cloud-init (Ubuntu)
Critical
Robert C Jennings

Bug Description

Since LXD is installed by default on the cloud-images, the default user should be put in the lxd group.

Related branches

Robert C Jennings (rcj) wrote :

Requesting this for 16.04 and raising priority for visibility.

Changed in cloud-init (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-16.04
Robert C Jennings (rcj) on 2016-03-09
Changed in cloud-init (Ubuntu):
assignee: nobody → Robert C Jennings (rcj)
Scott Moser (smoser) on 2016-03-10
Changed in cloud-init (Ubuntu):
status: New → Confirmed
Robert C Jennings (rcj) wrote :

smoser, I tested this with cloud-init 0.7.7~bzr1176+1179+441~ubuntu16.04.1 from ppa:cloud-init-dev/daily and it added the group for the ubuntu user. I tested with and without LX[CD] installed (installing LXD after the default user and lxd group were created).

Scott Moser (smoser) on 2016-03-10
Changed in cloud-init:
status: New → Fix Committed
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.7.7~bzr1182-0ubuntu1

---------------
cloud-init (0.7.7~bzr1182-0ubuntu1) xenial; urgency=medium

  * New upstream snapshot.
    * systemd changes enforcing intended ordering (cloud-init-local.service
      before networking and cloud-init.service before it comes up).
    * when reading dmidecode data, return found but unset value as "" rather
      than failing to decode that value.
    * add default user to 'lxd' group and create groups when necessary
      (LP: #1539317)
    * No longer run pollinate in seed_random (LP: #1554152)
    * Enable BigStep data source.

 -- Scott Moser <email address hidden> Mon, 14 Mar 2016 09:58:56 -0400

Changed in cloud-init (Ubuntu):
status: Confirmed → Fix Released
Scott Moser (smoser) wrote :

This is fixed in cloud-init 0.7.7

Changed in cloud-init:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers