cloud-init does not have the SmartOS data source as a configuration option

Bug #1398997 reported by Joshua M. Clulow on 2014-12-03
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
Undecided
Unassigned
cloud-init (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
Vivid
Medium
Unassigned
Wily
Medium
Dan Watkins

Bug Description

The generic Ubuntu "*-server-cloudimg-amd64-disk1.img" images available here...

  http://cloud-images.ubuntu.com/utopic/current/

... do not work on a SmartOS hypervisor: they try to detect a datasource, but ultimately fail. It appears that this is because the "SmartOS" datasource is not in the list of datasources to try. This appears to be an oversight, as the "cloud-init" project source includes a fallback configuration for when no configuration is provided by the image:

-----------------------------------
- cloudinit/settings.py
-----------------------------------
CFG_BUILTIN = {
    'datasource_list': [
        'NoCloud',
        'ConfigDrive',
        'OpenNebula',
        'Azure',
        'AltCloud',
        'OVF',
        'MAAS',
        'GCE',
        'OpenStack',
        'Ec2',
        'CloudSigma',
        'CloudStack',
        'SmartOS',
        # At the end to act as a 'catch' when none of the above work...
        'None',
    ],
...
-----------------------------------

This list seems to be overridden in the generic images as shipped on ubuntu.com:

-----------------------------------
- etc/cloud/cloud.cfg.d/90_dpkg.cfg
-----------------------------------
# to update this file, run dpkg-reconfigure cloud-init
datasource_list: [ NoCloud, ConfigDrive, OpenNebula, Azure, AltCloud,OVF, MAAS, GCE, OpenStack, CloudSigma, Ec2, CloudStack, None ]
-----------------------------------

SmartOS is the only datasource type that appears in the default CFG_BUILTIN list but is missing from the overridden list as shipped in the images. Can this list please be updated for at least the 14.04 and 14.10 generic cloud images to include SmartOS?

Thanks.

Changed in ubuntu:
assignee: nobody → Daniel Watkins (daniel-thewatkins)
importance: Undecided → Medium
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1398997/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Dan Watkins (oddbloke) wrote :

It looks like the issue here is that debian/cloud-init.templates was not updated to include the SmartOS data source.

Dan Watkins (oddbloke) on 2014-12-04
affects: ubuntu → cloud-init (Ubuntu)
Dan Watkins (oddbloke) wrote :

The attached patch adds SmartOS to the available data sources, and includes it in the default list.

Dan Watkins (oddbloke) wrote :

This is going to miss vivid, but we'll probably SRU it back in to everything later.

summary: - Ubuntu Cloud images do not work with SmartOS hypervisor
+ cloud-init does not have the SmartOS data source as a configuration
+ option
Scott Moser (smoser) wrote :

The smartOS datasource just never got enabled in ubuntu packaging.
It seems that it should be safe to do so as the datasource checks for existance of the serial device (/dev/ttyS1) and also checks for 'smartdc' in the system-product-name field of dmidecode.

Dan Watkins (oddbloke) on 2015-04-20
Changed in cloud-init (Ubuntu Trusty):
status: New → Confirmed
Scott Moser (smoser) on 2015-04-20
Changed in cloud-init (Ubuntu Trusty):
importance: Undecided → Medium
Dan Watkins (oddbloke) on 2015-04-20
Changed in cloud-init (Ubuntu Vivid):
assignee: Dan Watkins (daniel-thewatkins) → nobody

The attachment "lp1398997.patch" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.7.7~bzr1127-0ubuntu1

---------------
cloud-init (0.7.7~bzr1127-0ubuntu1) wily; urgency=medium

  [ Scott Moser ]
  * d/README.source, debian/cherry-pick-rev: improve packaging tool

  [ Daniel Watkins ]
  * d/cloud-init.templates: Include SmartOS data source in the default list
    and choices. (LP: #1398997)

  [ Scott Moser ]
  * New upstream snapshot.
    * check for systemd using sd_booted symantics (LP: #1461201)
    * fix importing of gpg keys in python3 (LP: #1463373)
    * fix specification of devices to growpart (LP: #1465436)
    * reliably detect and use Azure disks using udev rules (LP: #1411582)
    * support selection of Ubuntu mirrors on GCE (LP: #1470890)
    * ssh: generate ed25519 host keys if supported (LP: #1461242)
    * test fixes and cleanups
    * fix reading of availability-zone on GCE (LP: #1470880)
    * fix cloudsigma datasource with python3 (LP: #1475215)
    * fix rightscale user-data
    * fix consumption of CloudStack passwords on newer CloudStack platforms
      (LP: #1440263, #1464253)

 -- Scott Moser <email address hidden> Wed, 22 Jul 2015 17:06:18 -0400

Changed in cloud-init (Ubuntu Wily):
status: Confirmed → Fix Released
Michael Terry (mterry) wrote :

I've uploaded Dan's patch to trusty and vivid. Thanks!

Hello Joshua, or anyone else affected,

Accepted cloud-init into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/0.7.5-0ubuntu1.9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cloud-init (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in cloud-init (Ubuntu Vivid):
status: Confirmed → Fix Committed
Chris J Arges (arges) wrote :

Hello Joshua, or anyone else affected,

Accepted cloud-init into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/0.7.7~bzr1091-0ubuntu6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Performed the verification steps. This is good to go.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.7.5-0ubuntu1.10

---------------
cloud-init (0.7.5-0ubuntu1.10) trusty; urgency=medium

  [ Daniel Watkins ]
  * d/patches/lp-1490796-azure-fix-mount_cb-for-symlinks.patch:
      - Fix a regression caused by switching to /dev/disk symlinks
        (LP: #1490796).

 -- Ben Howard <email address hidden> Wed, 02 Sep 2015 10:57:30 -0600

Changed in cloud-init (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.7.7~bzr1091-0ubuntu7

---------------
cloud-init (0.7.7~bzr1091-0ubuntu7) vivid; urgency=medium

  [ Daniel Waktins ]
  * d/patches/lp-1490796-azure-fix-mount_cb-for-symlinks.patch:
      - Fix a regression caused by switching to /dev/disk symlinks
        (LP: #1490796).

 -- Ben Howard <email address hidden> Wed, 02 Sep 2015 11:18:30 -0600

Changed in cloud-init (Ubuntu Vivid):
status: Fix Committed → Fix Released
Dan Watkins (oddbloke) on 2015-11-09
Changed in cloud-init:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers