ephemeral disk formating fails on Windows Azure

Bug #1233698 reported by Ben Howard on 2013-10-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init (Ubuntu)
Undecided
Unassigned

Bug Description

Disk formating for Windows Azure fails to find the approprate device.

Oct 1 14:11:25 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: updated disk_setup device entry 'ephemeral0' to '/dev/sdb'
Oct 1 14:11:25 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: Partitioning disks: {'/dev/sdb': {'_origname': 'ephemeral0', 'table_type': 'mbr', 'layout': True, 'overwrite': False}}
Oct 1 14:11:25 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: Creating new partition table/disk
Oct 1 14:11:25 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: Checking values for /dev/sdb definition
Oct 1 14:11:25 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: Checking against default devices
Oct 1 14:11:25 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: Checking if device /dev/sdb is a valid device
Oct 1 14:11:25 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: Checking if device layout matches
Oct 1 14:11:26 utl-1001-s1 [CLOUDINIT] util.py[DEBUG]: Running command ['/sbin/sfdisk', '-l', '/dev/sdb'] with allowed return codes [0] (shell=False, capture=True)
Oct 1 14:11:26 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: Device partitioning layout matches
Oct 1 14:11:26 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: setting up filesystems: [{'device': 'ephemeral0', 'partition': 'auto', 'filesystem': 'ext4'}]
Oct 1 14:11:26 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: Creating new filesystem.
Oct 1 14:11:26 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: Checking /dev/sdb against default devices
Oct 1 14:11:26 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: Identifying device to create None filesytem on
Oct 1 14:11:26 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[WARNING]: Failed to find device during available device search.
Oct 1 14:11:26 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: Automatic device for /dev/sdb identified as None
Oct 1 14:11:26 utl-1001-s1 [CLOUDINIT] cc_disk_setup.py[DEBUG]: No device aviable that matches request. Skipping fs creation for {'device': '/dev/sdb', '_origname': 'ephemeral0', 'partition': 'auto', 'filesystem': 'ext4'}

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: cloud-init 0.7.3~bzr879-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-9.16-generic 3.11.2
Uname: Linux 3.11.0-9-generic x86_64
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
Date: Tue Oct 1 14:15:10 2013
MarkForUpload: True
PackageArchitecture: all
SourcePackage: cloud-init
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Oh, this is interesting:
root@utl-1001-s1:/var/log# blkid
/dev/sr0: LABEL="rd_rdfe_stable.130925-1043" TYPE="udf"
/dev/sda1: LABEL="cloudimg-rootfs" UUID="3fc25dc0-ee46-4799-a693-377074d2b73e" TYPE="ext4"
/dev/sdb1: LABEL="Temporary Storage" UUID="6A84F7F884F7C49B" TYPE="ntfs"

So the problem here is that is that the configuration is wrong, since the ephemeral storage on Windows Azure is pre-seeded with an NTFS filesystem.

Patched cloud-init to deal with this effectively by adding the ability for cloud-init to remove existing parititions and changed the Azure configuration to delete the existing partitions on the ephemeral device.

Tangential to the issue at hand, but I added a regression check to make sure that the appropriate mount is mount in the Windows Azure test suite.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 0.7.3~bzr884-0ubuntu1

---------------
cloud-init (0.7.3~bzr884-0ubuntu1) saucy; urgency=low

  * New upstream snapshot.
    * allow disabling of growpart via file /etc/growroot-disabled
      (LP: #1234331)
    * add default user to sudo group (LP: #1228228)
    * fix disk creation on azure (LP: #1233698)
    * DatasourceSmartOS: allow availabiltity-zone to be fed from the
      datasource via 'region' (which allows 'mirrors' and other things
      to make use of it).
 -- Scott Moser <email address hidden> Fri, 04 Oct 2013 21:08:07 -0400

Changed in cloud-init (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers