Cannot install closure-compiler in a trusty container

Bug #1497836 reported by Anders Kaseorg on 2015-09-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
closure-compiler (Debian)
Fix Released
Unknown
closure-compiler (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned

Bug Description

[Impact]

The libclosure-compiler-java package in trusty (20130227+dfsg1-4) cannot be installed within a container due to a dependency on jarwrapper,

Setting up jarwrapper (0.45ubuntu1) ...
update-binfmts: warning: unable to open /proc/sys/fs/binfmt_misc/status for writing: Permission denied
update-binfmts: warning: unable to open /proc/sys/fs/binfmt_misc/register for writing: Permission denied
update-binfmts: warning: unable to enable binary format jarwrapper
update-binfmts: exiting due to previous errors
dpkg: error processing package jarwrapper (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of libclosure-compiler-java:
 libclosure-compiler-java depends on jarwrapper; however:
  Package jarwrapper is not configured yet.

dpkg: error processing package libclosure-compiler-java (--configure):
 dependency problems - leaving unconfigured

This was fixed in the next Debian release (20130227+dfsg1-5) by replacing the “clever” symlink /usr/bin/closure-compiler -> /usr/share/java/closure-compiler.jar (relying on the kernel’s binfmt_misc functionality) with a wrapper script that invokes /usr/bin/java explicitly. In fact, the necessary wrapper script is already present in the source package; it need only be installed.

[Test Case]

‘apt-get install libclosure-compiler-java’ inside a trusty LXC container.

[Regression Potential]

If the user had modified the binfmt_misc configuration for jar files from the one provided by jarwrapper, the wrapper script might run closure-compiler under a different JRE than binfmt_misc. Even if so, this seems unlikely to be a problem.

Luke Faraone (lfaraone) on 2015-09-22
Changed in closure-compiler (Ubuntu):
milestone: none → trusty-updates
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in closure-compiler (Ubuntu):
status: New → Confirmed
Luke Faraone (lfaraone) on 2015-09-23
Changed in closure-compiler (Ubuntu):
status: Confirmed → Fix Released
Changed in closure-compiler (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Medium
Luke Faraone (lfaraone) on 2015-09-23
Changed in closure-compiler (Ubuntu):
status: Fix Released → In Progress
assignee: nobody → Luke Faraone (lfaraone)
status: In Progress → Fix Released
assignee: Luke Faraone (lfaraone) → nobody
Changed in closure-compiler (Ubuntu Trusty):
status: Triaged → In Progress
assignee: nobody → Luke Faraone (lfaraone)
Luke Faraone (lfaraone) on 2015-09-23
Changed in closure-compiler (Ubuntu Trusty):
assignee: Luke Faraone (lfaraone) → nobody
Changed in closure-compiler (Debian):
status: Unknown → Fix Released

Hello Anders, or anyone else affected,

Accepted closure-compiler into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/closure-compiler/20130227+dfsg1-4ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in closure-compiler (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Anders Kaseorg (andersk) wrote :

20130227+dfsg1-4ubuntu0.1 in trusty-proposed works for me.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package closure-compiler - 20130227+dfsg1-4ubuntu0.1

---------------
closure-compiler (20130227+dfsg1-4ubuntu0.1) trusty-proposed; urgency=medium

  [ tony mancill ]
  * Drop dependency on jarwrapper in favor of a simple wrapper script.
    (Closes: #743707, #734011) (LP: #1497836)

 -- Anders Kaseorg <email address hidden> Mon, 21 Sep 2015 01:41:13 -0400

Changed in closure-compiler (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for closure-compiler has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in closure-compiler (Ubuntu):
importance: Undecided → Medium
Changed in closure-compiler (Ubuntu Trusty):
milestone: none → trusty-updates
Changed in closure-compiler (Ubuntu):
milestone: trusty-updates → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.