Clonezilla - “Box” is an unknown partition device

Bug #1294854 reported by Sasa Stamenkovic
This bug affects 1 person
Affects Status Importance Assigned to Milestone
clonezilla (Ubuntu)
Georges Khaznadar

Bug Description

I get this error when trying to save disk image with clonezilla

After this, I don't get my SSD disk listed (one I want to image), just external HDD (on which I want to backup image)

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: clonezilla 3.4.9-1
ProcVersionSignature: Ubuntu 3.11.0-18.32-generic
Uname: Linux 3.11.0-18-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
Date: Wed Mar 19 21:44:29 2014
InstallationDate: Installed on 2013-09-29 (171 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: clonezilla
UpgradeStatus: Upgraded to saucy on 2013-12-31 (78 days ago)

Revision history for this message
Sasa Stamenkovic (umpirsky) wrote :
Revision history for this message
Georges Khaznadar (georgesk) wrote :

I cannot reproduce this bug

Changed in clonezilla (Ubuntu):
assignee: nobody → Georges Khaznadar (georgesk)
status: New → Incomplete
Revision history for this message
Dweia (dweia) wrote :

Got the error today for the first time (admittedly not from Ubuntu, but from PartedMagic 2015-03-06)

Anyways, I got it reproduced, AND it's (at least in my case) a not-bug.

Steps to reproduce:
- ATA Secure Erase an SSD
- Start Clonezilla without restarting the computer first and without updating the in-kernel partition-list
- The message appears: "Box" is an unknown partition device

Steps to AVOID the message:
- ATA Secure Erase an SSD
- execute "sudo partprobe"
     (notice that the information in /proc/partitions STILL contains the no-longer-existing partitions on the just erased device)
     (think it might be a bug in partprobe? shouldn't that delete non-existing partitions as well as register new ones?)
- use gparted or fdisk to create (at least) an empty partition-table on the device
     (confirm that cat /proc/partitions now shows /dev/sda without any partitions)
- start clonezilla again
    (notice that while the above error-message doesn't appear, clonezilla doesn't see my external harddisk - although I CAN mount the partitions manually *sigh*)
- restart the computer (again with Parted Magic)
- Start Clonezilla again - and notice, the external harddisk STILL doesn't appear....
- give up with PartedMagic and reboot to Clonezilla Live (2.4.2-something)
- finally be able to restore the image

OK, apologies for the lengthy "write as I go" procedure - obviously the middle few steps can be eliminated as they don't work. The main point was: the original "bug" isn't a bug, at least not in clonezilla and not how I used it.

And yes, I did notice that the original submitter said, he wanted to image FROM an SSD, and not TO an SSD, so it might be unrelated after all, however in my case at least, it was easy to circumvent the error-message.


Revision history for this message
Sean (ingorx) wrote :

Reproduced and solved!! (for me anyway...)

So this is WAY old and probably of little use to anyone anymore, but I just ran into this same issue and was able to resolve it. I get the "box" error any time I tried adding the usb devices after boot. It says you can add them, then wait 5 minutes and press enter. If I add them during that time I get the "box" error. If I boot the computer with all devices already attached then I don't.

Reproduced it on 2 different machines using 3 different connections (directly connected to hard drive, and then two different sata to usb brands). I also reproduced the error whether it was SSD or HHD. This was the only variable. Make sure all devices are already attached when booting if you're getting this error.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.