Cannot delete my chroot.

Bug #1346723 reported by XiaoGuo, Liu on 2014-07-22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
click (Ubuntu)
qtcreator-plugin-ubuntu (Ubuntu)

Bug Description

I found that my install chroot did not appear when I tried to manage my kits to add the build for it. The started to delete it. However, I found that I could not delete it, and it gave me the error.

Related branches

XiaoGuo, Liu (liu-xiao-guo) wrote :
XiaoGuo, Liu (liu-xiao-guo) wrote :
XiaoGuo, Liu (liu-xiao-guo) wrote :

The click-ubuntu-sdk-14.10-armhf directory is there, but it is not listed in the "Manage Kits..."

XiaoGuo, Liu (liu-xiao-guo) wrote :

liuxg@liuxg:/var/lib/schroot/chroots$ sudo rm -rf click-ubuntu-sdk-14.10-armhf/
[sudo] password for liuxg:
rm: cannot remove ‘click-ubuntu-sdk-14.10-armhf/home’: Device or resource busy
rm: cannot remove ‘click-ubuntu-sdk-14.10-armhf/proc’: Device or resource busy
rm: cannot remove ‘click-ubuntu-sdk-14.10-armhf/sys’: Device or resource busy
rm: cannot remove ‘click-ubuntu-sdk-14.10-armhf/dev’: Device or resource busy
rm: cannot remove ‘click-ubuntu-sdk-14.10-armhf/tmp’: Device or resource busy

Zoltan Balogh (bzoltan) on 2014-07-22
affects: qtcreator-plugin-ubuntu → click (Ubuntu)
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

The part that is failing is the umount after the chroot got cleaned. This part is done by the "share/qtcreator/ubuntu/scripts/click_destroy_target" in the qtcreator-plugin-ubuntu tree (see lines 33pp of the script). So I simply reassigning to click without any further explanation does not look correct and I added a qtcreator-plugin-ubuntu task back.

However I think that all the script should have to do is to run "click destory", the fact that it has to do extra lifting is a bug in click IMO so I keep a task for click open.

Zoltan Balogh (bzoltan) wrote :

This problem is fixed in the qtcreator-plugin-ubuntu in the 3.1.1+14.10.20140728.1 version. The backport of this version to Trusty is available in the SDK's Tools Development PPA ( and it will be released after testing and dogfooding.

The problem indeed is that click destroy does not delete the chroots if they have active mount points or the click chroot is severly broken. In this case I think it is perfectly OK to fall back to the file system level solution and lazy unmount the mounts and remove the chroots from the file system.

Changed in qtcreator-plugin-ubuntu (Ubuntu):
status: New → Fix Released
Michael Vogt (mvo) on 2014-08-22
Changed in click:
status: New → Invalid
Changed in click (Ubuntu):
status: New → In Progress
Colin Watson (cjwatson) on 2014-09-29
no longer affects: click
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package click - 0.4.33

click (0.4.33) utopic; urgency=medium

  [ Pete Woods ]
  * Add scope-facing APIs to chroot build (LP: #1370727).

  [ Colin Watson ]
  * Warn that "click install" without a registration may result in later
  * Rearrange garbage-collection to remove versions of packages that have no
    user registrations and are not running, rather than using the artificial
    @gcinuse registration which never really worked properly.
  * Run garbage-collection immediately before running system hooks on system
    startup (LP: #1342858).
  * Add new -n/--name option to "click chroot", defaulting to "click"
    (LP: #1364327).

  [ Michael Vogt ]
  * Make click destroy more robust by unmounting any mounted filesystem
    inside the schroot first (LP: #1346723).
  * Stop apps if necessary when uninstalling them (LP: #1232130).
  * Add new "click framework {info,get-field}" subcommands.
 -- Ubuntu daily release <email address hidden> Mon, 29 Sep 2014 14:18:41 +0000

Changed in click (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers