Uninstalling an app doesn't stop it

Bug #1232130 reported by Loïc Minier on 2013-09-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
click (Ubuntu)
Medium
Michael Vogt
ubuntu-touch-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

Launch an installed app, uninstall it. Not only is it still listed in the list of installed apps (bug #1232129), it's also still in the running app lists, and if you press on the installed app icon or slide right, you get back to the running app.

I think any running instance of this app should be killed along the removal.

Cheers,

Related branches

Loïc Minier (lool) wrote :

Moving this to click + adding a task to seed upstart-app-launch-tools.

affects: unity-scope-click (Ubuntu) → click (Ubuntu)
Loïc Minier (lool) on 2013-09-27
affects: click (Ubuntu) → upstart-app-launch (Ubuntu)
Ted Gould (ted) wrote :

I believe that Click is handling this, so leaving it there.

affects: upstart-app-launch (Ubuntu) → click (Ubuntu)
Vojtech Bocek (vbocek) wrote :

I think this also affects app updates. I did following:

1. Start clock app
2. Go to system settings, updates
3. Install clock app update
4. Clock app is still running, stop it
5. Start clock app

The clock app won't start after this, it just shows white window. I don't have any logs though, because I tried if reboot fixes this (and it does). This happend on image #71 from devel-proposed on hammerhead.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in click (Ubuntu):
status: New → Confirmed
Changed in ubuntu-touch-meta (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

We seeded upstart-app-launch-tools (now ubuntu-app-launch-tools) some time ago.

Changed in ubuntu-touch-meta (Ubuntu):
status: Confirmed → Fix Released
Colin Watson (cjwatson) on 2014-09-29
Changed in click (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package click - 0.4.33

---------------
click (0.4.33) utopic; urgency=medium

  [ Pete Woods ]
  * Add scope-facing APIs to chroot build (LP: #1370727).

  [ Colin Watson ]
  * Warn that "click install" without a registration may result in later
    garbage-collection.
  * Rearrange garbage-collection to remove versions of packages that have no
    user registrations and are not running, rather than using the artificial
    @gcinuse registration which never really worked properly.
  * Run garbage-collection immediately before running system hooks on system
    startup (LP: #1342858).
  * Add new -n/--name option to "click chroot", defaulting to "click"
    (LP: #1364327).

  [ Michael Vogt ]
  * Make click destroy more robust by unmounting any mounted filesystem
    inside the schroot first (LP: #1346723).
  * Stop apps if necessary when uninstalling them (LP: #1232130).
  * Add new "click framework {info,get-field}" subcommands.
 -- Ubuntu daily release <email address hidden> Mon, 29 Sep 2014 14:18:41 +0000

Changed in click (Ubuntu):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

This turns out not to be quite reliable. I should have caught this in review, but I think the problem is that stop_running_app calls get_manifest, which calls get_version; but it does this *after* removing the registration link, so tends to fail. We should probably stop the app before removing the link, or at least get hold of the manifest first.

no longer affects: ubuntu-app-launch (Ubuntu)
Changed in click (Ubuntu):
status: Fix Released → Triaged
Michael Vogt (mvo) wrote :

Thanks Colin and sorry for the trouble.

I looked into this now and reworked the way that the stopping happens. It seems to be reliable now and gets the correct appid that is then passed to app-launch-stop.

However the app still does not stop because ubuntu-app-stop needs to talk to the users session bus. When click runs as root (or via PK) it does not have access to it.

Michael Vogt (mvo) wrote :

I pushed a version that correctly gets the dbus session bus and stops the app for click unregister in lp:~mvo/click/lp1232130-kill-on-remove-2/ - however its not yet working under PK I'm looking into this now.

Michael Vogt (mvo) on 2014-10-09
Changed in click (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package click - 0.4.38.4

---------------
click (0.4.38.4) vivid; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/click/lp1232130-kill-on-remove-2:
    - When uninstalling a app, stop it if its running (LP: #1232130)
  * lp:~mvo/click/dont-crash-for-empty-db:
    - Do not crash when no database configuration is used and
      Click.DB.{get,props.overlay,gc,ensure_ownership} are called.
  * lp:~mvo/click/lp1219912-build-exclude:
    - add a new --ignore option to click {build,buildsource}
      (LP: #1219912)
  * lp:~mvo/click/fix-multiple-framework-validation:
    - fix framework validation for snappy
  * run debian/packagekit-check with "sh" as something in jenkins
    made it mode 0644

  [ CI Train Bot ]
  * New rebuild forced.
 -- CI Train Bot <email address hidden> Thu, 26 Feb 2015 17:07:09 +0000

Changed in click (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers