rename of click-reviewers LP group broke fetch of apparmor json

Bug #1608943 reported by Jamie Strandboge on 2016-08-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical Click Reviewers tools
High
Jamie Strandboge
click-reviewers-tools (Ubuntu)
High
Jamie Strandboge
Xenial
High
Jamie Strandboge
Yakkety
High
Jamie Strandboge

Bug Description

[Impact]
Users running click-review for the first time will encounter a traceback and existing users will not fetch new versions of the apparmor json.

[Test Case]
$ rm -f ~/.cache/click-reviewers-tools/apparmor-easyprof-ubuntu.json
$ click-review ./rottentomatoes.jdstrand_0.11.3_all.click
./rottentomatoes.jdstrand_0.11.3_all.click: pass

[Regression Potential]
The regression potential is low since the fetching of apparmor is totally broken and causes a traceback.

= Original description =

WARNING:root:Ignoring missing framework "ubuntu-sdk-15.04"
Now executing: click-review ./qsa3.nessita_0.2_all.click
Traceback (most recent call last):
  File "/usr/bin/click-review", line 162, in <module>
    main()
  File "/usr/bin/click-review", line 156, in main
    results.run_all_checks(overrides)
  File "/usr/bin/click-review", line 110, in run_all_checks
    self._run_module_checks(module, overrides)
  File "/usr/bin/click-review", line 97, in _run_module_checks
    review.do_checks()
  File "/usr/lib/python3/dist-packages/clickreviews/common.py", line 384, in do_checks
    func()
  File "/usr/lib/python3/dist-packages/clickreviews/cr_security.py", line 691, in check_policy_groups
    if len(policy_groups) < 1:
TypeError: object of type 'NoneType' has no len()
Successfully built package in './qsa3.nessita_0.2_all.click'.

This is because clickreviews/apparmor_policy.py has a link to ~click-reviewers instead of ~store-reviewers. This is fixed in r694

Changed in click-reviewers-tools:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Jamie Strandboge (jdstrand)
Changed in click-reviewers-tools (Ubuntu Yakkety):
status: Fix Committed → In Progress
Changed in click-reviewers-tools (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Jamie Strandboge (jdstrand)
description: updated
Changed in click-reviewers-tools (Ubuntu Yakkety):
status: In Progress → Fix Committed
Jamie Strandboge (jdstrand) wrote :

Fixed in upstream 0.44.

Changed in click-reviewers-tools:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package click-reviewers-tools - 0.44

---------------
click-reviewers-tools (0.44) yakkety; urgency=medium

  [ Jamie Strandboge ]
  * data/apparmor-easyprof-ubuntu.json:
    - add pulseaudio interface
    - add bluetooth policy group for Touch for 15.04 and higher
    - add location-observe and location-control
    - move all core interfaces to 'common'
    - add gsettings interface
    - set home to auto-approve
    - add mpris interface
    - add camera interface
    - add optical-drive interface
    - add serial-port interface
    - add content interface
  * clickreviews/common.py:
    - don't fail on libmvec.so since it comes from libc6 too (LP: #1584346)
    - extend the regex to also match ld-linux-x86-64.so.2
  * sr_common.py:
    - update _verify_pkgname() and _verify_appname() to use the same regex as
      in snapd and various tests
    - update attributes to be slots or plugs side and cleanup code for
      specifying attributes
  * bin/click-review, clickreviews/modules.py: exit '1' if error with
    init_object or running checks
  * sr_lint.py:
    - support 'environment' key in yaml (LP: #1583259)
    - support 'confinement' key in yaml
  * sr_security.py:
    - specifying mpris slot should not warn
    - adjust profile name length checks to use series 16 security label format
  * run_tests: exit non-zero with failures, errors or unexpectedSuccesses
  * cr_lint.py:
    - 'puritine' is a known, but redflagged hook
    - skip external symlinks and md5sums checks for puritine (since we expect
      external symlinks and the hash checks fail on broken symlinks)
    - 'puritine' hook should not be used with 'apparmor'
  * clickreviews/apparmor_policy.py: adjust for rename of store team
    (LP: #1608943)

  [ Celso Providelo ]
  * support for interface abbreviated syntax (LP: #1595184)

 -- Jamie Strandboge <email address hidden> Tue, 02 Aug 2016 08:23:46 -0500

Changed in click-reviewers-tools (Ubuntu Yakkety):
status: Fix Committed → Fix Released
description: updated
Changed in click-reviewers-tools (Ubuntu Xenial):
status: Triaged → In Progress
Jamie Strandboge (jdstrand) wrote :
description: updated

Hello Jamie, or anyone else affected,

Accepted click-reviewers-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/click-reviewers-tools/0.44~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in click-reviewers-tools (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Wimpress (flexiondotorg) wrote :

I've successfully used click-reviewers-tools (0.44~16.04.1) to build and review a couple of click packages.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package click-reviewers-tools - 0.44~16.04.1

---------------
click-reviewers-tools (0.44~16.04.1) xenial-proposed; urgency=medium

  [ Jamie Strandboge ]
  * data/apparmor-easyprof-ubuntu.json:
    - add pulseaudio interface
    - add bluetooth policy group for Touch for 15.04 and higher
    - add location-observe and location-control
    - move all core interfaces to 'common'
    - add gsettings interface
    - set home to auto-approve
    - add mpris interface
    - add camera interface
    - add optical-drive interface
    - add serial-port interface
    - add content interface
  * clickreviews/common.py:
    - don't fail on libmvec.so since it comes from libc6 too (LP: #1584346)
    - extend the regex to also match ld-linux-x86-64.so.2
  * sr_common.py:
    - update _verify_pkgname() and _verify_appname() to use the same regex as
      in snapd and various tests
    - update attributes to be slots or plugs side and cleanup code for
      specifying attributes
  * bin/click-review, clickreviews/modules.py: exit '1' if error with
    init_object or running checks
  * sr_lint.py:
    - support 'environment' key in yaml (LP: #1583259)
    - support 'confinement' key in yaml
  * sr_security.py:
    - specifying mpris slot should not warn
    - adjust profile name length checks to use series 16 security label format
  * run_tests: exit non-zero with failures, errors or unexpectedSuccesses
  * cr_lint.py:
    - 'puritine' is a known, but redflagged hook
    - skip external symlinks and md5sums checks for puritine (since we expect
      external symlinks and the hash checks fail on broken symlinks)
    - 'puritine' hook should not be used with 'apparmor'
  * clickreviews/apparmor_policy.py: adjust for rename of store team
    (LP: #1608943)

  [ Celso Providelo ]
  * support for interface abbreviated syntax (LP: #1595184)

 -- Jamie Strandboge <email address hidden> Tue, 02 Aug 2016 08:43:31 -0500

Changed in click-reviewers-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for click-reviewers-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers